summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-08-02 07:54:54 +0000
committerMichał Górny <mgorny@gentoo.org>2014-08-02 07:54:54 +0000
commit7972d7f374295e6828a6b96b15169536f8defe1c (patch)
tree34ac8f1be92e3e52a960a7f4f5b454d56dffa928 /sys-boot
parentVersion bump. (diff)
downloadgentoo-2-7972d7f374295e6828a6b96b15169536f8defe1c.tar.gz
gentoo-2-7972d7f374295e6828a6b96b15169536f8defe1c.tar.bz2
gentoo-2-7972d7f374295e6828a6b96b15169536f8defe1c.zip
Introduce gummiboot, the EFI boot manager. Bug #426598. Thanks to Elias Probst and J. García for all the work.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gummiboot/ChangeLog11
-rw-r--r--sys-boot/gummiboot/gummiboot-45.ebuild33
-rw-r--r--sys-boot/gummiboot/gummiboot-9999.ebuild33
-rw-r--r--sys-boot/gummiboot/metadata.xml8
4 files changed, 85 insertions, 0 deletions
diff --git a/sys-boot/gummiboot/ChangeLog b/sys-boot/gummiboot/ChangeLog
new file mode 100644
index 000000000000..aa023a1057c3
--- /dev/null
+++ b/sys-boot/gummiboot/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-boot/gummiboot
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gummiboot/ChangeLog,v 1.1 2014/08/02 07:54:54 mgorny Exp $
+
+*gummiboot-9999 (02 Aug 2014)
+*gummiboot-45 (02 Aug 2014)
+
+ 02 Aug 2014; Michał Górny <mgorny@gentoo.org> +gummiboot-45.ebuild,
+ +gummiboot-9999.ebuild, +metadata.xml:
+ Introduce gummiboot, the EFI boot manager. Bug #426598. Thanks to Elias Probst
+ and J. García for all the work.
diff --git a/sys-boot/gummiboot/gummiboot-45.ebuild b/sys-boot/gummiboot/gummiboot-45.ebuild
new file mode 100644
index 000000000000..48089804b7fd
--- /dev/null
+++ b/sys-boot/gummiboot/gummiboot-45.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gummiboot/gummiboot-45.ebuild,v 1.1 2014/08/02 07:54:54 mgorny Exp $
+
+EAPI=5
+
+inherit autotools eutils linux-info
+
+DESCRIPTION="Minimalistic UEFI bootloader"
+HOMEPAGE="http://freedesktop.org/wiki/Software/gummiboot/"
+SRC_URI="http://cgit.freedesktop.org/${PN}/snapshot/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="sys-apps/util-linux"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ =sys-boot/gnu-efi-3.0s"
+
+pkg_pretend() {
+ # CONFIG_EFI_STUB is required to boot a kernel with gummiboot
+ local CONFIG_CHECK="~EFI_STUB"
+ check_extra_config
+}
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}
diff --git a/sys-boot/gummiboot/gummiboot-9999.ebuild b/sys-boot/gummiboot/gummiboot-9999.ebuild
new file mode 100644
index 000000000000..398ac8a55dbc
--- /dev/null
+++ b/sys-boot/gummiboot/gummiboot-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gummiboot/gummiboot-9999.ebuild,v 1.1 2014/08/02 07:54:54 mgorny Exp $
+
+EAPI=5
+
+inherit autotools eutils linux-info git-r3
+
+DESCRIPTION="Minimalistic UEFI bootloader"
+HOMEPAGE="http://freedesktop.org/wiki/Software/gummiboot/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="sys-apps/util-linux"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ =sys-boot/gnu-efi-3.0s"
+
+pkg_pretend() {
+ # CONFIG_EFI_STUB is required to boot a kernel with gummiboot
+ local CONFIG_CHECK="~EFI_STUB"
+ check_extra_config
+}
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}
diff --git a/sys-boot/gummiboot/metadata.xml b/sys-boot/gummiboot/metadata.xml
new file mode 100644
index 000000000000..5cb9324943ab
--- /dev/null
+++ b/sys-boot/gummiboot/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>