summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-01-29 08:00:12 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-01-29 08:00:12 +0000
commit94199229f93f07428c27a5c9d42e83cc78cc68a5 (patch)
tree8ba13c81c11b38f3edc2a3498b3cd9ce3db75bed /sys-boot
parentdont force -j1 in src_install and drop installing INTERFACE file (diff)
downloadgentoo-2-94199229f93f07428c27a5c9d42e83cc78cc68a5.tar.gz
gentoo-2-94199229f93f07428c27a5c9d42e83cc78cc68a5.tar.bz2
gentoo-2-94199229f93f07428c27a5c9d42e83cc78cc68a5.zip
version bump as per bug #156083
(Portage version: 2.1.2-r2)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/netboot/ChangeLog11
-rw-r--r--sys-boot/netboot/files/digest-netboot-0.10.13
-rw-r--r--sys-boot/netboot/files/digest-netboot-0.9.82
-rw-r--r--sys-boot/netboot/files/netboot-0.10.1-destdir.patch355
-rw-r--r--sys-boot/netboot/files/netboot-0.10.1-nossp.patch44
-rw-r--r--sys-boot/netboot/netboot-0.10.1.ebuild50
6 files changed, 463 insertions, 2 deletions
diff --git a/sys-boot/netboot/ChangeLog b/sys-boot/netboot/ChangeLog
index d04bc580fae1..7a75e69c7a9d 100644
--- a/sys-boot/netboot/ChangeLog
+++ b/sys-boot/netboot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/netboot
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/ChangeLog,v 1.4 2006/12/09 12:08:01 masterdriverz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/ChangeLog,v 1.5 2007/01/29 08:00:12 dragonheart Exp $
+
+*netboot-0.10.1 (29 Jan 2007)
+
+ 29 Jan 2007; Daniel Black <dragonheart@gentoo.org>
+ +files/netboot-0.10.1-destdir.patch, +files/netboot-0.10.1-nossp.patch,
+ +netboot-0.10.1.ebuild:
+ version bump as per bug #156083 patches thanks to me
09 Dec 2006; Charlie Shepherd <masterdriverz@gentoo.org>
netboot-0.9.8.ebuild:
diff --git a/sys-boot/netboot/files/digest-netboot-0.10.1 b/sys-boot/netboot/files/digest-netboot-0.10.1
new file mode 100644
index 000000000000..aa5626672c4d
--- /dev/null
+++ b/sys-boot/netboot/files/digest-netboot-0.10.1
@@ -0,0 +1,3 @@
+MD5 f73a42953ef6b0f60ab258c2f2cfba1c netboot-0.10.1.tar.gz 1406533
+RMD160 c36a3fa9ffb7dad90b6ef5ba62b022ca779f07dd netboot-0.10.1.tar.gz 1406533
+SHA256 743d769ab0e20ce5363f07e711040bf2c9c43985fe05110df61eebbebdf9e565 netboot-0.10.1.tar.gz 1406533
diff --git a/sys-boot/netboot/files/digest-netboot-0.9.8 b/sys-boot/netboot/files/digest-netboot-0.9.8
index f28e0ea23399..485e67759804 100644
--- a/sys-boot/netboot/files/digest-netboot-0.9.8
+++ b/sys-boot/netboot/files/digest-netboot-0.9.8
@@ -1 +1,3 @@
MD5 2c4c83c3d7743b73247e2acdda79919d netboot-0.9.8.tar.gz 966389
+RMD160 32510a3b7070742ef2c40914a1c82317d978e095 netboot-0.9.8.tar.gz 966389
+SHA256 d5e3be89d4e6eef457148e7a9a3061fe04459f719749f4b2bba45ccb496877ba netboot-0.9.8.tar.gz 966389
diff --git a/sys-boot/netboot/files/netboot-0.10.1-destdir.patch b/sys-boot/netboot/files/netboot-0.10.1-destdir.patch
new file mode 100644
index 000000000000..70f6bdd19ecb
--- /dev/null
+++ b/sys-boot/netboot/files/netboot-0.10.1-destdir.patch
@@ -0,0 +1,355 @@
+diff -ru netboot-0.10.1/bootrom/Makefile netboot-0.10.1-installfixed/bootrom/Makefile
+--- netboot-0.10.1/bootrom/Makefile 2006-01-09 00:24:34.000000000 +1100
++++ netboot-0.10.1-installfixed/bootrom/Makefile 2007-01-29 13:56:16.000000000 +1100
+@@ -56,21 +56,21 @@
+ # Install all files in place
+ instbin:
+ @echo Make all necessary directories
+- $(INSTALL) -d $(nbbindir)
+- $(INSTALL) -d $(nbmiscdir)
++ $(INSTALL) -d $(DESTDIR)$(nbbindir)
++ $(INSTALL) -d $(DESTDIR)$(nbmiscdir)
+ @echo Remove files of old versions
+- @if test -d $(nblibdir)/binaries; then \
+- rm -f $(nblibdir)/binaries/*86.bin; \
+- rm -f $(nblibdir)/binaries/kernelm.bin; \
++ @if test -d $(DESTDIR)$(nblibdir)/binaries; then \
++ rm -f $(DESTDIR)$(nblibdir)/binaries/*86.bin; \
++ rm -f $(DESTDIR)$(nblibdir)/binaries/kernelm.bin; \
+ fi
+ @echo Install new binaries
+ @for i in $(bindestdir)/*.bin; do \
+- echo $(INSTALL_DATA) $$i $(nbbindir); \
+- $(INSTALL_DATA) $$i $(nbbindir); \
++ echo $(INSTALL_DATA) $$i $(DESTDIR)$(nbbindir); \
++ $(INSTALL_DATA) $$i $(DESTDIR)$(nbbindir); \
+ done
+ @for i in $(bindestdir)/*.com; do \
+- echo $(INSTALL_DATA) $$i $(nbmiscdir); \
+- $(INSTALL_DATA) $$i $(nbmiscdir); \
++ echo $(INSTALL_DATA) $$i $(DESTDIR)$(nbmiscdir); \
++ $(INSTALL_DATA) $$i $(DESTDIR)$(nbmiscdir); \
+ done
+
+ install: install-recursive instbin
+diff -ru netboot-0.10.1/bootrom/netdrvr/Makefile netboot-0.10.1-installfixed/bootrom/netdrvr/Makefile
+--- netboot-0.10.1/bootrom/netdrvr/Makefile 2006-07-07 06:54:57.000000000 +1000
++++ netboot-0.10.1-installfixed/bootrom/netdrvr/Makefile 2007-01-29 13:20:51.000000000 +1100
+@@ -55,9 +55,10 @@
+ netdrvr-nognu:
+
+ netdrvr-inst: $(TARGETS)
++ $(INSTALL) -d $(DESTDIR)$(bindestdir)
+ @for i in $^; do \
+ j=`basename $$i`; \
+- $(CPATTR) $$i $(bindestdir)/$$j; \
++ $(CPATTR) $$i $(DESTDIR)$(bindestdir)/$$j; \
+ done
+
+
+diff -ru netboot-0.10.1/bootrom/netdrvr/ndis2/drivers/Makefile netboot-0.10.1-installfixed/bootrom/netdrvr/ndis2/drivers/Makefile
+--- netboot-0.10.1/bootrom/netdrvr/ndis2/drivers/Makefile 2006-01-09 00:24:38.000000000 +1100
++++ netboot-0.10.1-installfixed/bootrom/netdrvr/ndis2/drivers/Makefile 2007-01-29 13:53:39.000000000 +1100
+@@ -53,7 +53,7 @@
+ $(MD5SUMS): $(DRIVERS) | $(INSTDRV) $(MD5PROG)
+ @MD5PROG="$(MD5PROGEXEC)" INSTALL="$(INSTALL)" $(INSTDRV) -u \
+ -t $(MODSUBDIR) -s drivers -v \
+- -n $(ROMDIR)/netdrvr -m $(MD5SUMS) \
++ -n $(DESTDIR)$(ROMDIR)/netdrvr -m $(MD5SUMS) \
+ $(foreach fname,$(DRIVERS),-d $(fname))
+
+
+@@ -64,12 +64,12 @@
+
+ # Installation
+ install: $(DRIVERS) | $(INSTDRV) $(MD5PROG)
+- $(INSTALL) -d $(nbnetdrvdir)
+- $(INSTALL) -d $(nbnetdrvdir)/$(MODSUBDIR)
++ $(INSTALL) -d $(DESTDIR)$(nbnetdrvdir)
++ $(INSTALL) -d $(DESTDIR)$(nbnetdrvdir)/$(MODSUBDIR)
+ @echo Installing network drivers
+ @MD5PROG="$(MD5PROGEXEC)" INSTALL="$(INSTALL)" $(INSTDRV) \
+ -t $(MODSUBDIR) -v \
+- -n $(nbnetdrvdir) -m $(nbnetdrvdir)/MD5SUMS \
++ -n $(DESTDIR)$(nbnetdrvdir) -m $(nbnetdrvdir)/MD5SUMS \
+ $(foreach fname,$(DRIVERS),-d $(fname))
+
+
+diff -ru netboot-0.10.1/bootrom/netdrvr/pktdrvr/drivers/Makefile netboot-0.10.1-installfixed/bootrom/netdrvr/pktdrvr/drivers/Makefile
+--- netboot-0.10.1/bootrom/netdrvr/pktdrvr/drivers/Makefile 2006-01-09 00:24:38.000000000 +1100
++++ netboot-0.10.1-installfixed/bootrom/netdrvr/pktdrvr/drivers/Makefile 2007-01-29 13:48:10.000000000 +1100
+@@ -53,7 +53,7 @@
+ $(MD5SUMS): $(DRIVERS) | $(INSTDRV) $(MD5PROG)
+ @MD5PROG="$(MD5PROGEXEC)" INSTALL="$(INSTALL)" $(INSTDRV) -u \
+ -t $(MODSUBDIR) -s drivers -v \
+- -n $(ROMDIR)/netdrvr -m $(MD5SUMS) \
++ -n $(DESTDIR)$(ROMDIR)/netdrvr -m $(MD5SUMS) \
+ $(foreach fname,$(DRIVERS),-d $(fname))
+
+
+@@ -64,12 +64,12 @@
+
+ # Installation
+ install: $(DRIVERS) | $(INSTDRV) $(MD5PROG)
+- $(INSTALL) -d $(nbnetdrvdir)
+- $(INSTALL) -d $(nbnetdrvdir)/$(MODSUBDIR)
++ $(INSTALL) -d $(DESTDIR)$(nbnetdrvdir)
++ $(INSTALL) -d $(DESTDIR)$(nbnetdrvdir)/$(MODSUBDIR)
+ @echo Installing network drivers
+ @MD5PROG="$(MD5PROGEXEC)" INSTALL="$(INSTALL)" $(INSTDRV) \
+ -t $(MODSUBDIR) -v \
+- -n $(nbnetdrvdir) -m $(nbnetdrvdir)/MD5SUMS \
++ -n $(DESTDIR)$(nbnetdrvdir) -m $(DESTDIR)$(nbnetdrvdir)/MD5SUMS \
+ $(foreach fname,$(DRIVERS),-d $(fname))
+
+
+diff -ru netboot-0.10.1/bootrom/netdrvr/undi/drivers/Makefile netboot-0.10.1-installfixed/bootrom/netdrvr/undi/drivers/Makefile
+--- netboot-0.10.1/bootrom/netdrvr/undi/drivers/Makefile 2006-01-09 00:24:39.000000000 +1100
++++ netboot-0.10.1-installfixed/bootrom/netdrvr/undi/drivers/Makefile 2007-01-29 13:54:34.000000000 +1100
+@@ -53,7 +53,7 @@
+ $(MD5SUMS): $(DRIVERS) | $(INSTDRV) $(MD5PROG)
+ @MD5PROG="$(MD5PROGEXEC)" INSTALL="$(INSTALL)" $(INSTDRV) -u \
+ -t $(MODSUBDIR) -s drivers -v \
+- -n $(ROMDIR)/netdrvr -m $(MD5SUMS) \
++ -n $(DESTDIR)$(ROMDIR)/netdrvr -m $(MD5SUMS) \
+ $(foreach fname,$(DRIVERS),-d $(fname))
+
+
+@@ -64,12 +64,12 @@
+
+ # Installation
+ install: $(DRIVERS) | $(INSTDRV) $(MD5PROG)
+- $(INSTALL) -d $(nbnetdrvdir)
+- $(INSTALL) -d $(nbnetdrvdir)/$(MODSUBDIR)
++ $(INSTALL) -d $(DESTDIR)$(nbnetdrvdir)
++ $(INSTALL) -d $(DESTDIR)$(nbnetdrvdir)/$(MODSUBDIR)
+ @echo Installing network drivers
+ @MD5PROG="$(MD5PROGEXEC)" INSTALL="$(INSTALL)" $(INSTDRV) \
+ -t $(MODSUBDIR) -v \
+- -n $(nbnetdrvdir) -m $(nbnetdrvdir)/MD5SUMS \
++ -n $(DESTDIR)$(nbnetdrvdir) -m $(nbnetdrvdir)/MD5SUMS \
+ $(foreach fname,$(DRIVERS),-d $(fname))
+
+
+diff -ru netboot-0.10.1/include/Makefile netboot-0.10.1-installfixed/include/Makefile
+--- netboot-0.10.1/include/Makefile 2006-01-09 00:24:40.000000000 +1100
++++ netboot-0.10.1-installfixed/include/Makefile 2007-01-29 13:20:51.000000000 +1100
+@@ -30,8 +30,8 @@
+
+
+ install: nblib.h
+- $(INSTALL) -d $(includedir)
+- $(INSTALL_DATA) nblib.h $(includedir)/nblib.h
++ $(INSTALL) -d $(DESTDIR)$(includedir)
++ $(INSTALL_DATA) nblib.h $(DESTDIR)$(includedir)/nblib.h
+
+
+ clean:
+diff -ru netboot-0.10.1/makerom/Makefile netboot-0.10.1-installfixed/makerom/Makefile
+--- netboot-0.10.1/makerom/Makefile 2006-07-07 06:54:57.000000000 +1000
++++ netboot-0.10.1-installfixed/makerom/Makefile 2007-01-29 13:20:51.000000000 +1100
+@@ -104,13 +104,13 @@
+ distrib: stamp-flash-gnu
+
+ install: $(LIBTOOL) all
+- $(INSTALL) -d $(bindir)
+- $(INSTALL) -d $(mandir)/man$(MANEXT)
+- $(INSTALL) -d $(nbdatadir)
++ $(INSTALL) -d $(DESTDIR)$(bindir)
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man$(MANEXT)
++ $(INSTALL) -d $(DESTDIR)$(nbdatadir)
+ @$(LIBTOOL) --mode=install \
+- $(INSTALL_PROGRAM) makerom $(bindir)/$(TARGET)
+- $(INSTALL_DATA) makerom.man $(mandir)/man$(MANEXT)/$(TARGET).$(MANEXT)
+- $(INSTALL_DATA) makerom.help $(nbdatadir)/makerom.help
++ $(INSTALL_PROGRAM) makerom $(DESTDIR)$(bindir)/$(TARGET)
++ $(INSTALL_DATA) makerom.man $(DESTDIR)$(mandir)/man$(MANEXT)/$(TARGET).$(MANEXT)
++ $(INSTALL_DATA) makerom.help $(DESTDIR)$(nbdatadir)/makerom.help
+
+
+ clean: clean-local clean-recursive
+diff -ru netboot-0.10.1/misc/Makefile netboot-0.10.1-installfixed/misc/Makefile
+--- netboot-0.10.1/misc/Makefile 2006-01-09 00:24:48.000000000 +1100
++++ netboot-0.10.1-installfixed/misc/Makefile 2007-01-29 13:20:50.000000000 +1100
+@@ -130,27 +130,27 @@
+
+
+ install-config: $(nbconfig)
+- $(INSTALL) -d $(sysconfdir)
+- $(INSTALL_DATA) $(nbconfig) $(sysconfdir)/$(nbconfig)
++ $(INSTALL) -d $(DESTDIR)$(sysconfdir)
++ $(INSTALL_DATA) $(nbconfig) $(DESTDIR)$(sysconfdir)/$(nbconfig)
+
+
+ install-drivers: $(drivers)
+- $(INSTALL) -d $(nblibdir)
+- $(INSTALL_DATA) $(drivers) $(nblibdir)/$(drivers)
++ $(INSTALL) -d $(DESTDIR)$(nblibdir)
++ $(INSTALL_DATA) $(drivers) $(DESTDIR)$(nblibdir)/$(drivers)
+
+
+ install-man: netboot.man $(nbconfig).man $(drivers).man $(db).man
+- $(INSTALL) -d $(mandir)/man$(MANEXT)
+- $(INSTALL_DATA) netboot.man $(mandir)/man$(MANEXT)/netboot.$(MANEXT)
+- $(INSTALL_DATA) $(nbconfig).man $(mandir)/man$(MANEXT)/$(nbconfig).$(MANEXT)
+- $(INSTALL_DATA) $(drivers).man $(mandir)/man$(MANEXT)/$(drivers).$(MANEXT)
+- $(INSTALL_DATA) $(db).man $(mandir)/man$(MANEXT)/$(db).$(MANEXT)
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man$(MANEXT)
++ $(INSTALL_DATA) netboot.man $(DESTDIR)$(mandir)/man$(MANEXT)/netboot.$(MANEXT)
++ $(INSTALL_DATA) $(nbconfig).man $(DESTDIR)$(mandir)/man$(MANEXT)/$(nbconfig).$(MANEXT)
++ $(INSTALL_DATA) $(drivers).man $(DESTDIR)$(mandir)/man$(MANEXT)/$(drivers).$(MANEXT)
++ $(INSTALL_DATA) $(db).man $(DESTDIR)$(mandir)/man$(MANEXT)/$(db).$(MANEXT)
+
+
+ install-utils: instdrv nbmd5
+- $(INSTALL) -d $(nbutildir)
+- $(INSTALL_SCRIPT) instdrv $(nbutildir)/instdrv
+- @$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) nbmd5 $(nbutildir)/nbmd5
++ $(INSTALL) -d $(DESTDIR)$(nbutildir)
++ $(INSTALL_SCRIPT) instdrv $(DESTDIR)$(nbutildir)/instdrv
++ @$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) nbmd5 $(DESTDIR)$(nbutildir)/nbmd5
+
+
+ clean: clean-general clean-recursive
+diff -ru netboot-0.10.1/misc/instdrv.in netboot-0.10.1-installfixed/misc/instdrv.in
+--- netboot-0.10.1/misc/instdrv.in 2005-02-28 07:27:54.000000000 +1100
++++ netboot-0.10.1-installfixed/misc/instdrv.in 2007-01-29 13:49:45.000000000 +1100
+@@ -497,21 +497,21 @@
+ # its final destination.
+
+ if [ "$DOINSTALL" = "TRUE" ]; then
+- DESTDIR="${NETDRVDIR}/${dname}"
++ DDIR="${NETDRVDIR}/${dname}"
+ if [ "$VERBOSE" -gt 0 ]; then
+- echo "Installing $sname into $DESTDIR"
++ echo "Installing $sname into $DDIR"
+ fi
+- if [ ! -d "$DESTDIR" ]; then
++ if [ ! -d "$DDIR" ]; then
+ if [ "$DEBUG" = "TRUE" ]; then
+- echo "$INSTPROG -d $DESTDIR"
++ echo "$INSTPROG -d $DDIR"
+ else
+- $INSTPROG -d $DESTDIR
++ $INSTPROG -d $DDIR
+ fi
+ fi
+ if [ "$DEBUG" = "TRUE" ]; then
+- echo "$INSTPROG -m 644 $sname $DESTDIR/$fname"
++ echo "$INSTPROG -m 644 $sname $DDIR/$fname"
+ else
+- $INSTPROG -m 644 $sname $DESTDIR/$fname
++ $INSTPROG -m 644 $sname $DDIR/$fname
+ fi
+ fi
+ done <$TMPSRC 5>>$TMPMD5
+diff -ru netboot-0.10.1/misc/romcheck/Makefile netboot-0.10.1-installfixed/misc/romcheck/Makefile
+--- netboot-0.10.1/misc/romcheck/Makefile 2006-01-09 00:24:49.000000000 +1100
++++ netboot-0.10.1-installfixed/misc/romcheck/Makefile 2007-01-29 13:20:50.000000000 +1100
+@@ -70,8 +70,8 @@
+
+ # Install
+ install: romcheck-$(GNU16BIT)
+- $(INSTALL) -d $(nbmiscdir)
+- $(INSTALL_DATA) romcheck.bin $(nbmiscdir)/romcheck.bin
++ $(INSTALL) -d $(DESTDIR)$(nbmiscdir)
++ $(INSTALL_DATA) romcheck.bin $(DESTDIR)$(nbmiscdir)/romcheck.bin
+
+
+ # Clean up
+diff -ru netboot-0.10.1/mknbi-dos/Makefile netboot-0.10.1-installfixed/mknbi-dos/Makefile
+--- netboot-0.10.1/mknbi-dos/Makefile 2006-07-07 06:54:57.000000000 +1000
++++ netboot-0.10.1-installfixed/mknbi-dos/Makefile 2007-01-29 13:20:51.000000000 +1100
+@@ -133,11 +133,11 @@
+
+
+ install: $(LIBTOOL) all
+- $(INSTALL) -d $(bindir)
+- $(INSTALL) -d $(mandir)/man$(MANEXT)
++ $(INSTALL) -d $(DESTDIR)$(bindir)
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man$(MANEXT)
+ @$(LIBTOOL) --mode=install \
+- $(INSTALL_PROGRAM) mknbi $(bindir)/$(TARGET)
+- $(INSTALL_DATA) mknbi.man $(mandir)/man$(MANEXT)/$(TARGET).$(MANEXT)
++ $(INSTALL_PROGRAM) mknbi $(DESTDIR)$(bindir)/$(TARGET)
++ $(INSTALL_DATA) mknbi.man $(DESTDIR)$(mandir)/man$(MANEXT)/$(TARGET).$(MANEXT)
+ @echo making install in utils
+ @(cd utils && $(MAKE) install) || exit 1
+
+diff -ru netboot-0.10.1/mknbi-dos/utils/Makefile netboot-0.10.1-installfixed/mknbi-dos/utils/Makefile
+--- netboot-0.10.1/mknbi-dos/utils/Makefile 2006-01-09 00:24:51.000000000 +1100
++++ netboot-0.10.1-installfixed/mknbi-dos/utils/Makefile 2007-01-29 13:20:51.000000000 +1100
+@@ -79,11 +79,11 @@
+
+ # Install
+ install: tools
+- $(INSTALL) -d $(nbmiscdir)
+- $(INSTALL) -d $(nbutildir)
+- $(INSTALL_DATA) rmrd.com $(nbmiscdir)/rmrd.com
+- $(INSTALL_DATA) nbramdrv.sys $(nbmiscdir)/nbramdrv.sys
+- $(INSTALL_SCRIPT) mntnbi.pl $(nbutildir)/mntnbi.pl
++ $(INSTALL) -d $(DESTDIR)$(nbmiscdir)
++ $(INSTALL) -d $(DESTDIR)$(nbutildir)
++ $(INSTALL_DATA) rmrd.com $(DESTDIR)$(nbmiscdir)/rmrd.com
++ $(INSTALL_DATA) nbramdrv.sys $(DESTDIR)$(nbmiscdir)/nbramdrv.sys
++ $(INSTALL_SCRIPT) mntnbi.pl $(DESTDIR)$(nbutildir)/mntnbi.pl
+
+
+ # Clean up
+diff -ru netboot-0.10.1/mknbi-linux/Makefile netboot-0.10.1-installfixed/mknbi-linux/Makefile
+--- netboot-0.10.1/mknbi-linux/Makefile 2006-07-07 06:54:58.000000000 +1000
++++ netboot-0.10.1-installfixed/mknbi-linux/Makefile 2007-01-29 13:20:51.000000000 +1100
+@@ -104,11 +104,11 @@
+ distrib: stamp-first-gnu stamp-firstd-gnu
+
+ install: $(LIBTOOL) all
+- $(INSTALL) -d $(bindir)
+- $(INSTALL) -d $(mandir)/man$(MANEXT)
++ $(INSTALL) -d $(DESTDIR)$(bindir)
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man$(MANEXT)
+ @$(LIBTOOL) --mode=install \
+- $(INSTALL_PROGRAM) mknbi $(bindir)/$(TARGET)
+- $(INSTALL_DATA) mknbi.man $(mandir)/man$(MANEXT)/$(TARGET).$(MANEXT)
++ $(INSTALL_PROGRAM) mknbi $(DESTDIR)$(bindir)/$(TARGET)
++ $(INSTALL_DATA) mknbi.man $(DESTDIR)$(mandir)/man$(MANEXT)/$(TARGET).$(MANEXT)
+
+
+ clean: clean-local clean-recursive
+diff -ru netboot-0.10.1/mknbi-mgl/Makefile netboot-0.10.1-installfixed/mknbi-mgl/Makefile
+--- netboot-0.10.1/mknbi-mgl/Makefile 2006-07-07 06:54:58.000000000 +1000
++++ netboot-0.10.1-installfixed/mknbi-mgl/Makefile 2007-01-29 13:20:51.000000000 +1100
+@@ -197,13 +197,13 @@
+ $(DISTSRCS)
+
+ install: $(LIBTOOL) all
+- $(INSTALL) -d $(bindir)
+- $(INSTALL) -d $(mandir)/man$(MANEXT)
++ $(INSTALL) -d $(DESTDIR)$(bindir)
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man$(MANEXT)
+ @$(LIBTOOL) --mode=install \
+- $(INSTALL_PROGRAM) mknbi $(bindir)/$(TARGET)
+- $(INSTALL_DATA) mknbi.man $(mandir)/man$(MANEXT)/$(TARGET).$(MANEXT)
+- $(INSTALL_DATA) misc/mgl.vim $(nbmiscdir)/mgl.vim
+- $(INSTALL_DATA) test/menu.mgl $(nbmiscdir)/menu.mgl
++ $(INSTALL_PROGRAM) mknbi $(DESTDIR)$(bindir)/$(TARGET)
++ $(INSTALL_DATA) mknbi.man $(DESTDIR)$(mandir)/man$(MANEXT)/$(TARGET).$(MANEXT)
++ $(INSTALL_DATA) misc/mgl.vim $(DESTDIR)$(nbmiscdir)/mgl.vim
++ $(INSTALL_DATA) test/menu.mgl $(DESTDIR)$(nbmiscdir)/menu.mgl
+
+
+ test: mknbi
+diff -ru netboot-0.10.1/nblib/Makefile netboot-0.10.1-installfixed/nblib/Makefile
+--- netboot-0.10.1/nblib/Makefile 2006-04-18 00:06:57.000000000 +1000
++++ netboot-0.10.1-installfixed/nblib/Makefile 2007-01-29 13:20:51.000000000 +1100
+@@ -88,9 +88,9 @@
+
+ # Install library
+ install: $(LIBTOOL) $(TARGET)
+- $(INSTALL) -d $(libdir)
++ $(INSTALL) -d $(DESTDIR)$(libdir)
+ @$(LIBTOOL) --mode=install \
+- $(INSTALL_PROGRAM) $(TARGET) $(libdir)/$(TARGET)
++ $(INSTALL_PROGRAM) $(TARGET) $(DESTDIR)$(libdir)/$(TARGET)
+
+
+ # Cleanup
diff --git a/sys-boot/netboot/files/netboot-0.10.1-nossp.patch b/sys-boot/netboot/files/netboot-0.10.1-nossp.patch
new file mode 100644
index 000000000000..bc279f335008
--- /dev/null
+++ b/sys-boot/netboot/files/netboot-0.10.1-nossp.patch
@@ -0,0 +1,44 @@
+--- ./netboot-0.10.1/make.rules.orig 2007-01-25 16:23:21.000000000 +1100
++++ ./netboot-0.10.1/make.rules 2007-01-25 16:24:27.000000000 +1100
+@@ -162,7 +162,7 @@
+ DOGCC86 = $(GCC86) $(CPP86INCS) $(GCC86FLAGS) -S
+
+ %.t86:: %.c86
+- $(DOGCC86) $($(<:%.c86=%)_FLAGS) -o $@ $<
++ $(DOGCC86) -fno-pie -fno-stack-protector $($(<:%.c86=%)_FLAGS) -o $@ $<
+
+
+ %-debug.t86:: %.c86
+--- ./netboot-0.10.1/i386/libc/Makefile.orig 2007-01-25 16:27:17.000000000 +1100
++++ ./netboot-0.10.1/i386/libc/Makefile 2007-01-25 16:27:32.000000000 +1100
+@@ -50,7 +50,7 @@
+ .INTERMEDIATE: $(STROBJS:%.o86=%.t86)
+
+ $(STROBJS:%.o86=%.t86): cstrings.c86 $(INCDIR)/i386/string.h86
+- $(DOGCC86) -DL_$(@:%.t86=%) -o $@ $<
++ $(DOGCC86) -fno-pie -fno-stack-protector -DL_$(@:%.t86=%) -o $@ $<
+
+
+ # distrib generates all files which are not removed by distclean
+--- ./netboot-0.10.1/include/i386/string.h86.org 2007-01-29 10:54:42.000000000 +1100
++++ ./netboot-0.10.1/include/i386/string.h86 2007-01-29 12:04:09.000000000 +1100
+@@ -639,16 +639,16 @@
+ */
+ __nb_inline__ short movemem(__lptr src, __lptr dest, __long n)
+ {
+- __u32 d0, d1, d2;
++ __u32 d0, d1;
+ register __u16 __res;
+
+ __asm__ __volatile__(
+ "call movmem\n\t"
+ "setnc %b0\n\t"
+ "cbtw"
+- : "=&a" (__res), "=&b" (d0), "=&c" (d1), "=&S" (d2)
++ : "=&a" (__res), "=&b" (d0), "=&c" (d1)
+ : "0" ((__u32)src), "1" ((__u32)dest), "2" ((__u32)n)
+- : "memory", "cc");
++ : "memory", "cc", "%esi");
+ return((short)__res);
+ }
+
diff --git a/sys-boot/netboot/netboot-0.10.1.ebuild b/sys-boot/netboot/netboot-0.10.1.ebuild
new file mode 100644
index 000000000000..02c09700e997
--- /dev/null
+++ b/sys-boot/netboot/netboot-0.10.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/netboot-0.10.1.ebuild,v 1.1 2007/01/29 08:00:12 dragonheart Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="netbooting utility"
+HOMEPAGE="http://netboot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/lzo-2
+ >=sys-libs/db-4"
+RDEPEND="${DEPEND}
+ !net-misc/mknbi"
+
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-nossp.patch
+ epatch "${FILESDIR}"/${P}-destdir.patch
+ sed -i -e "s/-s$//" "${S}"/make.config.in
+}
+
+src_compile() {
+# export GCC86DEBUG="-fno-pie -fno-stack-protector"
+ econf --enable-bootrom --with-gnu-cc86="$(tc-getCC)" \
+ --with-gnu-as86="$(tc-getAS)" --with-gnu-ld86="$(tc-getLD)"|| die 'cannot configure'
+ # --enable-config-file
+ sed -i -e "s/-llzo/-llzo2/" "${S}"/make.config
+ emake -j1 || die 'cannot make'
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dodoc README doc/*
+ docinto FlashCard
+ dodoc FlashCard/README FlashCard/*.ps
+ mv "${D}"/usr/share/misc "${D}"/usr/share/${PN}
+ rm -rf "${D}"/usr/lib/netboot/utils
+
+ dobin "${S}"/mknbi-dos/utils/mntnbi.pl
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}"/mknbi-mgl/misc/mgl.vim
+}