summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-07-28 20:13:24 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-07-28 20:13:24 +0000
commit9d5697887a5ca3fb698d7f9ac4cd5093a7eb14b1 (patch)
treed93c6c5d721e9a8e5f763345ee607e50fa5b22fc /sys-boot
parentversion bump (diff)
downloadgentoo-2-9d5697887a5ca3fb698d7f9ac4cd5093a7eb14b1.tar.gz
gentoo-2-9d5697887a5ca3fb698d7f9ac4cd5093a7eb14b1.tar.bz2
gentoo-2-9d5697887a5ca3fb698d7f9ac4cd5093a7eb14b1.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog8
-rw-r--r--sys-boot/syslinux/syslinux-4.02.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 37b786142d7f..40fc6769b816 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.70 2010/07/02 21:36:41 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.71 2010/07/28 20:13:24 chithanh Exp $
+
+*syslinux-4.02 (28 Jul 2010)
+
+ 28 Jul 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +syslinux-4.02.ebuild:
+ Version bump.
*syslinux-4.01 (02 Jul 2010)
diff --git a/sys-boot/syslinux/syslinux-4.02.ebuild b/sys-boot/syslinux/syslinux-4.02.ebuild
new file mode 100644
index 000000000000..6d4e89b0a6fa
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-4.02.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-4.02.ebuild,v 1.1 2010/07/28 20:13:24 chithanh Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${PV:0:1}.xx/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="custom-cflags"
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+S=${WORKDIR}/${P/_/-}
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix building on hardened
+ epatch "${FILESDIR}"/${PN}-4.00-nopie.patch
+
+ rm -f gethostip #bug 137081
+
+ # Don't prestrip or override user LDFLAGS, bug #305783
+ local SYSLINUX_MAKEFILES="extlinux/Makefile linux/Makefile mtools/Makefile \
+ sample/Makefile utils/Makefile"
+ sed -i ${SYSLINUX_MAKEFILES} -e '/^LDFLAGS/d' || die "sed failed"
+
+ if use custom-cflags; then
+ sed -i ${SYSLINUX_MAKEFILES} \
+ -e 's|-g -Os||g' \
+ -e 's|-Os||g' \
+ -e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
+ || die "sed custom-cflags failed"
+ fi
+
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) installer || die
+}
+
+src_install() {
+ emake INSTALLSUBDIRS=utils INSTALLROOT="${D}" MANDIR=/usr/share/man install || die
+ dodoc README NEWS doc/* || die
+}