summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-04 16:37:47 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-04 16:37:47 +0000
commitaf66f85cc0d988721b97460774d80959ec0e9d4a (patch)
tree65a13d20b449922651ad7e9076bdbd44711c4d2b /sys-boot
parentwhitespace (diff)
downloadgentoo-2-af66f85cc0d988721b97460774d80959ec0e9d4a.tar.gz
gentoo-2-af66f85cc0d988721b97460774d80959ec0e9d4a.tar.bz2
gentoo-2-af66f85cc0d988721b97460774d80959ec0e9d4a.zip
Version bump. Remove debugging echoes.
(Portage version: 2.2.0_alpha29/cvs/Linux i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog8
-rw-r--r--sys-boot/unetbootin/unetbootin-527-r1.ebuild3
-rw-r--r--sys-boot/unetbootin/unetbootin-549.ebuild43
3 files changed, 51 insertions, 3 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index b16f92d973ed..64a560a8fb3f 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.58 2011/04/04 04:27:07 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.59 2011/04/04 16:37:47 jer Exp $
+
+*unetbootin-549 (04 Apr 2011)
+
+ 04 Apr 2011; Jeroen Roovers <jer@gentoo.org> unetbootin-527-r1.ebuild,
+ +unetbootin-549.ebuild:
+ Version bump. Remove debugging echoes.
*unetbootin-527-r1 (04 Apr 2011)
diff --git a/sys-boot/unetbootin/unetbootin-527-r1.ebuild b/sys-boot/unetbootin/unetbootin-527-r1.ebuild
index bd8fbce49e72..aa36a3335f32 100644
--- a/sys-boot/unetbootin/unetbootin-527-r1.ebuild
+++ b/sys-boot/unetbootin/unetbootin-527-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-527-r1.ebuild,v 1.1 2011/04/04 04:27:07 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-527-r1.ebuild,v 1.2 2011/04/04 16:37:47 jer Exp $
EAPI="3"
@@ -37,7 +37,6 @@ src_install() {
for file in ${PN}*.png; do
size="${file/unetbootin_}"
size="${size/.png}x${size/.png}"
- echo $file $size
insinto /usr/share/icons/hicolor/${size}
newins ${file} ${PN}.png
done
diff --git a/sys-boot/unetbootin/unetbootin-549.ebuild b/sys-boot/unetbootin/unetbootin-549.ebuild
new file mode 100644
index 000000000000..cafbd2f2999b
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-549.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-549.ebuild,v 1.1 2011/04/04 16:37:47 jer Exp $
+
+EAPI="3"
+
+inherit qt4-r2
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_configure() {
+ lupdate ${PN}.pro || die
+ lrelease ${PN}.pro || die
+ eqmake4 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ insinto /usr/share/applications
+ doins ${PN}.desktop || die
+ for file in ${PN}*.png; do
+ size="${file/unetbootin_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}
+ newins ${file} ${PN}.png
+ done
+}