summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-02-13 07:41:16 +0000
committerMike Frysinger <vapier@gentoo.org>2011-02-13 07:41:16 +0000
commitb3706d39598b4644ee96d2f67263604a0d520cf8 (patch)
tree7dd4252720ac17d1a3bdbb66007bbe594d1d0d7b /sys-boot
parentRelease 4.4.4 p1.4 and 4.4.5 p1.2 with fix for HPPA wrong-code (bug #349113). (diff)
downloadgentoo-2-b3706d39598b4644ee96d2f67263604a0d520cf8.tar.gz
gentoo-2-b3706d39598b4644ee96d2f67263604a0d520cf8.tar.bz2
gentoo-2-b3706d39598b4644ee96d2f67263604a0d520cf8.zip
Make sure boot is mounted rw before we go setting it up #348946 by Jaco Kroon.
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog8
-rw-r--r--sys-boot/grub/grub-0.97-r10.ebuild6
-rw-r--r--sys-boot/grub/grub-0.97-r8.ebuild6
-rw-r--r--sys-boot/grub/grub-0.97-r9.ebuild6
-rw-r--r--sys-boot/grub/grub-1.98.ebuild7
-rw-r--r--sys-boot/grub/grub-9999.ebuild7
6 files changed, 29 insertions, 11 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 2fdffeef8fc9..d45cc11bd9dc 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.148 2011/01/09 03:22:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.149 2011/02/13 07:41:16 vapier Exp $
+
+ 13 Feb 2011; Mike Frysinger <vapier@gentoo.org> grub-0.97-r8.ebuild,
+ grub-0.97-r9.ebuild, grub-0.97-r10.ebuild, grub-1.98.ebuild,
+ grub-9999.ebuild:
+ Make sure boot is mounted rw before we go setting it up #348946 by Jaco
+ Kroon.
09 Jan 2011; Mike Frysinger <vapier@gentoo.org> grub-0.97-r8.ebuild,
grub-0.97-r9.ebuild, grub-0.97-r10.ebuild, grub-1.98.ebuild,
diff --git a/sys-boot/grub/grub-0.97-r10.ebuild b/sys-boot/grub/grub-0.97-r10.ebuild
index 84f2146321e1..8fbfdc2a77b6 100644
--- a/sys-boot/grub/grub-0.97-r10.ebuild
+++ b/sys-boot/grub/grub-0.97-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r10.ebuild,v 1.8 2011/01/09 03:22:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r10.ebuild,v 1.9 2011/02/13 07:41:16 vapier Exp $
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
@@ -257,7 +257,7 @@ setup_boot_dir() {
}
pkg_postinst() {
- mount-boot_pkg_postinst
+ mount-boot_mount_boot_partition
if [[ -n ${DONT_MOUNT_BOOT} ]]; then
elog "WARNING: you have DONT_MOUNT_BOOT in effect, so you must apply"
@@ -276,6 +276,8 @@ pkg_postinst() {
elog "Alternately, you can export GRUB_ALT_INSTALLDIR=/path/to/use to tell"
elog "grub where to install in a non-interactive way."
+ # needs to be after we call setup_boot_dir
+ mount-boot_pkg_postinst
}
pkg_config() {
diff --git a/sys-boot/grub/grub-0.97-r8.ebuild b/sys-boot/grub/grub-0.97-r8.ebuild
index ac44cdb2fe89..89f6b9d92716 100644
--- a/sys-boot/grub/grub-0.97-r8.ebuild
+++ b/sys-boot/grub/grub-0.97-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r8.ebuild,v 1.2 2011/01/09 03:22:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r8.ebuild,v 1.3 2011/02/13 07:41:16 vapier Exp $
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
@@ -239,7 +239,7 @@ setup_boot_dir() {
}
pkg_postinst() {
- mount-boot_pkg_postinst
+ mount-boot_mount_boot_partition
if [[ -n ${DONT_MOUNT_BOOT} ]]; then
elog "WARNING: you have DONT_MOUNT_BOOT in effect, so you must apply"
@@ -258,6 +258,8 @@ pkg_postinst() {
elog "Alternately, you can export GRUB_ALT_INSTALLDIR=/path/to/use to tell"
elog "grub where to install in a non-interactive way."
+ # needs to be after we call setup_boot_dir
+ mount-boot_pkg_postinst
}
pkg_config() {
diff --git a/sys-boot/grub/grub-0.97-r9.ebuild b/sys-boot/grub/grub-0.97-r9.ebuild
index 3df7fc02611a..655cae3b9d88 100644
--- a/sys-boot/grub/grub-0.97-r9.ebuild
+++ b/sys-boot/grub/grub-0.97-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r9.ebuild,v 1.6 2011/01/09 03:22:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r9.ebuild,v 1.7 2011/02/13 07:41:16 vapier Exp $
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
@@ -246,7 +246,7 @@ setup_boot_dir() {
}
pkg_postinst() {
- mount-boot_pkg_postinst
+ mount-boot_mount_boot_partition
if [[ -n ${DONT_MOUNT_BOOT} ]]; then
elog "WARNING: you have DONT_MOUNT_BOOT in effect, so you must apply"
@@ -265,6 +265,8 @@ pkg_postinst() {
elog "Alternately, you can export GRUB_ALT_INSTALLDIR=/path/to/use to tell"
elog "grub where to install in a non-interactive way."
+ # needs to be after we call setup_boot_dir
+ mount-boot_pkg_postinst
}
pkg_config() {
diff --git a/sys-boot/grub/grub-1.98.ebuild b/sys-boot/grub/grub-1.98.ebuild
index c67491625021..eabb00c4fde6 100644
--- a/sys-boot/grub/grub-1.98.ebuild
+++ b/sys-boot/grub/grub-1.98.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.98.ebuild,v 1.6 2011/01/09 03:22:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.98.ebuild,v 1.7 2011/02/13 07:41:16 vapier Exp $
# XXX: need to implement a grub.conf migration in pkg_postinst before we ~arch
@@ -102,11 +102,14 @@ setup_boot_dir() {
}
pkg_postinst() {
- mount-boot_pkg_postinst
+ mount-boot_mount_boot_partition
if use multislot ; then
elog "You have installed grub2 with USE=multislot, so to coexist"
elog "with grub1, the grub2 install binary is named grub2-install."
fi
setup_boot_dir "${ROOT}"boot
+
+ # needs to be after we call setup_boot_dir
+ mount-boot_pkg_postinst
}
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 622619ff6125..5a65e84cfe87 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.27 2011/01/09 03:22:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.28 2011/02/13 07:41:16 vapier Exp $
# XXX: need to implement a grub.conf migration in pkg_postinst before we ~arch
@@ -102,11 +102,14 @@ setup_boot_dir() {
}
pkg_postinst() {
- mount-boot_pkg_postinst
+ mount-boot_mount_boot_partition
if use multislot ; then
elog "You have installed grub2 with USE=multislot, so to coexist"
elog "with grub1, the grub2 install binary is named grub2-install."
fi
setup_boot_dir "${ROOT}"boot
+
+ # needs to be after we call setup_boot_dir
+ mount-boot_pkg_postinst
}