summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2006-07-13 15:02:09 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2006-07-13 15:02:09 +0000
commit5d4994a06445d6d726850374f604277301aef2ca (patch)
tree027b2c0f35b88993a73506e6594295d45f82e54a /sys-cluster/ccs/ccs-1.02.00-r1.ebuild
parentThe ldscript should be called 'libcap.so', and not versioned like it was. (diff)
downloadgentoo-2-5d4994a06445d6d726850374f604277301aef2ca.tar.gz
gentoo-2-5d4994a06445d6d726850374f604277301aef2ca.tar.bz2
gentoo-2-5d4994a06445d6d726850374f604277301aef2ca.zip
1.02.00 updated to current stable.
(Portage version: 2.1-r1)
Diffstat (limited to 'sys-cluster/ccs/ccs-1.02.00-r1.ebuild')
-rw-r--r--sys-cluster/ccs/ccs-1.02.00-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-cluster/ccs/ccs-1.02.00-r1.ebuild b/sys-cluster/ccs/ccs-1.02.00-r1.ebuild
new file mode 100644
index 000000000000..5cee95548388
--- /dev/null
+++ b/sys-cluster/ccs/ccs-1.02.00-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ccs-1.02.00-r1.ebuild,v 1.1 2006/07/13 15:02:09 xmerlin Exp $
+
+inherit eutils
+
+CVS_RELEASE="20060713"
+MY_P="cluster-${PV}"
+
+DESCRIPTION="cluster configuration system to manage the cluster config file"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz
+ mirror://gentoo/${PN}-${PV}-${CVS_RELEASE}-cvs.patch.gz
+ http://dev.gentoo.org/~xmerlin/gfs/${PN}-${PV}-${CVS_RELEASE}-cvs.patch.gz"
+
+IUSE=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+DEPEND=">=sys-cluster/magma-1.02.00
+ dev-libs/libxml2
+ sys-libs/zlib"
+
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${PN}-${PV}-${CVS_RELEASE}-cvs.patch || die
+}
+
+src_compile() {
+ ./configure || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ newinitd ${FILESDIR}/${PN}d.rc ${PN}d || die
+ newconfd ${FILESDIR}/${PN}d.conf ${PN}d || die
+}