summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-08-16 16:35:31 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-08-16 16:35:31 +0000
commit623b819bd5f20d7ac5cd4f08652cfdeb9c338461 (patch)
treed93ce313209fa77f336442e93899ce8f6c72be0e /sys-cluster/ceph
parenttypo (diff)
downloadgentoo-2-623b819bd5f20d7ac5cd4f08652cfdeb9c338461.tar.gz
gentoo-2-623b819bd5f20d7ac5cd4f08652cfdeb9c338461.tar.bz2
gentoo-2-623b819bd5f20d7ac5cd4f08652cfdeb9c338461.zip
Version bump per bug #479350
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ChangeLog9
-rw-r--r--sys-cluster/ceph/ceph-0.61.7.ebuild111
-rw-r--r--sys-cluster/ceph/ceph-0.67.ebuild111
3 files changed, 230 insertions, 1 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 5bbe4388f942..488b19d94065 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.39 2013/05/09 21:07:35 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.40 2013/08/16 16:35:31 alexxy Exp $
+
+*ceph-0.67 (16 Aug 2013)
+*ceph-0.61.7 (16 Aug 2013)
+
+ 16 Aug 2013; Alexey Shvetsov <alexxy@gentoo.org> +ceph-0.61.7.ebuild,
+ +ceph-0.67.ebuild:
+ Version bump per bug #479350
*ceph-0.56.5 (09 May 2013)
diff --git a/sys-cluster/ceph/ceph-0.61.7.ebuild b/sys-cluster/ceph/ceph-0.61.7.ebuild
new file mode 100644
index 000000000000..7dafd82ccd4d
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.61.7.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.61.7.ebuild,v 1.1 2013/08/16 16:35:31 alexxy Exp $
+
+EAPI=5
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="
+ git://github.com/ceph/ceph.git
+ https://github.com/ceph/ceph.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://ceph.com/download/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools eutils multilib udev ${scm_eclass}
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.com/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="debug fuse gtk libatomic radosgw static-libs tcmalloc"
+
+CDEPEND="
+ app-arch/snappy
+ dev-libs/boost
+ dev-libs/fcgi
+ dev-libs/libaio
+ dev-libs/libedit
+ dev-libs/leveldb
+ dev-libs/crypto++
+ sys-apps/keyutils
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ net-misc/curl
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-fs/btrfs-progs"
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+src_prepare() {
+ if [ ! -z ${PATCHES[@]} ]; then
+ epatch ${PATCHES[@]}
+ fi
+ sed -e 's:invoke-rc\.d.*:/etc/init.d/ceph reload >/dev/null:' \
+ -i src/logrotate.conf || die
+ sed -i "/^docdir =/d" src/Makefile.am || die #fix doc path
+ # disable testsnaps
+ sed -e '/testsnaps/d' -i src/Makefile.am || die
+ sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
+ > "${T}"/${PN}.initd || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ rmdir "${ED}/usr/sbin"
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins src/logrotate.conf ${PN}
+
+ chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${T}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ #install udev rules
+ udev_dorules udev/50-rbd.rules
+ udev_dorules udev/95-ceph-osd.rules
+}
diff --git a/sys-cluster/ceph/ceph-0.67.ebuild b/sys-cluster/ceph/ceph-0.67.ebuild
new file mode 100644
index 000000000000..905cc76a26a1
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.67.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.67.ebuild,v 1.1 2013/08/16 16:35:31 alexxy Exp $
+
+EAPI=5
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="
+ git://github.com/ceph/ceph.git
+ https://github.com/ceph/ceph.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://ceph.com/download/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools eutils multilib udev ${scm_eclass}
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.com/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="debug fuse gtk libatomic radosgw static-libs tcmalloc"
+
+CDEPEND="
+ app-arch/snappy
+ dev-libs/boost
+ dev-libs/fcgi
+ dev-libs/libaio
+ dev-libs/libedit
+ dev-libs/leveldb
+ dev-libs/crypto++
+ sys-apps/keyutils
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ net-misc/curl
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-fs/btrfs-progs"
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+src_prepare() {
+ if [ ! -z ${PATCHES[@]} ]; then
+ epatch ${PATCHES[@]}
+ fi
+ sed -e 's:invoke-rc\.d.*:/etc/init.d/ceph reload >/dev/null:' \
+ -i src/logrotate.conf || die
+ sed -i "/^docdir =/d" src/Makefile.am || die #fix doc path
+ # disable testsnaps
+ sed -e '/testsnaps/d' -i src/Makefile.am || die
+ sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
+ > "${T}"/${PN}.initd || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ rmdir "${ED}/usr/sbin"
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins src/logrotate.conf ${PN}
+
+ chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${T}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ #install udev rules
+ udev_dorules udev/50-rbd.rules
+ udev_dorules udev/95-ceph-osd.rules
+}