summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-08-19 08:57:46 +0000
committerYixun Lan <dlan@gentoo.org>2014-08-19 08:57:46 +0000
commit665313d9bc70e6009cb927fc2905439751dce273 (patch)
tree3d6d4e73b8f4d1f35eb43e6116765f071bcb46c9 /sys-cluster/ceph
parentStable for ppc64, wrt bug #505558 (diff)
downloadgentoo-2-665313d9bc70e6009cb927fc2905439751dce273.tar.gz
gentoo-2-665313d9bc70e6009cb927fc2905439751dce273.tar.bz2
gentoo-2-665313d9bc70e6009cb927fc2905439751dce273.zip
drop 0.56.3 which never updated and have security problem. bump 0.67.10, fix bug 519540
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ChangeLog11
-rw-r--r--sys-cluster/ceph/ceph-0.67.10.ebuild (renamed from sys-cluster/ceph/ceph-0.56.3.ebuild)72
-rw-r--r--sys-cluster/ceph/ceph-0.67.9.ebuild21
-rw-r--r--sys-cluster/ceph/ceph-0.80.5.ebuild19
-rw-r--r--sys-cluster/ceph/ceph-9999.ebuild19
-rw-r--r--sys-cluster/ceph/files/README.gentoo18
-rw-r--r--sys-cluster/ceph/files/ceph.confd8
-rw-r--r--sys-cluster/ceph/files/ceph.initd27
-rw-r--r--sys-cluster/ceph/files/ceph.initd-r12
9 files changed, 87 insertions, 110 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 7585c512ee76..5abf51508689 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.55 2014/08/01 02:31:42 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.56 2014/08/19 08:57:46 dlan Exp $
+
+*ceph-0.67.10 (19 Aug 2014)
+
+ 19 Aug 2014; Yixun Lan <dlan@gentoo.org> -ceph-0.56.3.ebuild,
+ ceph-0.67.9.ebuild, +ceph-0.67.10.ebuild, ceph-0.80.5.ebuild,
+ ceph-9999.ebuild, +files/README.gentoo, -files/ceph.confd, -files/ceph.initd,
+ files/ceph.initd-r1:
+ drop 0.56.3 which never updated and have security problem. bump 0.67.10, fix
+ bug 519540
*ceph-0.80.5 (01 Aug 2014)
diff --git a/sys-cluster/ceph/ceph-0.56.3.ebuild b/sys-cluster/ceph/ceph-0.67.10.ebuild
index c794dfa892ee..18cc1fcbe74b 100644
--- a/sys-cluster/ceph/ceph-0.56.3.ebuild
+++ b/sys-cluster/ceph/ceph-0.67.10.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.56.3.ebuild,v 1.3 2013/03/26 09:25:56 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.67.10.ebuild,v 1.1 2014/08/19 08:57:46 dlan Exp $
EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
if [[ $PV = *9999* ]]; then
- scm_eclass=git-2
+ scm_eclass=git-r3
EGIT_REPO_URI="
git://github.com/ceph/ceph.git
https://github.com/ceph/ceph.git"
@@ -13,25 +14,30 @@ if [[ $PV = *9999* ]]; then
KEYWORDS=""
else
SRC_URI="http://ceph.com/download/${P}.tar.bz2"
- KEYWORDS="amd64 x86"
+ KEYWORDS="~amd64 ~x86"
fi
-inherit autotools eutils multilib udev ${scm_eclass}
+inherit autotools eutils multilib python-any-r1 udev readme.gentoo ${scm_eclass}
DESCRIPTION="Ceph distributed filesystem"
HOMEPAGE="http://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="debug fuse gtk libatomic radosgw static-libs tcmalloc"
+IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc"
CDEPEND="
- dev-libs/boost
+ app-arch/snappy
+ dev-libs/boost:=[threads]
dev-libs/fcgi
dev-libs/libaio
dev-libs/libedit
- dev-libs/crypto++
+ dev-libs/leveldb[snappy]
+ nss? ( dev-libs/nss )
+ cryptopp? ( dev-libs/crypto++ )
sys-apps/keyutils
+ sys-apps/util-linux
+ dev-libs/libxml2
fuse? ( sys-fs/fuse )
libatomic? ( dev-libs/libatomic_ops )
gtk? (
@@ -45,23 +51,35 @@ CDEPEND="
net-misc/curl
)
tcmalloc? ( dev-util/google-perftools )
+ $(python_gen_any_dep '
+ ' )
+ ${PYTHON_DEPS}
"
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
- sys-fs/btrfs-progs"
+ sys-apps/hdparm
+ $(python_gen_any_dep '
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ' )"
+REQUIRED_USE="
+ ^^ ( nss cryptopp )
+ "
STRIP_MASK="/usr/lib*/rados-classes/*"
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
src_prepare() {
- sed -e 's:invoke-rc\.d.*:/etc/init.d/ceph reload >/dev/null:' \
- -i src/logrotate.conf || die
- sed -i "/^docdir =/d" src/Makefile.am || die #fix doc path
- # disable testsnaps
- sed -e '/testsnaps/d' -i src/Makefile.am || die
- sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
- > "${T}"/${PN}.initd || die
- sed -i -e '/AM_INIT_AUTOMAKE/s:-Werror ::' src/leveldb/configure.ac || die #423755
+ if [ ! -z ${PATCHES[@]} ]; then
+ epatch ${PATCHES[@]}
+ fi
+ sed -e '/^ceph_sbindir =/s:$(exec_prefix)::' -i src/Makefile.am || die
+
+ epatch_user
eautoreconf
}
@@ -72,7 +90,10 @@ src_configure() {
--includedir=/usr/include \
$(use_with debug) \
$(use_with fuse) \
+ $(use_with libaio) \
$(use_with libatomic libatomic-ops) \
+ $(use_with nss) \
+ $(use_with cryptopp) \
$(use_with radosgw) \
$(use_with gtk gtk2) \
$(use_enable static-libs static) \
@@ -84,13 +105,11 @@ src_install() {
prune_libtool_files --all
- rmdir "${ED}/usr/sbin"
-
exeinto /usr/$(get_libdir)/ceph
newexe src/init-ceph ceph_init.sh
insinto /etc/logrotate.d/
- newins src/logrotate.conf ${PN}
+ newins "${FILESDIR}"/ceph.logrotate ${PN}
chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
@@ -98,9 +117,16 @@ src_install() {
keepdir /var/lib/${PN}/tmp
keepdir /var/log/${PN}/stat
- newinitd "${T}/${PN}.initd" ${PN}
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd-r1" ${PN}
+
+ python_fix_shebang \
+ "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
+ "${ED}"/usr/bin/{ceph,ceph-rest-api}
- # install udev rules
+ #install udev rules
udev_dorules udev/50-rbd.rules
+ udev_dorules udev/95-ceph-osd.rules
+
+ readme.gentoo_src_install
}
diff --git a/sys-cluster/ceph/ceph-0.67.9.ebuild b/sys-cluster/ceph/ceph-0.67.9.ebuild
index 369762a353eb..80253291c82a 100644
--- a/sys-cluster/ceph/ceph-0.67.9.ebuild
+++ b/sys-cluster/ceph/ceph-0.67.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.67.9.ebuild,v 1.1 2014/07/18 06:42:13 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.67.9.ebuild,v 1.2 2014/08/19 08:57:46 dlan Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -17,7 +17,7 @@ else
KEYWORDS="~amd64 ~x86"
fi
-inherit autotools eutils multilib python-any-r1 udev ${scm_eclass}
+inherit autotools eutils multilib python-any-r1 udev readme.gentoo ${scm_eclass}
DESCRIPTION="Ceph distributed filesystem"
HOMEPAGE="http://ceph.com/"
@@ -77,8 +77,6 @@ src_prepare() {
if [ ! -z ${PATCHES[@]} ]; then
epatch ${PATCHES[@]}
fi
- sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
- > "${T}"/${PN}.initd || die
sed -e '/^ceph_sbindir =/s:$(exec_prefix)::' -i src/Makefile.am || die
epatch_user
@@ -129,19 +127,6 @@ src_install() {
#install udev rules
udev_dorules udev/50-rbd.rules
udev_dorules udev/95-ceph-osd.rules
-}
-pkg_postinst() {
- elog "We suggest to install following packages"
- elog " sys-block/parted to manage disk partions"
- elog " sys-fs/btrfs-progs to use btrfs filesytem"
- elog " sys-fs/cryptsetup to use encrypted devices with dm-crypt"
- elog ""
- elog "To have many daemons of one type, create your own script:"
- elog ""
- elog "cd /etc/init.d"
- elog "for dmn in mds.a mon.a osd.0 osd.1 osd.2; do"
- elog " ln -s ceph ceph-\${dmn};"
- elog " rc-update add ceph-\${dmn} default;"
- elog "done"
+ readme.gentoo_src_install
}
diff --git a/sys-cluster/ceph/ceph-0.80.5.ebuild b/sys-cluster/ceph/ceph-0.80.5.ebuild
index 9a3e8f28b37b..246b64b0c8a8 100644
--- a/sys-cluster/ceph/ceph-0.80.5.ebuild
+++ b/sys-cluster/ceph/ceph-0.80.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.80.5.ebuild,v 1.1 2014/08/01 02:31:42 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.80.5.ebuild,v 1.2 2014/08/19 08:57:46 dlan Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -17,7 +17,7 @@ else
KEYWORDS="~amd64 ~x86"
fi
-inherit autotools eutils multilib python-any-r1 udev ${scm_eclass}
+inherit autotools eutils multilib python-any-r1 udev readme.gentoo ${scm_eclass}
DESCRIPTION="Ceph distributed filesystem"
HOMEPAGE="http://ceph.com/"
@@ -133,19 +133,6 @@ src_install() {
#install udev rules
udev_dorules udev/50-rbd.rules
udev_dorules udev/95-ceph-osd.rules
-}
-pkg_postinst() {
- elog "We suggest to install following packages"
- elog " sys-block/parted to manage disk partions"
- elog " sys-fs/btrfs-progs to use btrfs filesytem"
- elog " sys-fs/cryptsetup to use encrypted devices with dm-crypt"
- elog ""
- elog "To have many daemons of one type, create your own script:"
- elog ""
- elog "cd /etc/init.d"
- elog "for dmn in mds.a mon.a osd.0 osd.1 osd.2; do"
- elog " ln -s ceph ceph-\${dmn};"
- elog " rc-update add ceph-\${dmn} default;"
- elog "done"
+ readme.gentoo_src_install
}
diff --git a/sys-cluster/ceph/ceph-9999.ebuild b/sys-cluster/ceph/ceph-9999.ebuild
index dc9a84262562..049ef1e9873f 100644
--- a/sys-cluster/ceph/ceph-9999.ebuild
+++ b/sys-cluster/ceph/ceph-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-9999.ebuild,v 1.12 2014/07/18 06:42:13 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-9999.ebuild,v 1.13 2014/08/19 08:57:46 dlan Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -17,7 +17,7 @@ else
KEYWORDS="~amd64 ~x86"
fi
-inherit autotools eutils multilib python-any-r1 udev ${scm_eclass}
+inherit autotools eutils multilib python-any-r1 udev readme.gentoo ${scm_eclass}
DESCRIPTION="Ceph distributed filesystem"
HOMEPAGE="http://ceph.com/"
@@ -128,19 +128,6 @@ src_install() {
#install udev rules
udev_dorules udev/50-rbd.rules
udev_dorules udev/95-ceph-osd.rules
-}
-pkg_postinst() {
- elog "We suggest to install following packages"
- elog " sys-block/parted to manage disk partions"
- elog " sys-fs/btrfs-progs to use btrfs filesytem"
- elog " sys-fs/cryptsetup to use encrypted devices with dm-crypt"
- elog ""
- elog "To have many daemons of one type, create your own script:"
- elog ""
- elog "cd /etc/init.d"
- elog "for dmn in mds.a mon.a osd.0 osd.1 osd.2; do"
- elog " ln -s ceph ceph-\${dmn};"
- elog " rc-update add ceph-\${dmn} default;"
- elog "done"
+ readme.gentoo_src_install
}
diff --git a/sys-cluster/ceph/files/README.gentoo b/sys-cluster/ceph/files/README.gentoo
new file mode 100644
index 000000000000..b0495158ec1d
--- /dev/null
+++ b/sys-cluster/ceph/files/README.gentoo
@@ -0,0 +1,18 @@
+1) We'd suggest you to install following packages
+ sys-block/parted to manage disk partions
+ sys-fs/btrfs-progs to use btrfs filesytem
+ sys-fs/cryptsetup to use encrypted devices with dm-crypt
+
+2) To start several daemons of one specific type, create your own scripts
+ cd /etc/init.d
+ for dmn in mds.a mon.a osd.0 osd.1 osd.2; do
+ ln -s ceph ceph-${dmn};
+ rc-update add ceph-${dmn} default;
+ done
+
+3) If you spread ceph daemons over several different machines,
+ We'd highly recommend you to start ntp-client to keep the system time sync.
+ Try to choose one of following ntp client to install and add into runlevel.
+ net-misc/ntp
+ net-misc/openntpd
+ net-misc/chrony
diff --git a/sys-cluster/ceph/files/ceph.confd b/sys-cluster/ceph/files/ceph.confd
deleted file mode 100644
index 1afc33560e1b..000000000000
--- a/sys-cluster/ceph/files/ceph.confd
+++ /dev/null
@@ -1,8 +0,0 @@
-# These are passed as arguments to original ceph initscript
-# see also http://ceph.newdream.net/wiki/Starting_and_stopping
-
-# CEPH_COMMON=( --hostname myhost )
-
-CEPH_START=( start )
-CEPH_STOP=( stop )
-CEPH_RELOAD=( reload )
diff --git a/sys-cluster/ceph/files/ceph.initd b/sys-cluster/ceph/files/ceph.initd
deleted file mode 100644
index 993bb01b60a8..000000000000
--- a/sys-cluster/ceph/files/ceph.initd
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/sbin/runscript
-
-extra_started_commands="reload"
-bin=/usr/lib/ceph/ceph_init.sh
-
-depend() {
- after net
- before netmount
-}
-
-start() {
- ebegin "Initializing local Ceph node"
- $bin "${CEPH_COMMON[@]}" "${CEPH_START[@]}"
- eend 0
-}
-
-reload() {
- ebegin "Reloading ceph configuration"
- $bin "${CEPH_COMMON[@]}" "${CEPH_RELOAD[@]}"
- eend 0
-}
-
-stop() {
- ebegin "Stopping local Ceph node"
- $bin "${CEPH_COMMON[@]}" "${CEPH_STOP[@]}"
- eend 0
-}
diff --git a/sys-cluster/ceph/files/ceph.initd-r1 b/sys-cluster/ceph/files/ceph.initd-r1
index f3bc87fd1de5..ca5ab60cc0b7 100644
--- a/sys-cluster/ceph/files/ceph.initd-r1
+++ b/sys-cluster/ceph/files/ceph.initd-r1
@@ -10,7 +10,7 @@ pidfile="/run/ceph/${type}.${id}.pid"
command_args="-i ${id} --pid-file ${pidfile} -c ${ceph_conf}"
depend() {
- after net
+ after net ntpd ntp-client chronyd
before netmount
}