summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-01-18 10:22:53 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-01-18 10:22:53 +0000
commitae1b4d05b9a533df3563c5fd2481874588deb8ef (patch)
tree93bf22e8e696fcfb76b7652b38c6f5aca5851b44 /sys-cluster/corosync
parentStable for amd64, wrt bug #452472 (diff)
downloadgentoo-2-ae1b4d05b9a533df3563c5fd2481874588deb8ef.tar.gz
gentoo-2-ae1b4d05b9a533df3563c5fd2481874588deb8ef.tar.bz2
gentoo-2-ae1b4d05b9a533df3563c5fd2481874588deb8ef.zip
Version bump, fix #451182
(Portage version: 2.1.11.41/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster/corosync')
-rw-r--r--sys-cluster/corosync/ChangeLog11
-rw-r--r--sys-cluster/corosync/corosync-1.4.4.ebuild6
-rw-r--r--sys-cluster/corosync/corosync-1.4.5.ebuild64
-rw-r--r--sys-cluster/corosync/corosync-2.3.0.ebuild68
4 files changed, 144 insertions, 5 deletions
diff --git a/sys-cluster/corosync/ChangeLog b/sys-cluster/corosync/ChangeLog
index be1e37331467..84422590eca3 100644
--- a/sys-cluster/corosync/ChangeLog
+++ b/sys-cluster/corosync/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/corosync
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.25 2012/10/29 13:56:21 ultrabug Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.26 2013/01/18 10:22:53 ultrabug Exp $
+
+*corosync-2.3.0 (18 Jan 2013)
+*corosync-1.4.5 (18 Jan 2013)
+
+ 18 Jan 2013; Ultrabug <ultrabug@gentoo.org> corosync-1.4.4.ebuild,
+ +corosync-1.4.5.ebuild, +corosync-2.3.0.ebuild:
+ Version bump, fix #451182
*corosync-1.4.4 (29 Oct 2012)
diff --git a/sys-cluster/corosync/corosync-1.4.4.ebuild b/sys-cluster/corosync/corosync-1.4.4.ebuild
index a30a45328d4c..8058e7353cc9 100644
--- a/sys-cluster/corosync/corosync-1.4.4.ebuild
+++ b/sys-cluster/corosync/corosync-1.4.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-1.4.4.ebuild,v 1.1 2012/10/29 13:56:21 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-1.4.4.ebuild,v 1.2 2013/01/18 10:22:53 ultrabug Exp $
EAPI=4
@@ -8,7 +8,7 @@ inherit base autotools
DESCRIPTION="OSI Certified implementation of a complete cluster engine"
HOMEPAGE="http://www.corosync.org/"
-SRC_URI="https://github.com/downloads/corosync/corosync/${P}.tar.gz"
+SRC_URI="mirror://github/corosync/corosync/${P}.tar.gz"
LICENSE="BSD-2 public-domain"
SLOT="0"
diff --git a/sys-cluster/corosync/corosync-1.4.5.ebuild b/sys-cluster/corosync/corosync-1.4.5.ebuild
new file mode 100644
index 000000000000..56cf54b67011
--- /dev/null
+++ b/sys-cluster/corosync/corosync-1.4.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-1.4.5.ebuild,v 1.1 2013/01/18 10:22:53 ultrabug Exp $
+
+EAPI=4
+
+inherit autotools base
+
+MY_TREE="5b75f8c"
+
+DESCRIPTION="OSI Certified implementation of a complete cluster engine"
+HOMEPAGE="http://www.corosync.org/"
+SRC_URI="https://github.com/corosync/corosync/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
+IUSE="doc infiniband ssl static-libs"
+
+RDEPEND="!sys-cluster/heartbeat
+ ssl? ( dev-libs/nss )
+ infiniband? (
+ sys-infiniband/libibverbs
+ sys-infiniband/librdmacm
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( sys-apps/groff )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-docs.patch"
+)
+
+DOCS=( README.recovery README.devmap SECURITY TODO AUTHORS )
+
+S="${WORKDIR}/${PN}-${PN}-${MY_TREE}"
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ # appends lib to localstatedir automatically
+ # FIXME: install just shared libs --disable-static does not work
+ econf \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable ssl nss) \
+ $(use_enable infiniband rdma)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ rm "${D}"/etc/init.d/corosync-notifyd || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ keepdir /var/lib/corosync
+ use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.a || die
+}
diff --git a/sys-cluster/corosync/corosync-2.3.0.ebuild b/sys-cluster/corosync/corosync-2.3.0.ebuild
new file mode 100644
index 000000000000..efc2683c04f9
--- /dev/null
+++ b/sys-cluster/corosync/corosync-2.3.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-2.3.0.ebuild,v 1.1 2013/01/18 10:22:53 ultrabug Exp $
+
+EAPI=4
+
+inherit autotools base
+
+MY_TREE="b7db472"
+
+DESCRIPTION="OSI Certified implementation of a complete cluster engine"
+HOMEPAGE="http://www.corosync.org/"
+SRC_URI="https://github.com/corosync/corosync/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc infiniband static-libs"
+
+# TODO: support those new configure flags
+# --enable-watchdog : Watchdog support
+# --enable-augeas : Install the augeas lens for corosync.conf
+# --enable-snmp : SNMP protocol support
+# --enable-xmlconf : XML configuration support
+# --enable-systemd : Install systemd service files
+RDEPEND="!sys-cluster/heartbeat
+ infiniband? (
+ sys-infiniband/libibverbs
+ sys-infiniband/librdmacm
+ )
+ dev-libs/nss
+ sys-cluster/libqb"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( sys-apps/groff )"
+
+PATCHES=( "${FILESDIR}/${PN}-2.0.0-docs.patch" )
+
+DOCS=( README.recovery SECURITY TODO AUTHORS )
+
+S="${WORKDIR}/${PN}-${PN}-${MY_TREE}"
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ # appends lib to localstatedir automatically
+ # FIXME: install just shared libs --disable-static does not work
+ econf \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable infiniband rdma)
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ rm "${D}"/etc/init.d/corosync-notifyd || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ keepdir /var/lib/corosync
+ use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.a || die
+}