summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2005-01-21 18:26:44 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2005-01-21 18:26:44 +0000
commitd919bfb9d4efdd084785008146628e5d6f51ce80 (patch)
tree667a207c4bb7ff06692feffe3c7f4ce0082246aa /sys-cluster/ipvsadm/ipvsadm-1.24.ebuild
parentStable on alpha, bug 78619. (diff)
downloadgentoo-2-d919bfb9d4efdd084785008146628e5d6f51ce80.tar.gz
gentoo-2-d919bfb9d4efdd084785008146628e5d6f51ce80.tar.bz2
gentoo-2-d919bfb9d4efdd084785008146628e5d6f51ce80.zip
unmasked, it's stable on 2.6 kernels and I want test it in the portage
Diffstat (limited to 'sys-cluster/ipvsadm/ipvsadm-1.24.ebuild')
-rw-r--r--sys-cluster/ipvsadm/ipvsadm-1.24.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/sys-cluster/ipvsadm/ipvsadm-1.24.ebuild b/sys-cluster/ipvsadm/ipvsadm-1.24.ebuild
index 736f1086b5ce..6ec34ac78dd1 100644
--- a/sys-cluster/ipvsadm/ipvsadm-1.24.ebuild
+++ b/sys-cluster/ipvsadm/ipvsadm-1.24.ebuild
@@ -1,34 +1,40 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/ipvsadm-1.24.ebuild,v 1.7 2005/01/21 18:14:37 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/ipvsadm-1.24.ebuild,v 1.8 2005/01/21 18:26:44 xmerlin Exp $
+inherit check-kernel
DESCRIPTION="ipvsadm is a utility to administer the IP virtual server services offered by the Linux kernel with IP virtual server support."
HOMEPAGE="http://linuxvirtualserver.org"
LICENSE="GPL-2"
DEPEND="virtual/libc
+ virtual/linux-sources
>=sys-libs/ncurses-5.2"
SRC_URI="http://www.linuxvirtualserver.org/software/kernel-2.5/${P}.tar.gz"
SLOT="0"
-KEYWORDS="-*"
+KEYWORDS="~x86"
IUSE=""
+pkg_setup() {
+ if is_2_4_kernel
+ then
+ die "${P} supports only 2.5 and 2.6 kernels, please try ${PN}-1.24 for 2.4 kernels"
+ fi
+}
+
+
src_compile() {
- cd "${S}"
- make || die
+ check_KV
+ make || die "error compiling source"
}
src_install() {
into /
- dosbin ipvsadm
- dosbin ipvsadm-save
- dosbin ipvsadm-restore
+ dosbin ipvsadm ipvsadm-save ipvsadm-restore || die
- doman ipvsadm.8
- doman ipvsadm-save.8
- doman ipvsadm-restore.8
+ doman ipvsadm.8 ipvsadm-save.8 ipvsadm-restore.8 || die
exeinto /etc/init.d
newexe ${FILESDIR}/ipvsadm-init ipvsadm
@@ -40,10 +46,10 @@ src_install() {
insopts -m 644 -o root -g root
insinto /usr/lib
- doins libipvs/libipvs.a
+ doins libipvs/libipvs.a || die
insinto /usr/include/ipvs
- newins libipvs/libipvs.h ipvs.h
+ newins libipvs/libipvs.h ipvs.h || die
einfo "You will need a kernel that has ipvs patches to use LVS."
einfo "This version is specicifically for 2.6 kernels."