summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-09-25 11:24:32 +0000
committerJustin Lecher <jlec@gentoo.org>2013-09-25 11:24:32 +0000
commit645bb3b8385699f2077eca208149696786e22fe6 (patch)
tree9737949cc0292a39ff12d9ec1f10494daf985291 /sys-cluster/maui
parentsys-cluster/maui: Add compatibility patch for torque-4, #479288 thanks Palmer... (diff)
downloadgentoo-2-645bb3b8385699f2077eca208149696786e22fe6.tar.gz
gentoo-2-645bb3b8385699f2077eca208149696786e22fe6.tar.bz2
gentoo-2-645bb3b8385699f2077eca208149696786e22fe6.zip
sys-cluster/maui: Add compatibility patch for torque-4, #479288 thanks Palmer Dabbelt for the patch
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-cluster/maui')
-rw-r--r--sys-cluster/maui/ChangeLog11
-rw-r--r--sys-cluster/maui/files/maui-3.3.1-torque_4.patch14
-rw-r--r--sys-cluster/maui/maui-3.3.1-r3.ebuild62
-rw-r--r--sys-cluster/maui/metadata.xml10
4 files changed, 90 insertions, 7 deletions
diff --git a/sys-cluster/maui/ChangeLog b/sys-cluster/maui/ChangeLog
index f85453b8e4b8..f0019bac8060 100644
--- a/sys-cluster/maui/ChangeLog
+++ b/sys-cluster/maui/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/maui
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.25 2011/10/31 10:30:09 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.26 2013/09/25 11:24:32 jlec Exp $
+
+*maui-3.3.1-r3 (25 Sep 2013)
+
+ 25 Sep 2013; Justin Lecher <jlec@gentoo.org> +maui-3.3.1-r3.ebuild,
+ +files/maui-3.3.1-torque_4.patch, metadata.xml:
+ Add compatibility patch for torque-4, #479288 thanks Palmer Dabbelt for the
+ patch
31 Oct 2011; Justin Lecher <jlec@gentoo.org> maui-3.3.1-r2.ebuild:
Fixed quoting
diff --git a/sys-cluster/maui/files/maui-3.3.1-torque_4.patch b/sys-cluster/maui/files/maui-3.3.1-torque_4.patch
new file mode 100644
index 000000000000..1e0631555736
--- /dev/null
+++ b/sys-cluster/maui/files/maui-3.3.1-torque_4.patch
@@ -0,0 +1,14 @@
+diff -ur maui-3.3.1.orig/src/moab/MPBSI.c maui-3.3.1/src/moab/MPBSI.c
+--- maui-3.3.1.orig/src/moab/MPBSI.c 2013-07-31 09:36:31.831849229 -0700
++++ maui-3.3.1/src/moab/MPBSI.c 2013-07-31 09:37:12.951107957 -0700
+@@ -174,8 +174,8 @@
+
+ extern int pbs_errno;
+
+-extern int get_svrport(const char *,char *,int);
+-extern int openrm(char *,int);
++extern unsigned int get_svrport(char *,char *,unsigned int);
++extern int openrm(char *,unsigned int);
+ extern int addreq(int,char *);
+ extern int closerm(int);
+ extern int pbs_stagein(int,char *,char *,char *);
diff --git a/sys-cluster/maui/maui-3.3.1-r3.ebuild b/sys-cluster/maui/maui-3.3.1-r3.ebuild
new file mode 100644
index 000000000000..97d0b6f4d29c
--- /dev/null
+++ b/sys-cluster/maui/maui-3.3.1-r3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.3.1-r3.ebuild,v 1.1 2013/09/25 11:24:32 jlec Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="Maui Cluster Scheduler"
+HOMEPAGE="http://www.clusterresources.com/pages/products/maui-cluster-scheduler.php"
+SRC_URI="http://www.adaptivecomputing.com/download/${PN}/${P}.tar.gz"
+
+LICENSE="maui"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="pbs slurm"
+
+REQUIRED_USE="^^ ( pbs slurm )"
+
+DEPEND="
+ pbs? ( >=sys-cluster/torque-4 )
+ slurm? ( sys-cluster/slurm )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="fetch mirror"
+
+pkg_setup() {
+ if use slurm; then
+ if [ -z ${MAUI_KEY} ]; then
+ eerror "You should set MAUI_KEY to any integer value in make.conf"
+ return 1
+ fi
+ fi
+}
+
+src_prepare() {
+ sed -e "s:\$(INST_DIR)/lib:\$(INST_DIR)/$(get_libdir):" \
+ -i src/{moab,server,mcom}/Makefile || die
+
+ epatch "${FILESDIR}"/${P}-torque_4.patch
+}
+
+src_configure() {
+ local myconf
+ use pbs && myconf="--with-pbs=${EPREFIX}/usr"
+ use slurm && myconf+=" --with-wiki --with-key=${MAUI_KEY}"
+ econf \
+ --with-spooldir="${EPREFIX}"/var/spool/${PN} \
+ ${myconf}
+}
+
+src_install() {
+ emake BUILDROOT="${D}" INST_DIR="${ED}/usr" install || die
+ dodoc docs/README CHANGELOG || die
+ dohtml docs/mauidocs.html || die
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
+}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}, obtain the file"
+ einfo "${P}.tar.gz and put it in ${DISTDIR}"
+}
diff --git a/sys-cluster/maui/metadata.xml b/sys-cluster/maui/metadata.xml
index 9db9d485077a..2d85b047fcca 100644
--- a/sys-cluster/maui/metadata.xml
+++ b/sys-cluster/maui/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>cluster</herd>
- <use>
- <flag name="pbs">Enable pbs integration</flag>
- <flag name="slurm">Enable slurm integration</flag>
- </use>
+ <herd>cluster</herd>
+ <use>
+ <flag name="pbs">Enable pbs integration</flag>
+ <flag name="slurm">Enable slurm integration</flag>
+ </use>
</pkgmetadata>