summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-03-24 22:20:30 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-03-24 22:20:30 +0000
commit0bd704f2c2e23a3c329081ebbd55795c57c76693 (patch)
tree3b9d5342c13552fffa54eb9ea538c6faba524586 /sys-cluster/pypvm/pypvm-0.94.ebuild
parentRemove few dev-java packages that were punted after last rites. (diff)
downloadgentoo-2-0bd704f2c2e23a3c329081ebbd55795c57c76693.tar.gz
gentoo-2-0bd704f2c2e23a3c329081ebbd55795c57c76693.tar.bz2
gentoo-2-0bd704f2c2e23a3c329081ebbd55795c57c76693.zip
Python module that allows interaction with the Parallel Virtual Machine (PVM) package.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-cluster/pypvm/pypvm-0.94.ebuild')
-rw-r--r--sys-cluster/pypvm/pypvm-0.94.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-cluster/pypvm/pypvm-0.94.ebuild b/sys-cluster/pypvm/pypvm-0.94.ebuild
new file mode 100644
index 000000000000..059427486e9d
--- /dev/null
+++ b/sys-cluster/pypvm/pypvm-0.94.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pypvm/pypvm-0.94.ebuild,v 1.1 2008/03/24 22:20:30 dberkholz Exp $
+
+inherit distutils multilib
+
+DESCRIPTION="Python module that allows interaction with the Parallel Virtual Machine (PVM) package"
+HOMEPAGE="http://pypvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND="sys-cluster/pvm"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local PVM_PREFIX="/usr/share/pvm3/"
+ local PVM_OS
+ case $(get_libdir) in
+ lib64) PVM_OS="LINUX64" ;;
+ lib) PVM_OS="LINUX" ;;
+ esac
+
+ ${python} setup.py build_ext \
+ --include-dirs ${PVM_PREFIX}/include \
+ --library-dirs ${PVM_PREFIX}/lib/${PVM_OS} \
+ || die
+ distutils_src_compile
+}