summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-11-10 07:02:22 +0000
committerIan Delaney <idella4@gentoo.org>2013-11-10 07:02:22 +0000
commit1fc94d1669f0ae62626459c29c94f07653f1fb0e (patch)
tree0412903f3328592c1a5c8c59bbf72ac8eec32a36 /sys-cluster/swift
parentVersion bump. (diff)
downloadgentoo-2-1fc94d1669f0ae62626459c29c94f07653f1fb0e.tar.gz
gentoo-2-1fc94d1669f0ae62626459c29c94f07653f1fb0e.tar.bz2
gentoo-2-1fc94d1669f0ae62626459c29c94f07653f1fb0e.zip
update of sorts to src_test, tidy up
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'sys-cluster/swift')
-rw-r--r--sys-cluster/swift/ChangeLog6
-rw-r--r--sys-cluster/swift/swift-1.10.0.ebuild28
-rw-r--r--sys-cluster/swift/swift-1.9.1.ebuild29
3 files changed, 19 insertions, 44 deletions
diff --git a/sys-cluster/swift/ChangeLog b/sys-cluster/swift/ChangeLog
index ded1a2a1bc2a..1d8468a64a7f 100644
--- a/sys-cluster/swift/ChangeLog
+++ b/sys-cluster/swift/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/swift
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.17 2013/10/29 05:29:57 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.18 2013/11/10 07:02:22 idella4 Exp $
+
+ 10 Nov 2013; Ian Delaney <idella4@gentoo.org> swift-1.10.0.ebuild,
+ swift-1.9.1.ebuild:
+ update of sorts to src_test, tidy up
*swift-1.10.0 (29 Oct 2013)
diff --git a/sys-cluster/swift/swift-1.10.0.ebuild b/sys-cluster/swift/swift-1.10.0.ebuild
index fbee073f8548..8b61d32158bc 100644
--- a/sys-cluster/swift/swift-1.10.0.ebuild
+++ b/sys-cluster/swift/swift-1.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.10.0.ebuild,v 1.1 2013/10/29 05:29:57 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.10.0.ebuild,v 1.2 2013/11/10 07:02:22 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -49,10 +49,6 @@ CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
~ZFS"
-src_test () {
- sh .unittests || die
-}
-
pkg_setup() {
enewuser swift
enewgroup swift
@@ -63,6 +59,12 @@ src_prepare() {
sed -i 's/xattr/pyxattr/g' "${S}/tools/pip-requires"
}
+src_test () {
+ # https://bugs.launchpad.net/swift/+bug/1249727
+ find . \( -name test_wsgi.py -o -name test_locale.py \) -delete || die
+ sh .unittests || die
+}
+
python_install() {
distutils-r1_python_install
keepdir /etc/swift
@@ -108,19 +110,3 @@ pkg_postinst() {
elog " * cd /etc/swift"
elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
}
-
-#src_install()
-#{
-# distutils_src_install
-#
-# dodir "/var/run/swift"
-#
-# if use proxy-server; then
-# newinitd "${FILESDIR}/swift-proxy-server.initd" swift-proxy-server
-# fi
-#
-# if use storage-server; then
-# newinitd "${FILESDIR}/swift-storage-server.initd" swift-storage-server
-# newconfd "${FILESDIR}/swift-storage-server.confd" swift-storage-server
-# fi
-#}
diff --git a/sys-cluster/swift/swift-1.9.1.ebuild b/sys-cluster/swift/swift-1.9.1.ebuild
index bfcc0a7384b4..25d5cd65fbfe 100644
--- a/sys-cluster/swift/swift-1.9.1.ebuild
+++ b/sys-cluster/swift/swift-1.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.9.1.ebuild,v 1.1 2013/08/13 16:07:23 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.9.1.ebuild,v 1.2 2013/11/10 07:02:22 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -49,11 +49,6 @@ CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
PATCHES=(
)
-# "${FILESDIR}/CVE-2013-2161.patch"
-
-src_test () {
- sh .unittests || die
-}
pkg_setup() {
enewuser swift
@@ -66,6 +61,12 @@ src_prepare() {
distutils-r1_python_prepare_all
}
+src_test () {
+ # https://bugs.launchpad.net/swift/+bug/1249727
+ find . \( -name test_wsgi.py -o -name test_locale.py \) -delete || die
+ sh .unittests || die
+}
+
python_install() {
distutils-r1_python_install
keepdir /etc/swift
@@ -111,19 +112,3 @@ pkg_postinst() {
elog " * cd /etc/swift"
elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
}
-
-#src_install()
-#{
-# distutils_src_install
-#
-# dodir "/var/run/swift"
-#
-# if use proxy-server; then
-# newinitd "${FILESDIR}/swift-proxy-server.initd" swift-proxy-server
-# fi
-#
-# if use storage-server; then
-# newinitd "${FILESDIR}/swift-storage-server.initd" swift-storage-server
-# newconfd "${FILESDIR}/swift-storage-server.confd" swift-storage-server
-# fi
-#}