summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-09-15 03:30:45 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-09-15 03:30:45 +0000
commit03a3d27a437a20e3448a9ede47e141508218be13 (patch)
treeb148c9eb5320272c6bdb1f29ea692d6ed4bcabaa /sys-cluster
parentupdate to nss-3.12.4 require pkgconfig in rdepend for nss-config --libdir,--i... (diff)
downloadgentoo-2-03a3d27a437a20e3448a9ede47e141508218be13.tar.gz
gentoo-2-03a3d27a437a20e3448a9ede47e141508218be13.tar.bz2
gentoo-2-03a3d27a437a20e3448a9ede47e141508218be13.zip
Updated with required patches to stop build failures with packages that
depend on mpi. (Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/ChangeLog9
-rw-r--r--sys-cluster/mpich2/files/mpich2-1.0.8-no-pvfs2.patch37
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.8-r1.ebuild (renamed from sys-cluster/mpich2/mpich2-1.0.8.ebuild)17
3 files changed, 60 insertions, 3 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index 75f0cb81f461..57f5bcdeb57a 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.39 2009/07/05 14:45:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.40 2009/09/15 03:30:45 nerdboy Exp $
+
+*mpich2-1.0.8-r1 (15 Sep 2009)
+
+ 15 Sep 2009; Steve Arnold <nerdboy@gentoo.org> -mpich2-1.0.8.ebuild,
+ +mpich2-1.0.8-r1.ebuild, +files/mpich2-1.0.8-no-pvfs2.patch:
+ Added back required patches needed for proper shared lib building.
+ (otherwise things like HDF5 barf with unresolved symbols)
05 Jul 2009; Markus Meier <maekke@gentoo.org> mpich2-1.0.8.ebuild:
amd64 stable, bug #266409
diff --git a/sys-cluster/mpich2/files/mpich2-1.0.8-no-pvfs2.patch b/sys-cluster/mpich2/files/mpich2-1.0.8-no-pvfs2.patch
new file mode 100644
index 000000000000..6e8b4403288f
--- /dev/null
+++ b/sys-cluster/mpich2/files/mpich2-1.0.8-no-pvfs2.patch
@@ -0,0 +1,37 @@
+--- src/mpi/romio/configure.orig 2009-09-14 17:30:33.267403501 -0700
++++ src/mpi/romio/configure 2009-09-14 17:39:40.079654437 -0700
+@@ -2033,6 +2033,12 @@
+ # Check whether --with-pvfs2 was given.
+ if test "${with_pvfs2+set}" = set; then
+ withval=$with_pvfs2;
++ if test "x$withval" = "xno" ; then
++ without_pvfs2=yes
++ with_pvfs2=""
++ fi
++else
++ without_pvfs2=yes
+ fi
+
+
+@@ -7577,11 +7583,16 @@
+ if test -n "${with_pvfs2}" -o -n "${file_system_pvfs2}" ; then
+ # the user either told us where pvfs is or asked for it in
+ # --with-file-system (or both)
+- CFLAGS="$CFLAGS $( $PVFS2_CONFIG --cflags)"
+- LIBS="$LIBS $( $PVFS2_CONFIG --libs)"
+- ROMIO_LIBLIST="$ROMIO_LIBLIST $LIBS"
+- FILE_SYSTEM="pvfs2 $FILE_SYSTEM"
+- file_system_pvfs2=1
++ if test "x$without_pvfs2" = "xyes" ; then
++ ROMIO_LIBLIST="$ROMIO_LIBLIST $LIBS"
++ file_system_pvfs2=0
++ else
++ CFLAGS="$CFLAGS $( $PVFS2_CONFIG --cflags)"
++ LIBS="$LIBS $( $PVFS2_CONFIG --libs)"
++ ROMIO_LIBLIST="$ROMIO_LIBLIST $LIBS"
++ FILE_SYSTEM="pvfs2 $FILE_SYSTEM"
++ file_system_pvfs2=1
++ fi
+ fi
+ fi
+
diff --git a/sys-cluster/mpich2/mpich2-1.0.8.ebuild b/sys-cluster/mpich2/mpich2-1.0.8-r1.ebuild
index 43dee079269a..79d994e832f9 100644
--- a/sys-cluster/mpich2/mpich2-1.0.8.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.8.ebuild,v 1.9 2009/07/05 14:45:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.8-r1.ebuild,v 1.1 2009/09/15 03:30:45 nerdboy Exp $
EAPI=1
inherit python eutils fortran autotools
@@ -11,7 +11,7 @@ SRC_URI="http://www.mcs.anl.gov/research/projects/mpich2/downloads/tarballs/${PV
LICENSE="as-is"
SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="+cxx debug doc fortran pvfs2 threads romio mpi-threads"
COMMON_DEPEND="dev-lang/perl
@@ -106,6 +106,19 @@ src_unpack() {
cat aclocal_mpd.m4 "${S}"/confdb/aclocal_subcfg.m4 > aclocal.m4
AT_M4DIR=${S}/confdb eautoreconf
popd >/dev/null
+
+ # Yes, we still need this to avoid unresolved symbols
+ # and related build errors (eg, with hdf5).
+ # TODO: Should probably send these upstream too...
+ epatch "${FILESDIR}"/${PN}-1.0.6-shlib.patch
+ epatch "${FILESDIR}"/${PN}-1.0.6-makefile.patch
+ sed -i -e "s:-Lnerdboy::g" Makefile.in || die "sed failed"
+ if use pvfs2; then
+ sed -i -e "s:-laio:-laio -lpvfs2:g" Makefile.in \
+ || die "sed pvfs2 failed"
+ else
+ epatch "${FILESDIR}"/${P}-no-pvfs2.patch
+ fi
}
src_compile() {