summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-08-04 15:47:03 +0000
committerYixun Lan <dlan@gentoo.org>2015-08-04 15:47:03 +0000
commitb5230e373e9dd60f74763a07cceb5bfd08b170b2 (patch)
treeb99f407e8e99b258afffde23694e4a733124e96e /sys-cluster
parentversion bump (diff)
downloadgentoo-2-b5230e373e9dd60f74763a07cceb5bfd08b170b2.tar.gz
gentoo-2-b5230e373e9dd60f74763a07cceb5bfd08b170b2.tar.bz2
gentoo-2-b5230e373e9dd60f74763a07cceb5bfd08b170b2.zip
backport cpp patch from upstream, fix bug 556406, 555270
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ChangeLog8
-rw-r--r--sys-cluster/ceph/ceph-0.80.10-r1.ebuild138
-rw-r--r--sys-cluster/ceph/ceph-0.87.2.ebuild3
-rw-r--r--sys-cluster/ceph/files/ceph-0.80.10-cpp-backport.patch50
4 files changed, 196 insertions, 3 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index cec0b00969d3..f3502855f80a 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.74 2015/07/15 08:57:51 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.75 2015/08/04 15:47:03 dlan Exp $
+
+*ceph-0.80.10-r1 (04 Aug 2015)
+
+ 04 Aug 2015; Yixun Lan <dlan@gentoo.org> +ceph-0.80.10-r1.ebuild,
+ ceph-0.87.2.ebuild, +files/ceph-0.80.10-cpp-backport.patch:
+ backport cpp patch from upstream, fix bug 556406, 555270
*ceph-0.94.2 (15 Jul 2015)
*ceph-0.87.2 (15 Jul 2015)
diff --git a/sys-cluster/ceph/ceph-0.80.10-r1.ebuild b/sys-cluster/ceph/ceph-0.80.10-r1.ebuild
new file mode 100644
index 000000000000..c6251a025f0d
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.80.10-r1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.80.10-r1.ebuild,v 1.1 2015/08/04 15:47:03 dlan Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="
+ git://github.com/ceph/ceph.git
+ https://github.com/ceph/ceph.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://ceph.com/download/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools eutils multilib python-any-r1 udev readme.gentoo ${scm_eclass}
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.com/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc xfs zfs"
+
+CDEPEND="
+ app-arch/snappy
+ <dev-libs/boost-1.56.0:=[threads]
+ dev-libs/fcgi
+ dev-libs/libaio
+ dev-libs/libedit
+ dev-libs/leveldb[snappy]
+ nss? ( dev-libs/nss )
+ cryptopp? ( dev-libs/crypto++ )
+ sys-apps/keyutils
+ sys-apps/util-linux
+ dev-libs/libxml2
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ xfs? ( sys-fs/xfsprogs )
+ zfs? ( sys-fs/zfs )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ net-misc/curl
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ $(python_gen_any_dep '
+ ' )
+ ${PYTHON_DEPS}
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-apps/hdparm
+ $(python_gen_any_dep '
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ' )"
+REQUIRED_USE="
+ ^^ ( nss cryptopp )
+ "
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.79-libzfs.patch
+ "${FILESDIR}"/${P}-cpp-backport.patch
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libaio) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with nss) \
+ $(use_with cryptopp) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc) \
+ $(use_with xfs libxfs) \
+ $(use_with zfs libzfs)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/ceph.logrotate ${PN}
+
+ chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd-r1" ${PN}
+
+ python_fix_shebang \
+ "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
+ "${ED}"/usr/bin/{ceph,ceph-rest-api}
+
+ #install udev rules
+ udev_dorules udev/50-rbd.rules
+ udev_dorules udev/95-ceph-osd.rules
+
+ readme.gentoo_create_doc
+}
diff --git a/sys-cluster/ceph/ceph-0.87.2.ebuild b/sys-cluster/ceph/ceph-0.87.2.ebuild
index 96760442f2a7..17ad373b65b3 100644
--- a/sys-cluster/ceph/ceph-0.87.2.ebuild
+++ b/sys-cluster/ceph/ceph-0.87.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.87.2.ebuild,v 1.1 2015/07/15 08:57:51 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.87.2.ebuild,v 1.2 2015/08/04 15:47:03 dlan Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -74,7 +74,6 @@ REQUIRED_USE="
STRIP_MASK="/usr/lib*/rados-classes/*"
PATCHES=(
- "${FILESDIR}"/${PN}-0.87.1-glibc-2.20.patch
"${FILESDIR}"/${PN}-0.79-libzfs.patch
)
diff --git a/sys-cluster/ceph/files/ceph-0.80.10-cpp-backport.patch b/sys-cluster/ceph/files/ceph-0.80.10-cpp-backport.patch
new file mode 100644
index 000000000000..ca79f0b6f483
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-0.80.10-cpp-backport.patch
@@ -0,0 +1,50 @@
+diff --git a/src/common/RWLock.h b/src/common/RWLock.h
+index 1a70ef1..2676ede 100644
+--- a/src/common/RWLock.h
++++ b/src/common/RWLock.h
+@@ -18,6 +18,7 @@
+ #define CEPH_RWLock_Posix__H
+
+ #include <pthread.h>
++#include "include/assert.h"
+ #include "lockdep.h"
+ #include "include/atomic.h"
+
+diff --git a/src/osd/ECBackend.cc b/src/osd/ECBackend.cc
+index 39e3429..64cd74f 100644
+--- a/src/osd/ECBackend.cc
++++ b/src/osd/ECBackend.cc
+@@ -13,7 +13,7 @@
+ */
+
+ #include <boost/variant.hpp>
+-#include <boost/optional.hpp>
++#include <boost/optional/optional_io.hpp>
+ #include <iostream>
+ #include <sstream>
+
+@@ -81,7 +81,7 @@ ostream &operator<<(ostream &lhs, const ECBackend::read_result_t &rhs)
+ lhs << "read_result_t(r=" << rhs.r
+ << ", errors=" << rhs.errors;
+ if (rhs.attrs) {
+- lhs << ", attrs=" << rhs.attrs;
++ lhs << ", attrs=" << rhs.attrs.get();
+ } else {
+ lhs << ", noattrs";
+ }
+diff --git a/src/osd/ReplicatedPG.cc b/src/osd/ReplicatedPG.cc
+index c8fb01e..b04f8f4 100644
+--- a/src/osd/ReplicatedPG.cc
++++ b/src/osd/ReplicatedPG.cc
+@@ -5065,7 +5065,10 @@ void ReplicatedPG::do_osd_op_effects(OpContext *ctx)
+ for (list<OpContext::NotifyAck>::iterator p = ctx->notify_acks.begin();
+ p != ctx->notify_acks.end();
+ ++p) {
+- dout(10) << "notify_ack " << make_pair(p->watch_cookie, p->notify_id) << dendl;
++ if (p->watch_cookie)
++ dout(10) << "notify_ack " << make_pair(p->watch_cookie.get(), p->notify_id) << dendl;
++ else
++ dout(10) << "notify_ack " << make_pair("NULL", p->notify_id) << dendl;
+ for (map<pair<uint64_t, entity_name_t>, WatchRef>::iterator i =
+ ctx->obc->watchers.begin();
+ i != ctx->obc->watchers.end();