summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-06-11 06:15:00 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-06-11 06:15:00 +0000
commitcf9c3fef710ba3f09fa89f22e883a50bea8c6cb2 (patch)
treea706455b6a81576d0bd514e8e605056bfbaaa1fa /sys-cluster
parentAdd java herd (diff)
downloadgentoo-2-cf9c3fef710ba3f09fa89f22e883a50bea8c6cb2.tar.gz
gentoo-2-cf9c3fef710ba3f09fa89f22e883a50bea8c6cb2.tar.bz2
gentoo-2-cf9c3fef710ba3f09fa89f22e883a50bea8c6cb2.zip
ploop version bump, thanks to slepnoga
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ploop/ChangeLog7
-rw-r--r--sys-cluster/ploop/ploop-1.7.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-cluster/ploop/ChangeLog b/sys-cluster/ploop/ChangeLog
index 3558358badcf..e3a1fc7f6633 100644
--- a/sys-cluster/ploop/ChangeLog
+++ b/sys-cluster/ploop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/ploop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.16 2013/06/03 11:36:06 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.17 2013/06/11 06:15:00 qnikst Exp $
+
+*ploop-1.7.1 (11 Jun 2013)
+
+ 11 Jun 2013; Alexander Vershilov <qnikst@gentoo.org> +ploop-1.7.1.ebuild:
+ ploop version bump, thanks to slepnoga
*ploop-1.7 (03 Jun 2013)
diff --git a/sys-cluster/ploop/ploop-1.7.1.ebuild b/sys-cluster/ploop/ploop-1.7.1.ebuild
new file mode 100644
index 000000000000..3e116af09728
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.7.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ploop-1.7.1.ebuild,v 1.1 2013/06/11 06:15:00 qnikst Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib systemd
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="http://wiki.openvz.org/Download/ploop"
+SRC_URI="http://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+DOCS=( tools/README )
+
+src_prepare() {
+ # Respect CFLAGS and CC, do not add debug by default
+ sed -i \
+ -e 's|CFLAGS =|CFLAGS +=|' \
+ -e '/CFLAGS/s/-g -O0 //' \
+ -e '/CFLAGS/s/-O2//' \
+ -e 's|CC=|CC?=|' \
+ -e 's/-Werror//' \
+ -e '/DEBUG=yes/d' \
+ -e '/LOCKDIR/s/var/run/' \
+ Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ epatch "${FILESDIR}/ploop-1.2-soname.patch"
+
+ # respect AR and RANLIB, bug #452092
+ tc-export AR RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' lib/Makefile || die 'sed on lib/Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 $(usex debug 'DEBUG' '' '=yes' '')
+}
+
+src_install() {
+ default
+ ldconfig -n "${D}/usr/$(get_libdir)/" || die
+ use static-libs || rm "${D}/usr/$(get_libdir)/libploop.a" || die 'remove static lib failed'
+}
+
+pkg_postinst() {
+ elog "Warning - API changes"
+ elog "1. This version requires running vzkernel >= 2.6.32-042stab061.1"
+ elog "2. DiskDescriptor.xml created by older ploop versions are converted to current format"
+}