summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-01-23 16:12:10 +0000
committerYixun Lan <dlan@gentoo.org>2014-01-23 16:12:10 +0000
commitdaa412ce112cff9b7c1b4826c9a7fe17d23d8a94 (patch)
tree29b6054a21de4c3171c23d71a022899f52714b24 /sys-cluster
parentRemove vulnerable versions wrt bug #498064 (diff)
downloadgentoo-2-daa412ce112cff9b7c1b4826c9a7fe17d23d8a94.tar.gz
gentoo-2-daa412ce112cff9b7c1b4826c9a7fe17d23d8a94.tar.bz2
gentoo-2-daa412ce112cff9b7c1b4826c9a7fe17d23d8a94.zip
use subslot, adjust deps, update to python-any-r1
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ChangeLog10
-rw-r--r--sys-cluster/ceph/ceph-0.67.5-r2.ebuild137
-rw-r--r--sys-cluster/ceph/ceph-0.72.2-r2.ebuild136
-rw-r--r--sys-cluster/ceph/ceph-0.75.ebuild136
-rw-r--r--sys-cluster/ceph/ceph-9999.ebuild40
-rw-r--r--sys-cluster/ceph/metadata.xml2
6 files changed, 447 insertions, 14 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 57af714a13da..6aebe43c36d1 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.43 2014/01/15 13:45:32 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.44 2014/01/23 16:12:10 dlan Exp $
+
+*ceph-0.75 (23 Jan 2014)
+*ceph-0.72.2-r2 (23 Jan 2014)
+*ceph-0.67.5-r2 (23 Jan 2014)
+
+ 23 Jan 2014; Yixun Lan <dlan@gentoo.org> +ceph-0.67.5-r2.ebuild,
+ +ceph-0.72.2-r2.ebuild, +ceph-0.75.ebuild, ceph-9999.ebuild, metadata.xml:
+ use subslot, adjust deps, update to python-any-r1
*ceph-0.67.5-r1 (15 Jan 2014)
*ceph-0.72.2-r1 (15 Jan 2014)
diff --git a/sys-cluster/ceph/ceph-0.67.5-r2.ebuild b/sys-cluster/ceph/ceph-0.67.5-r2.ebuild
new file mode 100644
index 000000000000..156db487e4d5
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.67.5-r2.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.67.5-r2.ebuild,v 1.1 2014/01/23 16:12:10 dlan Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="
+ git://github.com/ceph/ceph.git
+ https://github.com/ceph/ceph.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://ceph.com/download/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools eutils multilib python-any-r1 udev ${scm_eclass}
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.com/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc"
+
+CDEPEND="
+ app-arch/snappy
+ dev-libs/boost:=[threads]
+ dev-libs/fcgi
+ dev-libs/libaio
+ dev-libs/libedit
+ dev-libs/leveldb[snappy]
+ nss? ( dev-libs/nss )
+ cryptopp? ( dev-libs/crypto++ )
+ sys-apps/keyutils
+ sys-apps/util-linux
+ dev-libs/libxml2
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ net-misc/curl
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ $(python_gen_any_dep '
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ ' )
+ ${PYTHON_DEPS}
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-apps/hdparm
+ sys-block/parted
+ sys-fs/cryptsetup
+ sys-fs/btrfs-progs
+ $(python_gen_any_dep '
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ' )"
+REQUIRED_USE="
+ ^^ ( nss cryptopp )
+ ${PYTHON_REQUIRED_USE}
+ "
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [ ! -z ${PATCHES[@]} ]; then
+ epatch ${PATCHES[@]}
+ fi
+ sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
+ > "${T}"/${PN}.initd || die
+ sed -e '/^ceph_sbindir =/s:$(exec_prefix)::' -i src/Makefile.am || die
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libaio) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with nss) \
+ $(use_with cryptopp) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins src/logrotate.conf ${PN}
+
+ chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${T}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ _python_rewrite_shebang \
+ "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
+ "${ED}"/usr/bin/{ceph,ceph-rest-api}
+
+ #install udev rules
+ udev_dorules udev/50-rbd.rules
+ udev_dorules udev/95-ceph-osd.rules
+}
diff --git a/sys-cluster/ceph/ceph-0.72.2-r2.ebuild b/sys-cluster/ceph/ceph-0.72.2-r2.ebuild
new file mode 100644
index 000000000000..12f966749708
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.72.2-r2.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.72.2-r2.ebuild,v 1.1 2014/01/23 16:12:10 dlan Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="
+ git://github.com/ceph/ceph.git
+ https://github.com/ceph/ceph.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://ceph.com/download/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools eutils multilib python-any-r1 udev ${scm_eclass}
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.com/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc"
+
+CDEPEND="
+ app-arch/snappy
+ dev-libs/boost:=[threads]
+ dev-libs/fcgi
+ dev-libs/libaio
+ dev-libs/libedit
+ dev-libs/leveldb[snappy]
+ nss? ( dev-libs/nss )
+ cryptopp? ( dev-libs/crypto++ )
+ sys-apps/keyutils
+ sys-apps/util-linux
+ dev-libs/libxml2
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ net-misc/curl
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ $(python_gen_any_dep '
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ ' )
+ ${PYTHON_DEPS}
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-apps/hdparm
+ sys-block/parted
+ sys-fs/cryptsetup
+ sys-fs/btrfs-progs
+ $(python_gen_any_dep '
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ' )"
+REQUIRED_USE="
+ ^^ ( nss cryptopp )
+ ${PYTHON_REQUIRED_USE}
+ "
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [ ! -z ${PATCHES[@]} ]; then
+ epatch ${PATCHES[@]}
+ fi
+ sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
+ > "${T}"/${PN}.initd || die
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libaio) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with nss) \
+ $(use_with cryptopp) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins src/logrotate.conf ${PN}
+
+ chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${T}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ _python_rewrite_shebang \
+ "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
+ "${ED}"/usr/bin/{ceph,ceph-rest-api}
+
+ #install udev rules
+ udev_dorules udev/50-rbd.rules
+ udev_dorules udev/95-ceph-osd.rules
+}
diff --git a/sys-cluster/ceph/ceph-0.75.ebuild b/sys-cluster/ceph/ceph-0.75.ebuild
new file mode 100644
index 000000000000..c8d92c17e8ee
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.75.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.75.ebuild,v 1.1 2014/01/23 16:12:10 dlan Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="
+ git://github.com/ceph/ceph.git
+ https://github.com/ceph/ceph.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://ceph.com/download/${P}.tar.bz2"
+ KEYWORDS=""
+fi
+
+inherit autotools eutils multilib python-any-r1 udev ${scm_eclass}
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.com/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc"
+
+CDEPEND="
+ app-arch/snappy
+ dev-libs/boost:=[threads]
+ dev-libs/fcgi
+ dev-libs/libaio
+ dev-libs/libedit
+ dev-libs/leveldb[snappy]
+ nss? ( dev-libs/nss )
+ cryptopp? ( dev-libs/crypto++ )
+ sys-apps/keyutils
+ sys-apps/util-linux
+ dev-libs/libxml2
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ net-misc/curl
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ $(python_gen_any_dep '
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ ' )
+ ${PYTHON_DEPS}
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-apps/hdparm
+ sys-block/parted
+ sys-fs/cryptsetup
+ sys-fs/btrfs-progs
+ $(python_gen_any_dep '
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ' )"
+REQUIRED_USE="
+ ^^ ( nss cryptopp )
+ ${PYTHON_REQUIRED_USE}
+ "
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [ ! -z ${PATCHES[@]} ]; then
+ epatch ${PATCHES[@]}
+ fi
+ sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
+ > "${T}"/${PN}.initd || die
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libaio) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with nss) \
+ $(use_with cryptopp) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins src/logrotate.conf ${PN}
+
+ chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${T}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ _python_rewrite_shebang \
+ "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
+ "${ED}"/usr/bin/{ceph,ceph-rest-api}
+
+ #install udev rules
+ udev_dorules udev/50-rbd.rules
+ udev_dorules udev/95-ceph-osd.rules
+}
diff --git a/sys-cluster/ceph/ceph-9999.ebuild b/sys-cluster/ceph/ceph-9999.ebuild
index c718537c1d7e..804d92ee009d 100644
--- a/sys-cluster/ceph/ceph-9999.ebuild
+++ b/sys-cluster/ceph/ceph-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-9999.ebuild,v 1.6 2014/01/15 13:45:32 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-9999.ebuild,v 1.7 2014/01/23 16:12:10 dlan Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -17,30 +17,26 @@ else
KEYWORDS="~amd64 ~x86"
fi
-inherit autotools eutils multilib python-r1 udev ${scm_eclass}
+inherit autotools eutils multilib python-any-r1 udev ${scm_eclass}
DESCRIPTION="Ceph distributed filesystem"
HOMEPAGE="http://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="debug fuse gtk libatomic +libaio radosgw static-libs tcmalloc"
+IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc"
CDEPEND="
app-arch/snappy
- dev-libs/boost[threads]
+ dev-libs/boost:=[threads]
dev-libs/fcgi
dev-libs/libaio
dev-libs/libedit
dev-libs/leveldb[snappy]
- dev-libs/crypto++
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
+ nss? ( dev-libs/nss )
+ cryptopp? ( dev-libs/crypto++ )
sys-apps/keyutils
- sys-apps/hdparm
sys-apps/util-linux
- sys-block/parted
- sys-fs/cryptsetup
dev-libs/libxml2
fuse? ( sys-fs/fuse )
libatomic? ( dev-libs/libatomic_ops )
@@ -55,17 +51,33 @@ CDEPEND="
net-misc/curl
)
tcmalloc? ( dev-util/google-perftools )
+ $(python_gen_any_dep '
virtual/python-argparse[${PYTHON_USEDEP}]
+ ' )
${PYTHON_DEPS}
"
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
- sys-fs/btrfs-progs"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+ sys-apps/hdparm
+ sys-block/parted
+ sys-fs/cryptsetup
+ sys-fs/btrfs-progs
+ $(python_gen_any_dep '
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ' )"
+REQUIRED_USE="
+ ^^ ( nss cryptopp )
+ ${PYTHON_REQUIRED_USE}
+ "
STRIP_MASK="/usr/lib*/rados-classes/*"
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
src_prepare() {
if [ ! -z ${PATCHES[@]} ]; then
epatch ${PATCHES[@]}
@@ -86,6 +98,8 @@ src_configure() {
$(use_with fuse) \
$(use_with libaio) \
$(use_with libatomic libatomic-ops) \
+ $(use_with nss) \
+ $(use_with cryptopp) \
$(use_with radosgw) \
$(use_with gtk gtk2) \
$(use_enable static-libs static) \
@@ -112,7 +126,7 @@ src_install() {
newinitd "${T}/${PN}.initd" ${PN}
newconfd "${FILESDIR}/${PN}.confd" ${PN}
- python_replicate_script \
+ _python_rewrite_shebang \
"${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
"${ED}"/usr/bin/{ceph,ceph-rest-api}
diff --git a/sys-cluster/ceph/metadata.xml b/sys-cluster/ceph/metadata.xml
index ca60e61af651..350ee821ff70 100644
--- a/sys-cluster/ceph/metadata.xml
+++ b/sys-cluster/ceph/metadata.xml
@@ -11,9 +11,11 @@
Ceph is a distributed network file system designed to provide excellent performance, reliability, and scalability.
</longdescription>
<use>
+ <flag name='cryptopp'>Use <pkg>dev-libs/crypto++</pkg> for cryptography</flag>
<flag name='fuse'>Build fuse client</flag>
<flag name='libatomic'>Use libatomic instead of builtin atomic operations</flag>
<flag name='libaio'>Use libaio as asynchronous input/output library</flag>
+ <flag name='nss'>Use <pkg>dev-libs/nss</pkg> for cryptography</flag>
<flag name='radosgw'>Add radosgw support</flag>
</use>
</pkgmetadata>