summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-21 15:08:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-21 15:08:51 +0000
commitff9bdace3301d0fc3bd4cb1df8e75bc8effe4c3b (patch)
tree69094bf9d0ec66ec066b03735d37b8d1e42a829f /sys-cluster
parentStable for HPPA (bug #422673). (diff)
downloadgentoo-2-ff9bdace3301d0fc3bd4cb1df8e75bc8effe4c3b.tar.gz
gentoo-2-ff9bdace3301d0fc3bd4cb1df8e75bc8effe4c3b.tar.bz2
gentoo-2-ff9bdace3301d0fc3bd4cb1df8e75bc8effe4c3b.zip
Remove old and fix append-cppflags.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/gearmand/ChangeLog6
-rw-r--r--sys-cluster/gearmand/files/gearmand.init.d92
-rw-r--r--sys-cluster/gearmand/gearmand-0.12.ebuild100
-rw-r--r--sys-cluster/gearmand/gearmand-0.14.ebuild94
-rw-r--r--sys-cluster/gearmand/gearmand-0.24.ebuild92
5 files changed, 5 insertions, 379 deletions
diff --git a/sys-cluster/gearmand/ChangeLog b/sys-cluster/gearmand/ChangeLog
index 82f18f4c9797..cd7b359ac699 100644
--- a/sys-cluster/gearmand/ChangeLog
+++ b/sys-cluster/gearmand/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/gearmand
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.14 2012/06/21 14:43:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.15 2012/06/21 15:08:50 flameeyes Exp $
+
+ 21 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org> -files/gearmand.init.d,
+ -gearmand-0.12.ebuild, -gearmand-0.14.ebuild, -gearmand-0.24.ebuild:
+ Remove old and fix append-cppflags.
21 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+files/gearmand-0.33+gcc-4.7.patch, gearmand-0.33.ebuild:
diff --git a/sys-cluster/gearmand/files/gearmand.init.d b/sys-cluster/gearmand/files/gearmand.init.d
deleted file mode 100644
index 50414a77d45b..000000000000
--- a/sys-cluster/gearmand/files/gearmand.init.d
+++ /dev/null
@@ -1,92 +0,0 @@
-#!/sbin/runscript
-# Copyright 2009-2010 Pavel Stratil, senbonzakura.eu
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- use localmount
-
- case $PERSISTENT in
- drizzle)
- use drizzle
- ;;
- memcache)
- use memcache
- ;;
- mysql)
- use mysql
- ;;
- postgre)
- use postgresql
- ;;
- *)
- ;;
- esac
-}
-
-start() {
- case ${PERSISTENT:-none} in
- drizzle|mysql)
- GEARMAND_PARAMS="${GEARMAND_PARAMS} -q libdrizzle"
- [ ${PERSISTENT_HOST} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libdrizzle-host=${PERSISTENT_HOST}"
- [ ${PERSISTENT_USER} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libdrizzle-user=${PERSISTENT_USER}"
- [ ${PERSISTENT_PASS} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libdrizzle-password=${PERSISTENT_PASS}"
- [ ${PERSISTENT_DB} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libdrizzle-db=${PERSISTENT_DB}"
- [ ${PERSISTENT_TABLE} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libdrizzle-table=${PERSISTENT_TABLE}"
- [ ${PERSISTENT_PORT} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libdrizzle-port=${PERSISTENT_PORT}"
- [ ${PERSISTENT_SOCKET} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libdrizzle-uds=${PERSISTENT_SOCKET}"
- [ ${PERSISTENT} == "mysql" ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libdrizzle-mysql"
- ;;
- memcache)
- [ ${PERSISTENT_SERVERLIST} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} -q libmemcached --libmemcached-servers=${PERSISTENT_SERVERLIST}"
- ;;
- postgre)
- GEARMAND_PARAMS="${GEARMAND_PARAMS} -q libpq"
- [ ${PERSISTENT_HOST} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libpq-host=${PERSISTENT_HOST}"
- [ ${PERSISTENT_USER} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libpq-user=${PERSISTENT_USER}"
- [ ${PERSISTENT_PASS} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libpq-password=${PERSISTENT_PASS}"
- [ ${PERSISTENT_DB} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libpq-dbname=${PERSISTENT_DB}"
- [ ${PERSISTENT_PORT} ] && GEARMAND_PARAMS="${GEARMAND_PARAMS} --libpq-port=${PERSISTENT_PORT}"
- [ ${PERSISTENT_TABLE} ] && ewarn "Libpq doesn't recognise 'table' parameter."
- [ ${PERSISTENT_SOCKET} ] && ewarn "Libpq doesn't recognise 'socket' parameter. If no host is set, it automatically falls back to a socket."
- ;;
- tokyocabinet)
- GEARMAND_PARAMS="${GEARMAND_PARAMS} -q libtokyocabinet --libtokyocabinet-file=${PERSISTENT_FILE}"
- ;;
- sqlite)
- GEARMAND_PARAMS="${GEARMAND_PARAMS} -q libsqlite3 --libsqlite3-db=${PERSISTENT_FILE}"
- ;;
- none)
- ;;
- *)
- eerror "Wrong persistent queue store setting in /etc/conf.d/gearmand."
- return 1
- ;;
- esac
-
-
- if [ ! -d /var/run/gearmand ] ; then
- mkdir -p /var/run/gearmand
- chown gearmand:nogroup /var/run/gearmand
- chmod 0755 /var/run/gearmand
- fi
-
- if [ ! -d /var/log/gearmand ] ; then
- mkdir -p /var/log/gearmand
- chown gearmand:nogroup /var/log/gearmand
- chmod 0755 /var/log/gearmand
- fi
-
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --pidfile /var/run/gearmand/gearmand.pid --start \
- --exec /usr/sbin/gearmand -- --pid-file=/var/run/gearmand/gearmand.pid \
- --user=gearmand --daemon \
- --log-file=/var/log/gearmand/gearmand.log ${GEARMAND_PARAMS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --pidfile /var/run/gearmand/gearmand.pid --stop \
- --exec /usr/sbin/gearmand
- eend $?
-}
diff --git a/sys-cluster/gearmand/gearmand-0.12.ebuild b/sys-cluster/gearmand/gearmand-0.12.ebuild
deleted file mode 100644
index ebaec6cba91a..000000000000
--- a/sys-cluster/gearmand/gearmand-0.12.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.12.ebuild,v 1.4 2010/10/15 14:59:29 flameeyes Exp $
-
-EAPI=2
-
-inherit flag-o-matic libtool
-
-DESCRIPTION="Generic framework to farm out work to other machines"
-HOMEPAGE="http://www.gearman.org/"
-SRC_URI="http://launchpad.net/gearmand/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug tcmalloc +memcache drizzle sqlite tokyocabinet" # postgres
-# postgresql support is broken right now so keep it disabled
-
-RDEPEND="dev-libs/libevent
- || ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
- tcmalloc? ( dev-util/google-perftools )
- memcache? ( dev-libs/libmemcached )
- drizzle? ( dev-db/drizzle )
- sqlite? ( dev-db/sqlite:3 )
- tokyocabinet? ( dev-db/tokyocabinet )"
- #postgres? ( dev-db/postgresql-base )"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- enewuser gearmand -1 -1 /dev/null nogroup
-}
-
-src_prepare() {
- elibtoolize
-}
-
-src_configure() {
- # Don't ever use --enable-assert since configure.ac is broken, and
- # only does --disable-assert correctly.
- if use debug; then
- # Since --with-debug would turn off optimisations as well as
- # enabling debug, we just enable debug through the
- # preprocessor then.
- append-flags -DDEBUG
-
- else
- myconf="${myconf} --disable-assert"
- fi
-
- #$(use_enable postgres libpq)
- econf \
- --disable-static \
- --disable-dependency-tracking \
- --disable-mtmalloc \
- --disable-libpq \
- $(use_enable tcmalloc) \
- $(use_enable memcache libmemcached) \
- $(use_enable drizzle libdrizzle) \
- $(use_enable sqlite libsqlite3) \
- $(use_enable tokyocabinet libtokyocabinet)
-}
-
-src_test() {
- # Since libtool is stupid and doesn't discard /usr/lib64 from the
- # load path, we'd end up testing against the installed copy of
- # gearmand (bad).
- #
- # We thus cheat and "fix" the scripts by hand.
- sed -i -e '/LD_LIBRARY_PATH=/s|/usr/lib64:||' "${S}"/tests/*_test \
- || die "test fixing failed"
-
- emake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
-
- dodoc README AUTHORS ChangeLog || die "dodoc failed"
-
- newinitd "${FILESDIR}"/gearmand.init.d gearmand || die
- newconfd "${FILESDIR}"/gearmand.conf.d gearmand || die
-
- keepdir /var/run/gearmand || die
- fperms 0755 /var/run/gearmand || die
- fowners gearmand:nogroup /var/run/gearmand || die
-
- keepdir /var/log/gearmand || die
- fperms 0755 /var/log/gearmand || die
- fowners gearmand /var/log/gearmand || die
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog ""
- elog "Unless you set the PERSISTENT_TABLE option in"
- elog "/etc/conf.d/gearmand, Gearmand will use table 'queue'."
- elog "If such table doesn't exist, Gearmand will create it for you"
- elog ""
-}
diff --git a/sys-cluster/gearmand/gearmand-0.14.ebuild b/sys-cluster/gearmand/gearmand-0.14.ebuild
deleted file mode 100644
index 53783011c8e1..000000000000
--- a/sys-cluster/gearmand/gearmand-0.14.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.14.ebuild,v 1.3 2010/10/15 14:59:29 flameeyes Exp $
-
-EAPI=2
-
-inherit flag-o-matic libtool
-
-DESCRIPTION="Generic framework to farm out work to other machines"
-HOMEPAGE="http://www.gearman.org/"
-SRC_URI="http://launchpad.net/gearmand/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug tcmalloc +memcache drizzle sqlite tokyocabinet" # postgres
-# postgresql support is broken right now so keep it disabled
-RESTRICT="test"
-# restricting tests because of failures, package runs fine
-
-RDEPEND="dev-libs/libevent
- || ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
- tcmalloc? ( dev-util/google-perftools )
- memcache? ( dev-libs/libmemcached )
- drizzle? ( dev-db/drizzle )
- sqlite? ( dev-db/sqlite:3 )
- tokyocabinet? ( dev-db/tokyocabinet )"
- #postgres? ( dev-db/postgresql-base )"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- enewuser gearmand -1 -1 /dev/null nogroup
-}
-
-src_prepare() {
- elibtoolize
-}
-
-src_configure() {
- # Don't ever use --enable-assert since configure.ac is broken, and
- # only does --disable-assert correctly.
- if use debug; then
- # Since --with-debug would turn off optimisations as well as
- # enabling debug, we just enable debug through the
- # preprocessor then.
- append-flags -DDEBUG
-
- else
- myconf="${myconf} --disable-assert"
- fi
-
- #$(use_enable postgres libpq)
- econf \
- --disable-static \
- --disable-dependency-tracking \
- --disable-mtmalloc \
- --disable-libpq \
- $(use_enable tcmalloc) \
- $(use_enable memcache libmemcached) \
- $(use_enable drizzle libdrizzle) \
- $(use_enable sqlite libsqlite3) \
- $(use_enable tokyocabinet libtokyocabinet)
-}
-
-src_test() {
- # Since libtool is stupid and doesn't discard /usr/lib64 from the
- # load path, we'd end up testing against the installed copy of
- # gearmand (bad).
- #
- # We thus cheat and "fix" the scripts by hand.
- sed -i -e '/LD_LIBRARY_PATH=/s|/usr/lib64:||' "${S}"/tests/*_test \
- || die "test fixing failed"
-
- emake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
-
- dodoc README AUTHORS ChangeLog || die "dodoc failed"
-
- newinitd "${FILESDIR}"/gearmand.init.d gearmand || die
- newconfd "${FILESDIR}"/gearmand.conf.d gearmand || die
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog ""
- elog "Unless you set the PERSISTENT_TABLE option in"
- elog "/etc/conf.d/gearmand, Gearmand will use table 'queue'."
- elog "If such table doesn't exist, Gearmand will create it for you"
- elog ""
-}
diff --git a/sys-cluster/gearmand/gearmand-0.24.ebuild b/sys-cluster/gearmand/gearmand-0.24.ebuild
deleted file mode 100644
index d3276ca25015..000000000000
--- a/sys-cluster/gearmand/gearmand-0.24.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.24.ebuild,v 1.1 2011/10/22 00:31:33 flameeyes Exp $
-
-EAPI=2
-
-inherit flag-o-matic libtool
-
-DESCRIPTION="Generic framework to farm out work to other machines"
-HOMEPAGE="http://www.gearman.org/"
-SRC_URI="http://launchpad.net/gearmand/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug tcmalloc +memcache drizzle sqlite tokyocabinet postgres"
-
-RESTRICT="test"
-# restricting tests because of failures, package runs fine
-
-RDEPEND="dev-libs/libevent
- || ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
- tcmalloc? ( dev-util/google-perftools )
- memcache? ( >=dev-libs/libmemcached-0.47 )
- drizzle? ( dev-db/drizzle )
- sqlite? ( dev-db/sqlite:3 )
- tokyocabinet? ( dev-db/tokyocabinet )
- postgres? ( dev-db/postgresql-base:9.0 )"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- enewuser gearmand -1 -1 /dev/null nogroup
-}
-
-src_prepare() {
- elibtoolize
-}
-
-src_configure() {
- # Don't ever use --enable-assert since configure.ac is broken, and
- # only does --disable-assert correctly.
- if use debug; then
- # Since --with-debug would turn off optimisations as well as
- # enabling debug, we just enable debug through the
- # preprocessor then.
- append-flags -DDEBUG
- else
- myconf="${myconf} --disable-assert"
- fi
-
- econf \
- --disable-static \
- --disable-dependency-tracking \
- --disable-mtmalloc \
- $(use_enable tcmalloc) \
- $(use_enable memcache libmemcached) \
- $(use_enable drizzle libdrizzle) \
- $(use_enable sqlite libsqlite3) \
- $(use_enable tokyocabinet libtokyocabinet) \
- $(use_enable postgres libpq)
-}
-
-src_test() {
- # Since libtool is stupid and doesn't discard /usr/lib64 from the
- # load path, we'd end up testing against the installed copy of
- # gearmand (bad).
- #
- # We thus cheat and "fix" the scripts by hand.
- sed -i -e '/LD_LIBRARY_PATH=/s|/usr/lib64:||' "${S}"/tests/*_test \
- || die "test fixing failed"
-
- emake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
-
- dodoc README AUTHORS ChangeLog || die "dodoc failed"
-
- newinitd "${FILESDIR}"/gearmand.init.d gearmand || die
- newconfd "${FILESDIR}"/gearmand.conf.d gearmand || die
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog ""
- elog "Unless you set the PERSISTENT_TABLE option in"
- elog "/etc/conf.d/gearmand, Gearmand will use table 'queue'."
- elog "If such table doesn't exist, Gearmand will create it for you"
- elog ""
-}