summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-15 23:08:03 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-15 23:08:03 +0000
commitd8fc2992a26900cd2e937da5900fd8466d32277b (patch)
tree6a781b2034060c65770b8d89d49b47c78b511242 /sys-devel/autoconf/autoconf-2.13.ebuild
parentAdd prefix support and keywords (diff)
downloadgentoo-2-d8fc2992a26900cd2e937da5900fd8466d32277b.tar.gz
gentoo-2-d8fc2992a26900cd2e937da5900fd8466d32277b.tar.bz2
gentoo-2-d8fc2992a26900cd2e937da5900fd8466d32277b.zip
Force C locale when running configure to work around old bugs fixed in newer versions of autoconf #351982 by Priit Laes.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/autoconf/autoconf-2.13.ebuild')
-rw-r--r--sys-devel/autoconf/autoconf-2.13.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-devel/autoconf/autoconf-2.13.ebuild b/sys-devel/autoconf/autoconf-2.13.ebuild
index cb8e7e0e0bd1..6399cf204ced 100644
--- a/sys-devel/autoconf/autoconf-2.13.ebuild
+++ b/sys-devel/autoconf/autoconf-2.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.13.ebuild,v 1.18 2008/06/21 06:27:48 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.13.ebuild,v 1.19 2011/03/15 23:08:03 vapier Exp $
inherit eutils
@@ -38,6 +38,10 @@ src_unpack() {
src_compile() {
# need to include --exec-prefix and --bindir or our
# DESTDIR patch will trigger sandbox hate :(
+ #
+ # need to force locale to C to avoid bugs in the old
+ # configure script breaking the install paths #351982
+ LC_ALL=C \
econf \
--exec-prefix=/usr \
--bindir=/usr/bin \
@@ -49,8 +53,7 @@ src_compile() {
src_install() {
emake install DESTDIR="${D}" || die
- dodoc AUTHORS NEWS README TODO \
- ChangeLog ChangeLog.0 ChangeLog.1
+ dodoc AUTHORS NEWS README TODO ChangeLog ChangeLog.0 ChangeLog.1
mv "${D}"/usr/share/info/autoconf{,-${PV}}.info
}