summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-04-27 02:28:16 +0000
committerMike Frysinger <vapier@gentoo.org>2014-04-27 02:28:16 +0000
commit215476b2836c8c5e976f510609f9d4f99356c394 (patch)
tree8d0a6bf0049534bb41e05897f007770391a912a2 /sys-devel/autogen
parentMask gnome-extra/evolution-kolab as gnome3.8 was removed (diff)
downloadgentoo-2-215476b2836c8c5e976f510609f9d4f99356c394.tar.gz
gentoo-2-215476b2836c8c5e976f510609f9d4f99356c394.tar.bz2
gentoo-2-215476b2836c8c5e976f510609f9d4f99356c394.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/autogen')
-rw-r--r--sys-devel/autogen/ChangeLog9
-rw-r--r--sys-devel/autogen/autogen-5.18.2.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/sys-devel/autogen/ChangeLog b/sys-devel/autogen/ChangeLog
index a2fda65564d7..e2bf10cab3de 100644
--- a/sys-devel/autogen/ChangeLog
+++ b/sys-devel/autogen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/autogen
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/ChangeLog,v 1.98 2013/12/02 10:18:43 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/ChangeLog,v 1.99 2014/04/27 02:28:16 vapier Exp $
+
+*autogen-5.18.2 (27 Apr 2014)
+
+ 27 Apr 2014; Mike Frysinger <vapier@gentoo.org> +autogen-5.18.2.ebuild:
+ Version bump.
*autogen-5.18.1 (02 Dec 2013)
diff --git a/sys-devel/autogen/autogen-5.18.2.ebuild b/sys-devel/autogen/autogen-5.18.2.ebuild
new file mode 100644
index 000000000000..57da95103d1a
--- /dev/null
+++ b/sys-devel/autogen/autogen-5.18.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/autogen-5.18.2.ebuild,v 1.1 2014/04/27 02:28:16 vapier Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Program and text file generation"
+HOMEPAGE="http://www.gnu.org/software/autogen/"
+SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="libopts static-libs"
+
+RDEPEND=">=dev-scheme/guile-1.8
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # suppress possibly incorrect -R flag
+ export ag_cv_test_ldflags=
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if ! use libopts ; then
+ rm "${ED}"/usr/share/autogen/libopts-*.tar.gz || die
+ fi
+}