summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-04-04 22:15:06 +0000
committerMike Frysinger <vapier@gentoo.org>2013-04-04 22:15:06 +0000
commit45f3171af0bd5ae6ee24bee650f1d5baec8e72d8 (patch)
tree819e65dff5cbaefe78ed93373485f28872a33ec8 /sys-devel/automake/automake-1.6.3-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-45f3171af0bd5ae6ee24bee650f1d5baec8e72d8.tar.gz
gentoo-2-45f3171af0bd5ae6ee24bee650f1d5baec8e72d8.tar.bz2
gentoo-2-45f3171af0bd5ae6ee24bee650f1d5baec8e72d8.zip
Redo how we slot the info pages to avoid regenerating them from source #464146 by Denys Dmytriyenko.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-devel/automake/automake-1.6.3-r1.ebuild')
-rw-r--r--sys-devel/automake/automake-1.6.3-r1.ebuild43
1 files changed, 34 insertions, 9 deletions
diff --git a/sys-devel/automake/automake-1.6.3-r1.ebuild b/sys-devel/automake/automake-1.6.3-r1.ebuild
index b97eedb143b9..ef9bb5541c28 100644
--- a/sys-devel/automake/automake-1.6.3-r1.ebuild
+++ b/sys-devel/automake/automake-1.6.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.3-r1.ebuild,v 1.8 2012/01/19 20:55:45 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.3-r1.ebuild,v 1.9 2013/04/04 22:15:06 vapier Exp $
inherit eutils
@@ -13,31 +13,56 @@ SLOT="${PV:0:3}"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE=""
-DEPEND="dev-lang/perl
+RDEPEND="dev-lang/perl
sys-devel/automake-wrapper
>=sys-devel/autoconf-2.59-r6
sys-devel/gnuconfig"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i \
- -e "/^@setfilename/s|automake|automake${SLOT}|" \
- -e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
- -e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
- automake.texi || die "sed failed"
epatch "${FILESDIR}"/${P}-test-fixes.patch #159557
epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
epatch "${FILESDIR}"/${PN}-1.5-CVE-2009-4029.patch #295357
export WANT_AUTOCONF=2.5
}
+# slot the info pages. do this w/out munging the source so we don't have
+# to depend on texinfo to regen things. #464146 (among others)
+slot_info_pages() {
+ pushd "${D}"/usr/share/info >/dev/null
+ rm -f dir
+
+ # Rewrite all the references to other pages.
+ # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
+ # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
+ local p pages=( *.info ) args=()
+ for p in "${pages[@]/%.info}" ; do
+ args+=(
+ -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
+ -e "s:(${p}):(${p}-${SLOT}):g"
+ )
+ done
+ sed -i "${args[@]}" * || die
+
+ # Rewrite all the file references, and rename them in the process.
+ local f d
+ for f in * ; do
+ d=${f/.info/-${SLOT}.info}
+ mv "${f}" "${d}" || die
+ sed -i -e "s:${f}:${d}:g" * || die
+ done
+
+ popd >/dev/null
+}
+
src_install() {
emake DESTDIR="${D}" install || die
+ slot_info_pages
rm -f "${D}"/usr/bin/{aclocal,automake}
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
- doinfo *.info
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version