summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2004-11-07 22:56:00 +0000
committerKito Danya Dietrich <kito@gentoo.org>2004-11-07 22:56:00 +0000
commit4e5460d4ba41aaef083fe69626f4ee55316c1e15 (patch)
treed1d58ee37ff4efc77c205db8acff8786b6d6f0c6 /sys-devel/cctools-extras
parentStable amd64, x86. (Manifest recommit) (diff)
downloadgentoo-2-4e5460d4ba41aaef083fe69626f4ee55316c1e15.tar.gz
gentoo-2-4e5460d4ba41aaef083fe69626f4ee55316c1e15.tar.bz2
gentoo-2-4e5460d4ba41aaef083fe69626f4ee55316c1e15.zip
cctools-extras inital commit
Diffstat (limited to 'sys-devel/cctools-extras')
-rw-r--r--sys-devel/cctools-extras/ChangeLog10
-rw-r--r--sys-devel/cctools-extras/Manifest6
-rw-r--r--sys-devel/cctools-extras/cctools-extras-495.8.ebuild34
-rw-r--r--sys-devel/cctools-extras/cctools-extras-525.ebuild35
-rw-r--r--sys-devel/cctools-extras/files/digest-cctools-extras-495.81
-rw-r--r--sys-devel/cctools-extras/files/digest-cctools-extras-5251
-rw-r--r--sys-devel/cctools-extras/metadata.xml8
7 files changed, 95 insertions, 0 deletions
diff --git a/sys-devel/cctools-extras/ChangeLog b/sys-devel/cctools-extras/ChangeLog
new file mode 100644
index 000000000000..e733bed87123
--- /dev/null
+++ b/sys-devel/cctools-extras/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-devel/cctools-extras
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/cctools-extras/ChangeLog,v 1.1 2004/11/07 22:56:00 kito Exp $
+
+*cctools-extras-525 (07 Nov 2004)
+
+ 07 Nov 2004; Kito <kito@gentoo.org> +cctools-extras-495.8.ebuild,
+ +cctools-extras-525.ebuild:
+ cctools-extras initial commit
+
diff --git a/sys-devel/cctools-extras/Manifest b/sys-devel/cctools-extras/Manifest
new file mode 100644
index 000000000000..2e095585ead8
--- /dev/null
+++ b/sys-devel/cctools-extras/Manifest
@@ -0,0 +1,6 @@
+MD5 6284e262ce2ed2b3531a796bfa2ac01b ChangeLog 291
+MD5 157fc0f8714d18fa02e23a12d74c13ac cctools-extras-495.8.ebuild 873
+MD5 64f24d9953be0f079d77f40c0b53335d cctools-extras-525.ebuild 893
+MD5 e526e84277cb8eb1bcf73840117ff45a metadata.xml 220
+MD5 fa2bd3a13c7f1219adb4f11850b94fb6 files/digest-cctools-extras-495.8 66
+MD5 7224fbe051fc8939e6ddeb9c73055e35 files/digest-cctools-extras-525 64
diff --git a/sys-devel/cctools-extras/cctools-extras-495.8.ebuild b/sys-devel/cctools-extras/cctools-extras-495.8.ebuild
new file mode 100644
index 000000000000..720bd81ecc14
--- /dev/null
+++ b/sys-devel/cctools-extras/cctools-extras-495.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/cctools-extras/cctools-extras-495.8.ebuild,v 1.1 2004/11/07 22:56:00 kito Exp $
+
+DESCRIPTION="Extra cctools utils"
+HOMEPAGE="http://darwinsource.opendarwin.org/"
+SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/cctools-${PV}.tar.gz"
+
+LICENSE="APSL-2"
+
+SLOT="0"
+KEYWORDS="~ppc-macos"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ cd ${WORKDIR}/cctools-${PV}
+ rm -rf ar as cbtlibs dyld file gprof ld libdyld libmacho mkshlib otool
+ make SUBDIRS="libstuff misc" || die "make failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/cctools-${PV}/misc
+ newbin check_dylib.NEW check_dylib
+ newbin checksyms.NEW checksyms
+ newbin dylib_pcsampler.NEW dylib_pcsampler
+ newbin indr.NEW indr
+ newbin seg_addr_table.NEW seg_addr_table
+ newbin seg_hack.NEW seg_hack
+
+ cd ${WORKDIR}/cctools-${PV}/man
+ doman {check_dylib.1,checksyms.1,indr.1,seg_addr_table.1}
+} \ No newline at end of file
diff --git a/sys-devel/cctools-extras/cctools-extras-525.ebuild b/sys-devel/cctools-extras/cctools-extras-525.ebuild
new file mode 100644
index 000000000000..028d7e4ea035
--- /dev/null
+++ b/sys-devel/cctools-extras/cctools-extras-525.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/cctools-extras/cctools-extras-525.ebuild,v 1.1 2004/11/07 22:56:00 kito Exp $
+
+DESCRIPTION="Extra cctools utils"
+HOMEPAGE="http://darwinsource.opendarwin.org/"
+SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/cctools-${PV}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="APSL-2"
+
+SLOT="0"
+KEYWORDS="~ppc-macos"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ cd ${WORKDIR}/cctools-${PV}
+ rm -rf ar as cbtlibs dyld file gprof ld libdyld libmacho mkshlib otool
+ make SUBDIRS="libstuff misc" || die "make failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/cctools-${PV}/misc
+ newbin check_dylib.NEW check_dylib
+ newbin checksyms.NEW checksyms
+ newbin dylib_pcsampler.NEW dylib_pcsampler
+ newbin indr.NEW indr
+ newbin seg_addr_table.NEW seg_addr_table
+ newbin seg_hack.NEW seg_hack
+
+ cd ${WORKDIR}/cctools-${PV}/man
+ doman {check_dylib.1,checksyms.1,indr.1,seg_addr_table.1}
+} \ No newline at end of file
diff --git a/sys-devel/cctools-extras/files/digest-cctools-extras-495.8 b/sys-devel/cctools-extras/files/digest-cctools-extras-495.8
new file mode 100644
index 000000000000..a7e4386a249c
--- /dev/null
+++ b/sys-devel/cctools-extras/files/digest-cctools-extras-495.8
@@ -0,0 +1 @@
+MD5 e7aef5838734ff9650cc1b60df136e66 cctools-495.8.tar.gz 1859332
diff --git a/sys-devel/cctools-extras/files/digest-cctools-extras-525 b/sys-devel/cctools-extras/files/digest-cctools-extras-525
new file mode 100644
index 000000000000..3ba58e0cc352
--- /dev/null
+++ b/sys-devel/cctools-extras/files/digest-cctools-extras-525
@@ -0,0 +1 @@
+MD5 3107c790a55595c6410696ebb7ea80a9 cctools-525.tar.gz 1931230
diff --git a/sys-devel/cctools-extras/metadata.xml b/sys-devel/cctools-extras/metadata.xml
new file mode 100644
index 000000000000..a65e8c2fdf72
--- /dev/null
+++ b/sys-devel/cctools-extras/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>kito@gentoo.org</email>
+</maintainer>
+</pkgmetadata>