summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-05 23:43:07 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-05 23:43:07 +0000
commitf95e2f22d3de10324a8ffc41b0a09f929728cb84 (patch)
tree5059fc96fa23d35190a5f7447e03140dc365903c /sys-devel/dev86
parentAdded COMPAT_NET_DEV_OPS to CONFIG_CHECK, bug #287083. (diff)
downloadgentoo-2-f95e2f22d3de10324a8ffc41b0a09f929728cb84.tar.gz
gentoo-2-f95e2f22d3de10324a8ffc41b0a09f929728cb84.tar.bz2
gentoo-2-f95e2f22d3de10324a8ffc41b0a09f929728cb84.zip
Update HOMEPAGE/SRC_URI #259106 by Mr. Anderson, and clean up some of the build code in the process.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/dev86')
-rw-r--r--sys-devel/dev86/ChangeLog6
-rw-r--r--sys-devel/dev86/dev86-0.16.17-r6.ebuild30
2 files changed, 21 insertions, 15 deletions
diff --git a/sys-devel/dev86/ChangeLog b/sys-devel/dev86/ChangeLog
index 28c0e5e03c94..5d24685b38bd 100644
--- a/sys-devel/dev86/ChangeLog
+++ b/sys-devel/dev86/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/dev86
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/ChangeLog,v 1.13 2009/02/02 19:02:27 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/ChangeLog,v 1.14 2009/10/05 23:43:07 vapier Exp $
+
+ 05 Oct 2009; Mike Frysinger <vapier@gentoo.org> dev86-0.16.17-r6.ebuild:
+ Update HOMEPAGE/SRC_URI #259106 by Mr. Anderson, and clean up some of the
+ build code in the process.
*dev86-0.16.17-r6 (02 Feb 2009)
diff --git a/sys-devel/dev86/dev86-0.16.17-r6.ebuild b/sys-devel/dev86/dev86-0.16.17-r6.ebuild
index 19a1d6edf0ca..0ca5257e6d3a 100644
--- a/sys-devel/dev86/dev86-0.16.17-r6.ebuild
+++ b/sys-devel/dev86/dev86-0.16.17-r6.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/dev86-0.16.17-r6.ebuild,v 1.1 2009/02/02 19:02:27 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/dev86-0.16.17-r6.ebuild,v 1.2 2009/10/05 23:43:07 vapier Exp $
inherit eutils
DESCRIPTION="Bruce's C compiler - Simple C compiler to generate 8086 code"
-HOMEPAGE="http://www.cix.co.uk/~mayday"
-SRC_URI="http://www.cix.co.uk/~mayday/dev86/Dev86src-${PV}.tar.gz"
+HOMEPAGE="http://www.debath.co.uk/"
+SRC_URI="http://www.debath.co.uk/dev86/Dev86src-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -28,12 +28,14 @@ src_unpack() {
"${S}"/makefile.in
fi
cd "${S}"
- epatch "${FILESDIR}/dev86-pic.patch"
+ epatch "${FILESDIR}"/dev86-pic.patch
epatch "${FILESDIR}"/${P}-fortify.patch
- sed -i -e "s/-O2 -g/${CFLAGS}/" \
- -e "s/INEXE=-m 755 -s/INEXE=-m 755/g" makefile.in
- sed -i -e "s/INSTALL_OPTS=-m 755 -s/INSTALL_OPTS=-m 755/g" bin86/Makefile
- sed -i -e "s/install -m 755 -s/install -m 755/g" dis88/Makefile
+ sed -i \
+ -e "s:-O2 -g:${CFLAGS} ${CPPFLAGS}:" \
+ -e '/INEXE=/s:-s::' \
+ makefile.in
+ sed -i -e '/INSTALL_OPTS=/s:-s::' bin86/Makefile
+ sed -i -e '/install -m 755 -s/s:-s::' dis88/Makefile
}
src_compile() {
@@ -49,12 +51,12 @@ src_compile() {
}
src_install() {
- make install-all DIST="${D}" || die
- dobin bootblocks/makeboot
+ emake -j1 install-all DIST="${D}" || die
+ dobin bootblocks/makeboot || die
# remove all the stuff supplied by bin86
cd "${D}"
- rm usr/bin/{as,ld,nm,objdump,size}86
- rm usr/man/man1/{as,ld}86.1
- mkdir -p usr/share/man
- mv usr/man usr/share/
+ rm usr/bin/{as,ld,nm,objdump,size}86 || die
+ rm usr/man/man1/{as,ld}86.1 || die
+ dodir /usr/share/man
+ mv usr/man usr/share/ || die
}