summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-24 19:49:06 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-24 19:49:06 +0000
commit2e51d1c9f75edccf474b2d32369db5d2f7388af8 (patch)
tree3e2be0de146549a4ce49ff6970bba9d0971dbacd /sys-devel/gcc/gcc-3.2.2.ebuild
parentvarious fixes (diff)
downloadgentoo-2-2e51d1c9f75edccf474b2d32369db5d2f7388af8.tar.gz
gentoo-2-2e51d1c9f75edccf474b2d32369db5d2f7388af8.tar.bz2
gentoo-2-2e51d1c9f75edccf474b2d32369db5d2f7388af8.zip
Fix to only build static if we do not build c++, fortran, objc, or java
Diffstat (limited to 'sys-devel/gcc/gcc-3.2.2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.2.2.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-devel/gcc/gcc-3.2.2.ebuild b/sys-devel/gcc/gcc-3.2.2.ebuild
index 73f86990941e..dce442420102 100644
--- a/sys-devel/gcc/gcc-3.2.2.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2.ebuild,v 1.12 2003/03/09 03:23:08 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2.ebuild,v 1.13 2003/03/24 19:49:06 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -287,18 +287,21 @@ src_compile() {
get_number_of_jobs
einfo "Building GCC..."
- if [ -z "`use static`" ]
+ # Only build it static if we are just building the C frontend, else
+ # a lot of things break because there are not libstdc++.so ....
+ if [ -n "`use static`" -a "${gcc_lang}" = "c" ]
then
# Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake bootstrap-lean \
+ emake LDFLAGS="-static" bootstrap \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
# Above FLAGS optimize and speedup build, thanks
# to Jeff Garzik <jgarzik@mandrakesoft.com>
else
+ # Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
- emake LDFLAGS=-static bootstrap \
+ emake bootstrap-lean \
LIBPATH="${LIBPATH}" \
BOOT_CFLAGS="${CFLAGS}" STAGE1_CFLAGS="-O" || die
fi