summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-06-21 10:38:26 +0000
committerFabian Groffen <grobian@gentoo.org>2009-06-21 10:38:26 +0000
commit249ffb5932c74d7696c953bbead259a6c0bb4ec2 (patch)
tree957d1318801cfb2acb9d24e6d70f10a12691acb0 /sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
parentdrop tl 2007 install support as all ebuilds are gone now (diff)
downloadgentoo-2-249ffb5932c74d7696c953bbead259a6c0bb4ec2.tar.gz
gentoo-2-249ffb5932c74d7696c953bbead259a6c0bb4ec2.tar.bz2
gentoo-2-249ffb5932c74d7696c953bbead259a6c0bb4ec2.zip
add sys-devel/gdb-apple from Gentoo Prefix tree
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gdb-apple/gdb-apple-768-r1.ebuild')
-rw-r--r--sys-devel/gdb-apple/gdb-apple-768-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild b/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
new file mode 100644
index 000000000000..e0c373b94ab6
--- /dev/null
+++ b/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-768-r1.ebuild,v 1.1 2009/06/21 10:38:25 grobian Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Apple branch of the GNU Debugger, 10.5"
+HOMEPAGE="http://sources.redhat.com/gdb/"
+SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gdb-${PV}.tar.gz"
+
+LICENSE="APSL-2 GPL-2"
+SLOT="0"
+
+KEYWORDS="~ppc-macos ~x86-macos"
+
+IUSE="nls"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ =dev-db/sqlite-3*"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/gdb-${PV}/src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-texinfo.patch
+ epatch "${FILESDIR}"/${P}-darwin-arch.patch
+
+ # for FSF gcc / gcc-apple:42
+ sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
+}
+
+src_compile() {
+ replace-flags -O? -O2
+ econf \
+ --disable-werror \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_install() {
+ local ED=${ED-${D}}
+
+ emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
+ rm -r "${D}"/nukeme || die
+ rm -Rf "${ED}"/usr/${CHOST} || die
+ mv "${ED}"/usr/bin/gdb ${ED}/
+ rm -f "${ED}"/usr/bin/*
+ mv "${ED}"/gdb "${ED}"/usr/bin/
+}