summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-10-18 21:34:51 +0000
committerJason Wever <weeve@gentoo.org>2003-10-18 21:34:51 +0000
commite62cabfa3368124575e26cb3dfb9be728126624c (patch)
tree4ffd56fb2edb22d734e655a91b20e6f91675dc68 /sys-devel/gdb/gdb-6.0.ebuild
parentchangelog:P (diff)
downloadgentoo-2-e62cabfa3368124575e26cb3dfb9be728126624c.tar.gz
gentoo-2-e62cabfa3368124575e26cb3dfb9be728126624c.tar.bz2
gentoo-2-e62cabfa3368124575e26cb3dfb9be728126624c.zip
Added fix for bug #29845 and fixed gdb-6.0 compile on sparc.
Diffstat (limited to 'sys-devel/gdb/gdb-6.0.ebuild')
-rw-r--r--sys-devel/gdb/gdb-6.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-devel/gdb/gdb-6.0.ebuild b/sys-devel/gdb/gdb-6.0.ebuild
index 59903f7d524a..098425e438b7 100644
--- a/sys-devel/gdb/gdb-6.0.ebuild
+++ b/sys-devel/gdb/gdb-6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.0.ebuild,v 1.1 2003/10/17 16:39:40 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.0.ebuild,v 1.2 2003/10/18 21:34:47 weeve Exp $
IUSE="nls"
@@ -25,6 +25,10 @@ src_unpack() {
epatch ${FILESDIR}/gdb-6.0-threadver-aug2003.patch
epatch ${FILESDIR}/gdb-6.0-coreutils.patch
epatch ${FILESDIR}/gdb-6.0-info.patch
+
+ if [ "${ARCH}" = "sparc" ]; then
+ epatch ${FILESDIR}/${PN}-5.3-sparc-nat-asm.patch
+ fi
}
src_compile() {