summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-19 22:19:40 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-19 22:19:40 +0000
commit3e16535fecaf3504ce6e2d1fbe932ddcca27003f (patch)
tree21a0af90ae5bfc70fbc87b754151269b10c56f47 /sys-devel/gettext
parentRemove retired developer from metadata.xml. (diff)
downloadgentoo-2-3e16535fecaf3504ce6e2d1fbe932ddcca27003f.tar.gz
gentoo-2-3e16535fecaf3504ce6e2d1fbe932ddcca27003f.tar.bz2
gentoo-2-3e16535fecaf3504ce6e2d1fbe932ddcca27003f.zip
Version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel/gettext')
-rw-r--r--sys-devel/gettext/ChangeLog9
-rw-r--r--sys-devel/gettext/files/digest-gettext-0.14.41
-rw-r--r--sys-devel/gettext/gettext-0.14.4.ebuild122
3 files changed, 130 insertions, 2 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index 9a07e61c9d48..e14c110730d8 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gettext
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.85 2005/04/12 13:16:54 usata Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.86 2005/04/19 22:19:40 vapier Exp $
+
+*gettext-0.14.4 (19 Apr 2005)
+
+ 19 Apr 2005; Mike Frysinger <vapier@gentoo.org> +gettext-0.14.4.ebuild:
+ Version bump.
12 Apr 2005; Mamoru KOMACHI <usata@gentoo.org> +files/50po-mode-gentoo.el,
gettext-0.14.2.ebuild:
diff --git a/sys-devel/gettext/files/digest-gettext-0.14.4 b/sys-devel/gettext/files/digest-gettext-0.14.4
new file mode 100644
index 000000000000..6af600950480
--- /dev/null
+++ b/sys-devel/gettext/files/digest-gettext-0.14.4
@@ -0,0 +1 @@
+MD5 7580b2d77ef26cafa248f525dcb960c3 gettext-0.14.4.tar.gz 7034035
diff --git a/sys-devel/gettext/gettext-0.14.4.ebuild b/sys-devel/gettext/gettext-0.14.4.ebuild
new file mode 100644
index 000000000000..8805ca17131e
--- /dev/null
+++ b/sys-devel/gettext/gettext-0.14.4.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.14.4.ebuild,v 1.1 2005/04/19 22:19:40 vapier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs mono libtool elisp-common
+
+DESCRIPTION="GNU locale utilities"
+HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="emacs nls"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epunt_cxx
+
+ epatch "${FILESDIR}"/${PN}-0.14.1-lib-path-tests.patch #81628
+ # java sucks
+ epatch "${FILESDIR}"/${PN}-0.14.1-without_java.patch
+ epatch "${FILESDIR}"/${PN}-0.14.2-no-java-tests.patch
+ # Fix race, bug #85054
+ epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch
+
+ # bundled libtool seems to be broken so skip certain rpath tests
+ # http://lists.gnu.org/archive/html/bug-libtool/2005-03/msg00070.html
+ sed -i \
+ -e '2iexit 77' \
+ autoconf-lib-link/tests/rpath-3*[ef] || die "sed tests"
+
+ # use Gentoo std docdir
+ sed -i \
+ -e "/^docdir=/s:=.*:=/usr/share/doc/${PF}:" \
+ gettext-runtime/configure \
+ gettext-tools/configure \
+ gettext-tools/examples/installpaths.in \
+ || die "sed docdir"
+
+ if use ppc-macos ; then
+ glibtoolize
+ append-flags -bind_at_load
+ fi
+}
+
+src_compile() {
+ # Build with --without-included-gettext (will use that of glibc), as we
+ # need preloadable_libintl.so for new help2man, bug #40162.
+ # Also note that it only gets build with USE=nls ...
+ # Lastly, we need to build without --disable-shared ...
+ CXX=$(tc-getCC) \
+ econf \
+ --without-java \
+ --without-included-gettext \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+ dosym msgfmt /usr/bin/gmsgfmt #43435
+
+ exeopts -m0755
+ exeinto /usr/bin
+ doexe gettext-tools/misc/gettextize || die "doexe"
+
+ # remove stuff that glibc handles
+ if ! use ppc-macos; then
+ # Mac OS X does not provide these files.
+ rm -f ${D}/usr/include/libintl.h
+ rm -f ${D}/usr/$(get_libdir)/libintl.*
+ fi
+ rm -rf ${D}/usr/share/locale/locale.alias
+
+ # older gettext's sometimes installed libintl ...
+ # need to keep the linked version or the system
+ # could die (things like sed link against it :/)
+ if use ppc-macos; then
+ rm -f ${D}/usr/lib/charset.alias
+ if [ -e "${ROOT}"/usr/$(get_libdir)/libintl.2.dylib ] ; then
+ cp -pPR ${ROOT}/usr/$(get_libdir)/libintl.2.dylib ${D}/usr/$(get_libdir)/
+ touch ${D}/usr/$(get_libdir)/libintl.2.dylib
+ fi
+ else
+ if [ -e "${ROOT}"/usr/$(get_libdir)/libintl.so.2 ] ; then
+ cp -a ${ROOT}/usr/$(get_libdir)/libintl.so.2* ${D}/usr/$(get_libdir)/
+ touch ${D}/usr/$(get_libdir)/libintl.so.2*
+ fi
+ fi
+
+ if [[ -d ${D}/usr/doc/gettext ]] ; then
+ mv "${D}"/usr/doc/gettext "${D}"/usr/share/doc/${PF}/html
+ rm -r "${D}"/usr/doc
+ fi
+
+ # Remove emacs site-lisp stuff if 'emacs' is not in USE
+ if use emacs ; then
+ elisp-site-file-install ${FILESDIR}/50po-mode-gentoo.el
+ else
+ rm -rf ${D}/usr/share/emacs
+ fi
+
+ dodoc AUTHORS BUGS ChangeLog DISCLAIM NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ ewarn "Any package that linked against the previous version"
+ ewarn "of gettext will have to be rebuilt."
+ ewarn "Please 'emerge gentoolkit' and run:"
+ ewarn "revdep-rebuild --soname libintl.so.2"
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}