summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-01-08 15:51:41 +0000
committerJeroen Roovers <jer@gentoo.org>2013-01-08 15:51:41 +0000
commit966f7407b3be06f14c72bcc80f416a9f3a3846aa (patch)
tree2c5b17e2804f9ca1aae040df68e29e1c28b6a645 /sys-devel/kgcc64
parentFix license. Version bump. (diff)
downloadgentoo-2-966f7407b3be06f14c72bcc80f416a9f3a3846aa.tar.gz
gentoo-2-966f7407b3be06f14c72bcc80f416a9f3a3846aa.tar.bz2
gentoo-2-966f7407b3be06f14c72bcc80f416a9f3a3846aa.zip
Update PATCH_VER. Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux i686, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-devel/kgcc64')
-rw-r--r--sys-devel/kgcc64/ChangeLog10
-rw-r--r--sys-devel/kgcc64/kgcc64-4.6.3.ebuild8
-rw-r--r--sys-devel/kgcc64/kgcc64-4.7.2.ebuild54
3 files changed, 66 insertions, 6 deletions
diff --git a/sys-devel/kgcc64/ChangeLog b/sys-devel/kgcc64/ChangeLog
index 634f766ba8c1..1458b8c1aece 100644
--- a/sys-devel/kgcc64/ChangeLog
+++ b/sys-devel/kgcc64/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/kgcc64
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.45 2012/11/14 17:03:04 ranger Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.46 2013/01/08 15:51:41 jer Exp $
+
+*kgcc64-4.7.2 (08 Jan 2013)
+
+ 08 Jan 2013; Jeroen Roovers <jer@gentoo.org> kgcc64-4.6.3.ebuild,
+ +kgcc64-4.7.2.ebuild:
+ Update PATCH_VER. Version bump.
14 Nov 2012; Brent Baude <ranger@gentoo.org> kgcc64-4.2.4.ebuild:
marking kgcc64-4.2.4 ppc stable
diff --git a/sys-devel/kgcc64/kgcc64-4.6.3.ebuild b/sys-devel/kgcc64/kgcc64-4.6.3.ebuild
index da67d8c9ecbe..dc7a810c14c3 100644
--- a/sys-devel/kgcc64/kgcc64-4.6.3.ebuild
+++ b/sys-devel/kgcc64/kgcc64-4.6.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.6.3.ebuild,v 1.1 2012/06/27 16:34:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.6.3.ebuild,v 1.2 2013/01/08 15:51:41 jer Exp $
case ${CHOST} in
hppa*) CTARGET=hppa64-${CHOST#*-};;
@@ -14,10 +14,10 @@ export CTARGET
TOOLCHAIN_ALLOWED_LANGS="c"
GCC_TARGET_NO_MULTILIB=true
-PATCH_VER="1.3"
+PATCH_VER="1.9"
GCC_FILESDIR=${FILESDIR/${PN}/gcc}
-inherit toolchain eutils
+inherit toolchain
DESCRIPTION="64bit kernel compiler"
diff --git a/sys-devel/kgcc64/kgcc64-4.7.2.ebuild b/sys-devel/kgcc64/kgcc64-4.7.2.ebuild
new file mode 100644
index 000000000000..c8abd60f65c2
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-4.7.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.7.2.ebuild,v 1.1 2013/01/08 15:51:41 jer Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.3"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain eutils
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on mips and sparc; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~sparc"
+
+RDEPEND=">=dev-libs/gmp-4.3.2
+ >=dev-libs/mpfr-2.4.2
+ >=dev-libs/mpc-0.8.1
+ >=sys-devel/gcc-config-1.4"
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="${RDEPEND}
+ hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64
+ >=sys-apps/texinfo-4.8
+ >=sys-devel/bison-1.875"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}