summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-01-22 20:15:55 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-01-22 20:15:55 +0000
commitfba4d64d5fd0316fd5795e42a5daed70b44e875f (patch)
treef4a31580929660c50a84c4540ce6d1faebb3fbe3 /sys-devel/patch/patch-2.6.1.ebuild
parentstable ppc, bug 285406 (diff)
downloadgentoo-2-fba4d64d5fd0316fd5795e42a5daed70b44e875f.tar.gz
gentoo-2-fba4d64d5fd0316fd5795e42a5daed70b44e875f.tar.bz2
gentoo-2-fba4d64d5fd0316fd5795e42a5daed70b44e875f.zip
Add missing strnlen implementation that upstream apparently forgot to include, bug #300845
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/patch/patch-2.6.1.ebuild')
-rw-r--r--sys-devel/patch/patch-2.6.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-devel/patch/patch-2.6.1.ebuild b/sys-devel/patch/patch-2.6.1.ebuild
index 9ca75c025b7a..b3ce5e507662 100644
--- a/sys-devel/patch/patch-2.6.1.ebuild
+++ b/sys-devel/patch/patch-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.6.1.ebuild,v 1.2 2010/01/02 03:35:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.6.1.ebuild,v 1.3 2010/01/22 20:15:54 darkside Exp $
inherit flag-o-matic
@@ -17,6 +17,13 @@ RDEPEND=""
DEPEND="${RDEPEND}
test? ( sys-apps/ed )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # this file is missing from the tarball bug #300845
+ cp "${FILESDIR}"/gnulib_strnlen.c gl/lib/strnlen.c || die
+}
+
src_compile() {
use static && append-ldflags -static