summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-07-11 07:53:25 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-07-11 07:53:25 +0000
commit1eeee21f8b1e44f9c1aac48bdb5c2230e5bb25fc (patch)
tree0bd1f16fe3dfc1b0a236b3c986e8731510e5858f /sys-devel/prelink/prelink-20100106.ebuild
parentFix building with OpenSSL >= 1.0.0 wrt #324959. (diff)
downloadgentoo-2-1eeee21f8b1e44f9c1aac48bdb5c2230e5bb25fc.tar.gz
gentoo-2-1eeee21f8b1e44f9c1aac48bdb5c2230e5bb25fc.tar.bz2
gentoo-2-1eeee21f8b1e44f9c1aac48bdb5c2230e5bb25fc.zip
Unset LD_AS_NEEDED before running the testsuite. (bug #303797)
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/prelink/prelink-20100106.ebuild')
-rw-r--r--sys-devel/prelink/prelink-20100106.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/prelink/prelink-20100106.ebuild b/sys-devel/prelink/prelink-20100106.ebuild
index 3718e9cd2c7a..dacc864671f6 100644
--- a/sys-devel/prelink/prelink-20100106.ebuild
+++ b/sys-devel/prelink/prelink-20100106.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/prelink-20100106.ebuild,v 1.4 2010/06/15 08:02:01 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/prelink-20100106.ebuild,v 1.5 2010/07/11 07:53:25 dirtyepic Exp $
# if not on http://people.redhat.com/jakub/prelink/, releases can usually be ripped from
# http://mirrors.kernel.org/fedora/development/source/SRPMS/prelink-<blah>.src.rpm
@@ -32,6 +32,11 @@ src_unpack() {
sed -i -e '/^CC=/s: : -Wl,--disable-new-dtags :' testsuite/functions.sh #100147
}
+src_test() {
+ unset LD_AS_NEEDED #303797
+ emake -j1 check
+}
+
src_install() {
emake install DESTDIR="${D}" || die "Install Failed"