summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-07 04:25:57 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-07 04:25:57 +0000
commitdbc9025e89062171f1e8b95ba40b0c45797e4217 (patch)
tree96d307747e18a3a96e88aed82a2d452f6ab9b8b7 /sys-devel/sparse/sparse-9999.ebuild
parentold (diff)
downloadgentoo-2-dbc9025e89062171f1e8b95ba40b0c45797e4217.tar.gz
gentoo-2-dbc9025e89062171f1e8b95ba40b0c45797e4217.tar.bz2
gentoo-2-dbc9025e89062171f1e8b95ba40b0c45797e4217.zip
Respect user CFLAGS #361853 by Nathan Phillip Brink.
Diffstat (limited to 'sys-devel/sparse/sparse-9999.ebuild')
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index d375721bc7ba..2c1974073bd7 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.5 2010/10/05 08:41:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.6 2011/04/07 04:25:57 vapier Exp $
EAPI="2"
-inherit eutils multilib flag-o-matic toolchain-funcs
+inherit multilib toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
inherit git
@@ -29,8 +29,8 @@ src_prepare() {
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ -e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions::}' \
Makefile || die
- append-flags -fno-strict-aliasing
export MAKEOPTS+=" V=1 CC=$(tc-getCC)"
}