summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 18:23:13 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 18:23:13 +0000
commit780bad578c08fc8bb3bb49bd9b1a6bd2c102f1e7 (patch)
tree7614f657835390d5dd307857fd091cc6bf3795cd /sys-devel/spython
parentNow uses static and build USE flags (diff)
downloadgentoo-2-780bad578c08fc8bb3bb49bd9b1a6bd2c102f1e7.tar.gz
gentoo-2-780bad578c08fc8bb3bb49bd9b1a6bd2c102f1e7.tar.bz2
gentoo-2-780bad578c08fc8bb3bb49bd9b1a6bd2c102f1e7.zip
Now use Setup.local for configuration
USE readline is now detected
Diffstat (limited to 'sys-devel/spython')
-rw-r--r--sys-devel/spython/files/digest-spython-2.0-r42
-rw-r--r--sys-devel/spython/spython-2.0-r4.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/sys-devel/spython/files/digest-spython-2.0-r4 b/sys-devel/spython/files/digest-spython-2.0-r4
new file mode 100644
index 000000000000..d5edd17f12a5
--- /dev/null
+++ b/sys-devel/spython/files/digest-spython-2.0-r4
@@ -0,0 +1,2 @@
+MD5 4751f4619eda0b5ade9d9dd017e7c1ef BeOpen-Python-2.0.tar.bz2
+MD5 7c99113a11b03599d8494638f6d90b56 python-fchksum-1.1.tar.gz
diff --git a/sys-devel/spython/spython-2.0-r4.ebuild b/sys-devel/spython/spython-2.0-r4.ebuild
new file mode 100644
index 000000000000..ba558d6b494a
--- /dev/null
+++ b/sys-devel/spython/spython-2.0-r4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r4.ebuild,v 1.1 2001/02/27 18:23:13 achim Exp $
+
+S=${WORKDIR}/Python-2.0
+S2=${WORKDIR}/python-fchksum-1.1
+DESCRIPTION="A really great language -- minimalist python environment"
+SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
+ http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
+
+HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
+
+DEPEND=">=sys-libs/zlib-1.1.3-r2 readline? ( >=sys-libs/readline-4.1-r2 )"
+RDEPEND="virtual/glibc"
+PROVIDE="virtual/python-2.0"
+
+src_unpack() {
+
+ unpack BeOpen-Python-2.0.tar.bz2
+
+ cd ${S}/Modules
+
+ cp ${FILESDIR}/pfconfig.h .
+ unpack python-fchksum-1.1.tar.gz
+
+ echo '*static*' >> Setup.local
+
+ echo "zlib zlibmodule.c -lz" >> Setup.local
+ if [ "`use readline`" ]
+ then
+ echo "readline readline.c -lreadline -lncurses" >> Setup.local
+ fi
+
+ echo "fchksum fchksum.c md5_2.c" >> Setup.local
+
+ cd python-fchksum-1.1
+ mv md5.h ../md5_2.h
+ sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
+ sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
+
+ #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
+ cd ${S}/Python
+ cp pythonrun.c pythonrun.c.orig
+ sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
+
+}
+
+src_compile() {
+
+ export LDFLAGS=-static
+
+ try ./configure --prefix=/usr --without-libdb
+
+ #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
+ #included with python is for db 1.85 only.
+
+ cp Makefile Makefile.orig
+ sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}/Modules
+ cp Makefile.pre Makefile.orig
+ sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
+ Makefile.orig > Makefile.pre
+
+ # Parallel make does not work
+ cd ${S}
+ try make
+
+}
+
+src_install() {
+
+ dodir /usr/share/man
+ try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
+ rm ${D}/usr/bin/python
+ mv ${D}/usr/bin/python2.0 ${D}/usr/bin/spython
+ dosym spython /usr/bin/python
+
+ if [ "`use build`" ]
+ then
+ rm -rf ${D}/usr/share/man
+ fi
+}