summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-05-06 09:04:01 +0000
committerMike Frysinger <vapier@gentoo.org>2007-05-06 09:04:01 +0000
commit01716fc5c2f2f7e213fd8e52489b06fc2448a67e (patch)
tree1a528b194bec8212798665e25b0c8b6f719f6fbc /sys-devel
parentold (diff)
downloadgentoo-2-01716fc5c2f2f7e213fd8e52489b06fc2448a67e.tar.gz
gentoo-2-01716fc5c2f2f7e213fd8e52489b06fc2448a67e.tar.bz2
gentoo-2-01716fc5c2f2f7e213fd8e52489b06fc2448a67e.zip
Fix ldscript symlink generation #171486 by Alan Hourihane.
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-config/ChangeLog10
-rw-r--r--sys-devel/binutils-config/binutils-config-1.9-r4.ebuild19
-rwxr-xr-xsys-devel/binutils-config/files/binutils-config-1.96
-rw-r--r--sys-devel/binutils-config/files/digest-binutils-config-1.9-r40
4 files changed, 30 insertions, 5 deletions
diff --git a/sys-devel/binutils-config/ChangeLog b/sys-devel/binutils-config/ChangeLog
index 754b1890b0b4..ad19c39068b1 100644
--- a/sys-devel/binutils-config/ChangeLog
+++ b/sys-devel/binutils-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/binutils-config
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/ChangeLog,v 1.34 2006/11/26 13:40:14 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/ChangeLog,v 1.35 2007/05/06 09:04:01 vapier Exp $
+
+*binutils-config-1.9-r4 (06 May 2007)
+
+ 06 May 2007; Mike Frysinger <vapier@gentoo.org> files/binutils-config-1.9,
+ +binutils-config-1.9-r4.ebuild:
+ Fix ldscript symlink generation #171486 by Alan Hourihane.
*binutils-config-1.9-r3 (26 Nov 2006)
diff --git a/sys-devel/binutils-config/binutils-config-1.9-r4.ebuild b/sys-devel/binutils-config/binutils-config-1.9-r4.ebuild
new file mode 100644
index 000000000000..99855e0247eb
--- /dev/null
+++ b/sys-devel/binutils-config/binutils-config-1.9-r4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/binutils-config-1.9-r4.ebuild,v 1.1 2007/05/06 09:04:01 vapier Exp $
+
+DESCRIPTION="Utility to change the binutils version being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="userland_GNU? ( >=sys-apps/findutils-4.2 )"
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die
+ doman "${FILESDIR}"/${PN}.8
+}
diff --git a/sys-devel/binutils-config/files/binutils-config-1.9 b/sys-devel/binutils-config/files/binutils-config-1.9
index 9eebfe722c5a..f7e03a7b0a60 100755
--- a/sys-devel/binutils-config/files/binutils-config-1.9
+++ b/sys-devel/binutils-config/files/binutils-config-1.9
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.9,v 1.9 2007/03/01 21:30:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.9,v 1.10 2007/05/06 09:04:01 vapier Exp $
# Format of /etc/env.d/binutils/:
# config-TARGET: CURRENT=version for TARGET
@@ -130,8 +130,8 @@ switch_profile() {
fi
# When upgrading, we need to clean up ldscripts and libs
rm -rf "${dstlib}/ldscripts" "${ROOT}/${BINPATH_LINKS}"/ldscripts
- ln -sf "${LIBPATH}/ldscripts" "${ROOT}/${BINPATH_LINKS}"/ldscripts
mkdir -p "${dstlib}"
+ ln -sf "${LIBPATH}/ldscripts" "${dstlib}"/ldscripts
find -L "${dstlib}" -type l -exec rm {} \;
for x in lib* ; do
ln -sf "${LIBPATH}/${x}" "${dstlib}/${x}"
@@ -334,7 +334,7 @@ while [[ $# -gt 0 ]] ; do
exit 0
;;
-V|--version)
- cvsver="$Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.9,v 1.9 2007/03/01 21:30:00 vapier Exp $"
+ cvsver="$Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.9,v 1.10 2007/05/06 09:04:01 vapier Exp $"
cvsver=${cvsver##*binutils-config-}
bver=${cvsver%%,v *}
cvsver=${cvsver#* }
diff --git a/sys-devel/binutils-config/files/digest-binutils-config-1.9-r4 b/sys-devel/binutils-config/files/digest-binutils-config-1.9-r4
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/binutils-config/files/digest-binutils-config-1.9-r4