summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-05-20 08:08:54 +0000
committerMichał Górny <mgorny@gentoo.org>2012-05-20 08:08:54 +0000
commit11e0ecca57d7be797ac5831ce883d00baa49bfbd (patch)
tree355dff8dba2d1618b2c734c304716869276af390 /sys-devel
parentStable for ppc/ppc64; bug #381981 (diff)
downloadgentoo-2-11e0ecca57d7be797ac5831ce883d00baa49bfbd.tar.gz
gentoo-2-11e0ecca57d7be797ac5831ce883d00baa49bfbd.tar.bz2
gentoo-2-11e0ecca57d7be797ac5831ce883d00baa49bfbd.zip
Disable manpage generation code until either rst2man or docs are fixed.
(Portage version: 2.2.0_alpha107_p2/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild18
2 files changed, 13 insertions, 10 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 96ccb611f82e..f4ac1da6bec5 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.74 2012/05/14 17:09:58 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.75 2012/05/20 08:08:54 mgorny Exp $
+
+ 20 May 2012; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
+ Disable manpage generation code until either rst2man or docs are fixed.
14 May 2012; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
Generate manpages before compiling llvm -- save time if it is going to fail.
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 0921b9a4c2a8..bbd267c605f4 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.29 2012/05/14 17:09:58 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.30 2012/05/20 08:08:54 mgorny Exp $
EAPI="4"
PYTHON_DEPEND="2"
@@ -140,14 +140,14 @@ src_configure() {
src_compile() {
# generate the manpages
- cd docs/CommandGuide || die
- local infiles=( *.rst )
-
- cat > Makefile <<EOF || die
-%.1: %.rst
- rst2man.py \$< > \$@
-EOF
- emake ${infiles[@]/.rst/.1}
+# cd docs/CommandGuide || die
+# local infiles=( *.rst )
+#
+# cat > Makefile <<EOF || die
+#%.1: %.rst
+# rst2man.py \$< > \$@
+#EOF
+# emake ${infiles[@]/.rst/.1}
emake VERBOSE=1 KEEP_SYMBOLS=1 REQUIRES_RTTI=1
}