summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-03-08 16:28:48 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-03-08 16:28:48 +0000
commit3807f4bf57c2cb533ff96e1cf181985ee9837a7f (patch)
tree67b0b103916f413614cc628f9142fd73fcb22e48 /sys-devel
parentUpdate SRC_URI since our mirrors seem to be missing some files (diff)
downloadgentoo-2-3807f4bf57c2cb533ff96e1cf181985ee9837a7f.tar.gz
gentoo-2-3807f4bf57c2cb533ff96e1cf181985ee9837a7f.tar.bz2
gentoo-2-3807f4bf57c2cb533ff96e1cf181985ee9837a7f.zip
Version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/patch/ChangeLog7
-rw-r--r--sys-devel/patch/patch-2.7.5.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index 4471c3f8925e..12407af5af28 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/patch
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.80 2015/02/24 10:56:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.81 2015/03/08 16:28:48 polynomial-c Exp $
+
+*patch-2.7.5 (08 Mar 2015)
+
+ 08 Mar 2015; Lars Wendler <polynomial-c@gentoo.org> +patch-2.7.5.ebuild:
+ Version bump.
24 Feb 2015; Agostino Sarubbo <ago@gentoo.org> patch-2.7.3.ebuild:
Stable for alpha, wrt bug #536614
diff --git a/sys-devel/patch/patch-2.7.5.ebuild b/sys-devel/patch/patch-2.7.5.ebuild
new file mode 100644
index 000000000000..d31a4dfbb854
--- /dev/null
+++ b/sys-devel/patch/patch-2.7.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.7.5.ebuild,v 1.1 2015/03/08 16:28:48 polynomial-c Exp $
+
+EAPI=4
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+SRC_URI="mirror://gnu/patch/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static test xattr"
+
+RDEPEND="xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # Do not let $ED mess up the search for `ed` 470210.
+ ac_cv_path_ED=$(type -P ed) \
+ econf \
+ $(use_enable xattr) \
+ --program-prefix="$(use userland_BSD && echo g)"
+}