summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-10-26 16:16:40 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-10-26 16:16:40 +0000
commit3ac68f186a13265ba5abb6e915fcda19d7e1cf51 (patch)
treef61426adea95b155e715d40a0df317700c6bc282 /sys-devel
parentBlock media-libs/lastfmlib wrt #290585 (diff)
downloadgentoo-2-3ac68f186a13265ba5abb6e915fcda19d7e1cf51.tar.gz
gentoo-2-3ac68f186a13265ba5abb6e915fcda19d7e1cf51.tar.bz2
gentoo-2-3ac68f186a13265ba5abb6e915fcda19d7e1cf51.zip
Disable .ps doc generation, these are just the man pages. Bug #290581
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/files/llvm-2.6-commandguide-nops.patch21
-rw-r--r--sys-devel/llvm/llvm-2.6.ebuild3
3 files changed, 28 insertions, 2 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 7595661e637c..f265780563f2 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.5 2009/10/26 09:58:41 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.6 2009/10/26 16:16:40 voyageur Exp $
+
+ 26 Oct 2009; Bernard Cafarelli <voyageur@gentoo.org> llvm-2.6.ebuild,
+ +files/llvm-2.6-commandguide-nops.patch:
+ Disable .ps doc generation, these are just the man pages. Bug #290581
26 Oct 2009; Bernard Cafarelli <voyageur@gentoo.org> llvm-2.6.ebuild,
metadata.xml:
diff --git a/sys-devel/llvm/files/llvm-2.6-commandguide-nops.patch b/sys-devel/llvm/files/llvm-2.6-commandguide-nops.patch
new file mode 100644
index 000000000000..7f0337351fd9
--- /dev/null
+++ b/sys-devel/llvm/files/llvm-2.6-commandguide-nops.patch
@@ -0,0 +1,21 @@
+--- docs/CommandGuide/Makefile.orig 2009-10-26 16:54:33.000000000 +0100
++++ docs/CommandGuide/Makefile 2009-10-26 17:07:34.000000000 +0100
+@@ -19,7 +19,7 @@
+ DST_PS_DIR=ps/
+
+ # If we are in BUILD_FOR_WEBSITE mode, default to the all target.
+-all:: html man ps
++all:: html man
+
+ clean:
+ rm -f pod2htm*.*~~ $(HTML) $(MAN) $(PS)
+@@ -90,9 +90,6 @@
+ $(Echo) Installing MAN CommandGuide Documentation
+ $(Verb) $(MKDIR) $(MAN_DIR)
+ $(Verb) $(DataInstall) $(INSTALL_MANS) $(MAN_DIR)
+- $(Echo) Installing PS CommandGuide Documentation
+- $(Verb) $(MKDIR) $(PS_DIR)
+- $(Verb) $(DataInstall) $(PS) $(PS_DIR)
+
+ uninstall-local::
+ $(Echo) Uninstalling CommandGuide Documentation
diff --git a/sys-devel/llvm/llvm-2.6.ebuild b/sys-devel/llvm/llvm-2.6.ebuild
index e5c975ac8371..1a9048bd80c8 100644
--- a/sys-devel/llvm/llvm-2.6.ebuild
+++ b/sys-devel/llvm/llvm-2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.6.ebuild,v 1.2 2009/10/26 09:58:41 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.6.ebuild,v 1.3 2009/10/26 16:16:40 voyageur Exp $
EAPI="2"
inherit eutils multilib toolchain-funcs
@@ -85,6 +85,7 @@ src_prepare() {
sed -e '/^NO_INSTALL_MANS/s/$/$(DST_MAN_DIR)tblgen.1 $(DST_MAN_DIR)llvmgcc.1 $(DST_MAN_DIR)llvmgxx.1/' \
-i docs/CommandGuide/Makefile || die "manpages sed failed"
epatch "${FILESDIR}"/${PN}-2.6-nodoctargz.patch
+ epatch "${FILESDIR}"/${PN}-2.6-commandguide-nops.patch
# Buggy test, http://llvm.org/bugs/show_bug.cgi?id=5047
rm test/DebugInfo/2009-01-15-dbg_declare.ll