summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-13 23:23:11 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-13 23:23:11 +0000
commit3ddd46bd2db5dfa46b5203e24725767b28adfe69 (patch)
tree5e5221635567a8e7454a09057886ef2fbd486820 /sys-devel
parentRemove old version; no package needs SLOT 2.2 anymore. (diff)
downloadgentoo-2-3ddd46bd2db5dfa46b5203e24725767b28adfe69.tar.gz
gentoo-2-3ddd46bd2db5dfa46b5203e24725767b28adfe69.tar.bz2
gentoo-2-3ddd46bd2db5dfa46b5203e24725767b28adfe69.zip
Add fix from upstream for instsh2.test failure #217513 by Markus Rothe.
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake/ChangeLog6
-rw-r--r--sys-devel/automake/automake-1.10.1.ebuild4
-rw-r--r--sys-devel/automake/files/automake-1.10.1-tests.patch111
3 files changed, 119 insertions, 2 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index d191360dbf0e..db9a1d7f4700 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/automake
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.111 2008/04/13 09:51:19 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.112 2008/04/13 23:23:10 vapier Exp $
+
+ 13 Apr 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/automake-1.10.1-tests.patch, automake-1.10.1.ebuild:
+ Add fix from upstream for instsh2.test failure #217513 by Markus Rothe.
13 Apr 2008; Benedikt Böhm <hollow@gentoo.org> automake-1.10.1.ebuild:
amd64 stable wrt #217239
diff --git a/sys-devel/automake/automake-1.10.1.ebuild b/sys-devel/automake/automake-1.10.1.ebuild
index 6ad1927e25cb..559f76579e68 100644
--- a/sys-devel/automake/automake-1.10.1.ebuild
+++ b/sys-devel/automake/automake-1.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.10.1.ebuild,v 1.3 2008/04/13 09:51:19 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.10.1.ebuild,v 1.4 2008/04/13 23:23:10 vapier Exp $
inherit eutils
@@ -24,6 +24,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-tests.patch #217513
+ chmod a+rx tests/*.test
sed -i \
-e "s|: (automake)| v${SLOT}: (automake${SLOT})|" \
doc/automake.texi || die "sed failed"
diff --git a/sys-devel/automake/files/automake-1.10.1-tests.patch b/sys-devel/automake/files/automake-1.10.1-tests.patch
new file mode 100644
index 000000000000..02e71949dc28
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.10.1-tests.patch
@@ -0,0 +1,111 @@
+commit eed743342cfa0ff8cc69666243233229e7417f8f
+Author: Ralf Wildenhues <Ralf.Wildenhues@gmx.de>
+Date: Wed Jan 30 21:23:16 2008 +0100
+
+ Split instsh2.test, so that only the new part requires non-root.
+
+ * tests/instsh2.test: Split off testing of `install-sh -C' ...
+ * tests/instsh3.test: ... to this new test, requiring non-root.
+ * tests/Makefile.am: Adjust.
+ * THANKS: Update.
+ Report by Theodoros V. Kalamatianos.
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index ec10801..8405c7a 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -293,6 +293,7 @@ install2.test \
+ installdir.test \
+ instsh.test \
+ instsh2.test \
++instsh3.test \
+ instdat.test \
+ instdat2.test \
+ instexec.test \
+diff --git a/tests/Makefile.in b/tests/Makefile.in
+index 6ba81ab..1bcb573 100644
+--- a/tests/Makefile.in
++++ b/tests/Makefile.in
+@@ -442,6 +442,7 @@ install2.test \
+ installdir.test \
+ instsh.test \
+ instsh2.test \
++instsh3.test \
+ instdat.test \
+ instdat2.test \
+ instexec.test \
+diff --git a/tests/instsh2.test b/tests/instsh2.test
+index 17b61ab..f0b729e 100755
+--- a/tests/instsh2.test
++++ b/tests/instsh2.test
+@@ -1,5 +1,5 @@
+ #! /bin/sh
+-# Copyright (C) 2002, 2004, 2006 Free Software Foundation, Inc.
++# Copyright (C) 2002, 2004, 2006, 2008 Free Software Foundation, Inc.
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+@@ -77,20 +77,6 @@ test -f d3/y
+ ./install-sh -T x d3 && exit 1
+ ./install-sh -T x d4// && exit 1
+
+-# Do not change the timestamps when using -C.
+-echo foo >file
+-./install-sh -C file d1
+-TZ=UTC0 touch -t $old_timestamp d1/file
+-./install-sh -C file d1
+-is_newest file d1/file
+-echo foo1 >file
+-./install-sh -C file d1
+-diff file d1/file
+-# Rights must be updated.
+-./install-sh -C -m 444 file d1
+-test -r d1/file
+-test ! -w d1/file
+-
+ # Ensure that install-sh works with names that include spaces
+ touch 'a b'
+ mkdir 'x y'
+diff --git a/tests/instsh3.test b/tests/instsh3.test
+new file mode 100755
+index 0000000..95b74c7
+--- /dev/null
++++ b/tests/instsh3.test
+@@ -0,0 +1,37 @@
++#! /bin/sh
++# Copyright (C) 2006, 2008 Free Software Foundation, Inc.
++#
++# This program is free software; you can redistribute it and/or modify
++# it under the terms of the GNU General Public License as published by
++# the Free Software Foundation; either version 3, or (at your option)
++# any later version.
++#
++# This program is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++# GNU General Public License for more details.
++#
++# You should have received a copy of the GNU General Public License
++# along with this program. If not, see <http://www.gnu.org/licenses/>.
++
++# More install-sh checks: check -C.
++
++required=non-root
++. ./defs || exit 1
++set -e
++
++./install-sh -d d1
++
++# Do not change the timestamps when using -C.
++echo foo >file
++./install-sh -C file d1
++TZ=UTC0 touch -t $old_timestamp d1/file
++./install-sh -C file d1
++is_newest file d1/file
++echo foo1 >file
++./install-sh -C file d1
++diff file d1/file
++# Rights must be updated.
++./install-sh -C -m 444 file d1
++test -r d1/file
++test ! -w d1/file