summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-08 01:45:07 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-08 01:45:07 +0000
commit437dddd099e155e5dea27f801524f20becd7271a (patch)
tree4070a88049d2363c291afb7ac32afd039d269ecc /sys-devel
parentversion bump. this version contains improved interfaces with support for embe... (diff)
downloadgentoo-2-437dddd099e155e5dea27f801524f20becd7271a.tar.gz
gentoo-2-437dddd099e155e5dea27f801524f20becd7271a.tar.bz2
gentoo-2-437dddd099e155e5dea27f801524f20becd7271a.zip
Fix #30849 and clean up the ebuild in general
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/digest-gcc-3.1.1-r2 (renamed from sys-devel/gcc/files/digest-gcc-3.1.1-r1)0
-rw-r--r--sys-devel/gcc/gcc-3.1.1-r2.ebuild (renamed from sys-devel/gcc/gcc-3.1.1-r1.ebuild)23
3 files changed, 14 insertions, 17 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 158278910784..f41b1bf726dc 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.266 2004/06/05 22:20:41 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.267 2004/06/08 01:45:07 vapier Exp $
+
+*gcc-3.1.1-r2 (07 Jun 2004)
+
+ 07 Jun 2004; Mike Frysinger <vapier@gentoo.org> -gcc-3.1.1-r1.ebuild,
+ +gcc-3.1.1-r2.ebuild:
+ Fix long standing env bug #30849 and use epatch instead of patch.
05 Jun 2004; Travis Tilley <lv@gentoo.org>
+files/3.4.0/reiser4-why-do-you-hate-me.patch, gcc-3.4.0-r6.ebuild:
diff --git a/sys-devel/gcc/files/digest-gcc-3.1.1-r1 b/sys-devel/gcc/files/digest-gcc-3.1.1-r2
index 4306377f63b0..4306377f63b0 100644
--- a/sys-devel/gcc/files/digest-gcc-3.1.1-r1
+++ b/sys-devel/gcc/files/digest-gcc-3.1.1-r2
diff --git a/sys-devel/gcc/gcc-3.1.1-r1.ebuild b/sys-devel/gcc/gcc-3.1.1-r2.ebuild
index 4d84e9ca99e7..5f7008b4a3b8 100644
--- a/sys-devel/gcc/gcc-3.1.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.1.1-r1.ebuild,v 1.16 2004/06/07 23:37:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.1.1-r2.ebuild,v 1.1 2004/06/08 01:45:07 vapier Exp $
# NOTE TO MAINTAINER: Info pages get nuked for multiple version installs.
# Ill fix it later if i get a chance.
@@ -9,7 +9,7 @@
# in src_install() ... Ill implement auto-version detection
# later on.
-inherit flag-o-matic libtool
+inherit flag-o-matic libtool eutils
do_filter_flags() {
# Compile problems with these ...
@@ -25,7 +25,6 @@ GCC_SUFFIX=-${MY_PV}
LOC="/usr"
# dont install in /usr/include/g++-v3/, as it will nuke gcc-3.0.x installs
STDCXX_INCDIR="${LOC}/include/g++-v${MY_PV/\./}"
-PATCHES="${WORKDIR}/patches"
DESCRIPTION="Modern GCC C/C++ compiler"
HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
@@ -70,23 +69,15 @@ FAKE_ROOT=""
src_unpack() {
unpack ${P}.tar.bz2
- mkdir -p ${WORKDIR}/patches
- tar -jxf ${DISTDIR}/${P}_final-patches-1.0.tbz2 -C ${WORKDIR}/patches || \
- die "Could not unpack patches"
-
cd ${S}
# Fixup libtool to correctly generate .la files with portage
elibtoolize --portage --shallow
- for x in ${PATCHES}/*.patch
- do
- # sad to say booboo I relised *after* uploading the patch to ibiblio :(
- if [ "${x##*/}" = "28_gcc31-c++-diagnostic-no-line-wrapping.patch" ]
- then
- patch -p1 < ${x} || die "Failed with patch ${x##*/}"
- else
- patch -p0 < ${x} || die "Failed with patch ${x##*/}"
- fi
+ mkdir -p ${WORKDIR}/patch
+ tar -jxf ${DISTDIR}/${P}_final-patches-1.0.tbz2 -C ${WORKDIR}/patch \
+ || die "Could not unpack patches"
+ for f in ${WORKDIR}/patch/*.patch ; do
+ epatch ${f}
done
# Currently if any path is changed via the configure script, it breaks