summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-12 19:02:14 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-12 19:02:14 +0000
commit484ddea549b5adb5b3132eabea3e215f0bd8b508 (patch)
tree2fa958b5ce940f08cc797ae78a8e3ba63e543dcd /sys-devel
parentInstall a /usr/include/CL symlink for the NVIDIA OpenCL headers. (diff)
downloadgentoo-2-484ddea549b5adb5b3132eabea3e215f0bd8b508.tar.gz
gentoo-2-484ddea549b5adb5b3132eabea3e215f0bd8b508.tar.bz2
gentoo-2-484ddea549b5adb5b3132eabea3e215f0bd8b508.zip
Add fix from upstream gnulib for uClibc.
(Portage version: 2.2.0_alpha5/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/ChangeLog6
-rw-r--r--sys-devel/bison/bison-2.4.2.ebuild3
-rw-r--r--sys-devel/bison/bison-2.4.3.ebuild8
-rw-r--r--sys-devel/bison/files/bison-2.4.3-uclibc-sched_param-def.patch19
4 files changed, 32 insertions, 4 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 736ec976f4a4..cc433b9657e4 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.95 2010/09/12 17:40:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.96 2010/12/12 19:02:14 vapier Exp $
+
+ 12 Dec 2010; Mike Frysinger <vapier@gentoo.org> bison-2.4.2.ebuild,
+ bison-2.4.3.ebuild, +files/bison-2.4.3-uclibc-sched_param-def.patch:
+ Add fix from upstream gnulib for uClibc.
12 Sep 2010; Raúl Porcel <armin76@gentoo.org> bison-2.4.2.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #331577
diff --git a/sys-devel/bison/bison-2.4.2.ebuild b/sys-devel/bison/bison-2.4.2.ebuild
index dfb68f7e7486..f4e661b6db08 100644
--- a/sys-devel/bison/bison-2.4.2.ebuild
+++ b/sys-devel/bison/bison-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.2.ebuild,v 1.9 2010/09/12 17:40:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.2.ebuild,v 1.10 2010/12/12 19:02:14 vapier Exp $
inherit toolchain-funcs flag-o-matic
@@ -21,6 +21,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-2.4.2-gnulib_spawn.patch # 312697
epatch "${FILESDIR}"/${PN}-2.4.2-gcc45_testsuite.patch
+ epatch "${FILESDIR}"/${PN}-2.4.3-uclibc-sched_param-def.patch
}
src_compile() {
diff --git a/sys-devel/bison/bison-2.4.3.ebuild b/sys-devel/bison/bison-2.4.3.ebuild
index 158635029677..71b6e642b0c5 100644
--- a/sys-devel/bison/bison-2.4.3.ebuild
+++ b/sys-devel/bison/bison-2.4.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.3.ebuild,v 1.1 2010/08/07 22:37:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.3.ebuild,v 1.2 2010/12/12 19:02:14 vapier Exp $
EAPI="2"
-inherit flag-o-matic
+inherit flag-o-matic eutils
DESCRIPTION="A yacc-compatible parser generator"
HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
@@ -18,6 +18,10 @@ IUSE="nls static"
DEPEND="nls? ( sys-devel/gettext )"
RDEPEND="sys-devel/m4"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-uclibc-sched_param-def.patch
+}
+
src_configure() {
use static && append-ldflags -static
econf $(use_enable nls)
diff --git a/sys-devel/bison/files/bison-2.4.3-uclibc-sched_param-def.patch b/sys-devel/bison/files/bison-2.4.3-uclibc-sched_param-def.patch
new file mode 100644
index 000000000000..50652d8babc2
--- /dev/null
+++ b/sys-devel/bison/files/bison-2.4.3-uclibc-sched_param-def.patch
@@ -0,0 +1,19 @@
+uclibc defines __GLIBC__ but it does not expose struct shed_param as much as glibc
+and is not needed too per standard. gnulib attempts to use it but we have to account
+for it because in this case uclibc does not behave like glibc.
+
+-Khem
+
+http://bugs.gentoo.org/336484
+
+--- m4-1.4.14/lib/spawn.in.h
++++ m4-1.4.14/lib/spawn.in.h
+@@ -31,7 +31,7 @@
+
+ /* Get definitions of 'struct sched_param' and 'sigset_t'.
+ But avoid namespace pollution on glibc systems. */
+-#ifndef __GLIBC__
++#if !defined __GLIBC__ || defined __UCLIBC__
+ # include <sched.h>
+ # include <signal.h>
+ #endif