summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-28 22:26:57 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-28 22:26:57 +0000
commit5a7f114b58e820081cc9696c159ff4d87fe10e08 (patch)
tree8c916fba7df056abf2ec40131faeec5265122eb4 /sys-devel
parentMissed changelog entry the last time around (Manifest recommit) (diff)
downloadgentoo-2-5a7f114b58e820081cc9696c159ff4d87fe10e08.tar.gz
gentoo-2-5a7f114b58e820081cc9696c159ff4d87fe10e08.tar.bz2
gentoo-2-5a7f114b58e820081cc9696c159ff4d87fe10e08.zip
added fix for bug 49174
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/files/3.4.0/gcc-3.4.0-fno-for-scope.patch47
-rw-r--r--sys-devel/gcc/gcc-3.4.0.ebuild5
3 files changed, 56 insertions, 2 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 84e272279505..73877ee4100c 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.227 2004/04/28 22:13:14 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.228 2004/04/28 22:26:57 lv Exp $
+
+ 28 Apr 2004; Travis Tilley <lv@gentoo.org>
+ +files/3.4.0/gcc-3.4.0-fno-for-scope.patch, gcc-3.4.0.ebuild:
+ added fix for bug 49174
28 Apr 2004; Travis Tilley <lv@gentoo.org> gcc-3.4.0.ebuild:
fixed things up a bit and added a check that changes the deprecated -mcpu
diff --git a/sys-devel/gcc/files/3.4.0/gcc-3.4.0-fno-for-scope.patch b/sys-devel/gcc/files/3.4.0/gcc-3.4.0-fno-for-scope.patch
new file mode 100644
index 000000000000..534e7dba6dcd
--- /dev/null
+++ b/sys-devel/gcc/files/3.4.0/gcc-3.4.0-fno-for-scope.patch
@@ -0,0 +1,47 @@
+diff -prN libstdc++-v3-orig/include/bits/locale_facets.h libstdc++-v3/include/bits/locale_facets.h
+*** libstdc++-v3-orig/include/bits/locale_facets.h 2004-03-24 21:11:32.000000000 +0000
+--- libstdc++-v3/include/bits/locale_facets.h 2004-04-23 15:45:34.000000000 +0100
+*************** namespace std
+*** 1161,1168 ****
+
+ _M_widen_ok = 1;
+ // Set _M_widen_ok to 2 if memcpy can't be used.
+! for (size_t __i = 0; __i < sizeof(_M_widen); ++__i)
+! if (__tmp[__i] != _M_widen[__i])
+ {
+ _M_widen_ok = 2;
+ break;
+--- 1161,1168 ----
+
+ _M_widen_ok = 1;
+ // Set _M_widen_ok to 2 if memcpy can't be used.
+! for (size_t __j = 0; __j < sizeof(_M_widen); ++__j)
+! if (__tmp[__j] != _M_widen[__j])
+ {
+ _M_widen_ok = 2;
+ break;
+*************** namespace std
+*** 1182,1192 ****
+ // Check if any default values were created. Do this by
+ // renarrowing with a different default value and comparing.
+ bool __consecutive = true;
+! for (size_t __i = 0; __i < sizeof(_M_narrow); ++__i)
+! if (!_M_narrow[__i])
+ {
+ char __c;
+! do_narrow(__tmp + __i, __tmp + __i + 1, 1, &__c);
+ if (__c == 1)
+ {
+ __consecutive = false;
+--- 1182,1192 ----
+ // Check if any default values were created. Do this by
+ // renarrowing with a different default value and comparing.
+ bool __consecutive = true;
+! for (size_t __j = 0; __j < sizeof(_M_narrow); ++__j)
+! if (!_M_narrow[__j])
+ {
+ char __c;
+! do_narrow(__tmp + __j, __tmp + __j + 1, 1, &__c);
+ if (__c == 1)
+ {
+ __consecutive = false;
diff --git a/sys-devel/gcc/gcc-3.4.0.ebuild b/sys-devel/gcc/gcc-3.4.0.ebuild
index a2882143479a..cde1a120ceb5 100644
--- a/sys-devel/gcc/gcc-3.4.0.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.12 2004/04/28 22:13:14 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.13 2004/04/28 22:26:57 lv Exp $
IUSE="static nls bootstrap java build X multilib gcj hardened f77 objc uclibc"
@@ -333,6 +333,9 @@ src_unpack() {
# TODO: on arches where we lack a Scrt1.o (like parisc) we still need unpack, compile and install logic
# TODO: for the crt1Snocsu.o provided by a custom gcc-pie-ssp.tgz which can also be included in SRC_URI
+ # apps like openoffice break without this
+ cd ${S} ; epatch ${FILESDIR}/3.4.0/gcc-3.4.0-fno-for-scope.patch
+
# Install our pre generated manpages if we do not have perl ...
if [ ! -x /usr/bin/perl ]
then