summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-03-24 00:23:08 +0000
committerJon Portnoy <avenj@gentoo.org>2004-03-24 00:23:08 +0000
commit7ab304c44d47378e782e1f4fe38aeafb394cf652 (patch)
treeb6bfc5012bd338aa6e0898121515aa3853bd414e /sys-devel
parentstable on alpha and ia64 (Manifest recommit) (diff)
downloadgentoo-2-7ab304c44d47378e782e1f4fe38aeafb394cf652.tar.gz
gentoo-2-7ab304c44d47378e782e1f4fe38aeafb394cf652.tar.bz2
gentoo-2-7ab304c44d47378e782e1f4fe38aeafb394cf652.zip
Sync with GNUMach 2.x tree to make OSKit build again. Bug 44867. See ChangeLog for more complete information.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/oskit/ChangeLog11
-rw-r--r--sys-devel/oskit/Manifest4
-rw-r--r--sys-devel/oskit/files/digest-oskit-20020317-r12
-rw-r--r--sys-devel/oskit/oskit-20020317-r1.ebuild76
4 files changed, 91 insertions, 2 deletions
diff --git a/sys-devel/oskit/ChangeLog b/sys-devel/oskit/ChangeLog
index 3935744d1596..e0d9b0fb9e5a 100644
--- a/sys-devel/oskit/ChangeLog
+++ b/sys-devel/oskit/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/oskit
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/oskit/ChangeLog,v 1.1 2003/03/15 22:23:35 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/oskit/ChangeLog,v 1.2 2004/03/24 00:23:08 avenj Exp $
+
+*oskit-20020317-r1 (23 Mar 2004)
+
+ 23 Mar 2004; Jon Portnoy <avenj@gentoo.org> oskit-20020317-r1.ebuild :
+ Original OSKit no longer builds and is no longer maintained.
+ Added patchset from Eric Olinger (evvl@rustedhalo.net) that
+ syncs us against the GNU tree (GNUMach 2.x), fixing issues with
+ multistring literals and adding newer drivers from Linux 2.2.
+ Bug #44867.
*oskit-20020317 (15 March 2003)
diff --git a/sys-devel/oskit/Manifest b/sys-devel/oskit/Manifest
index c1b371d3d3e0..b80cadc07d0f 100644
--- a/sys-devel/oskit/Manifest
+++ b/sys-devel/oskit/Manifest
@@ -1,4 +1,6 @@
+MD5 26992a9abd9516a8a4eba09e0570a7ec oskit-20020317.ebuild 2127
MD5 0f6d5f7137c3b55e41eef94295c934ff ChangeLog 420
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 26992a9abd9516a8a4eba09e0570a7ec oskit-20020317.ebuild 2127
+MD5 e2a900ae36382acd765a4c918d0b3dc3 oskit-20020317-r1.ebuild 2051
MD5 2e8bb57adc0dfde2faa26b1ed405f5f7 files/digest-oskit-20020317 68
+MD5 8cbf6c994adc2f67256762b966611487 files/digest-oskit-20020317-r1 137
diff --git a/sys-devel/oskit/files/digest-oskit-20020317-r1 b/sys-devel/oskit/files/digest-oskit-20020317-r1
new file mode 100644
index 000000000000..7bb8c6bb38c5
--- /dev/null
+++ b/sys-devel/oskit/files/digest-oskit-20020317-r1
@@ -0,0 +1,2 @@
+MD5 258f256a87c19bf1a49090c46ea0e51b oskit-20020317.tar.gz 11252678
+MD5 9ff6b859695fe2c83ab175e0dd705ed8 oskit-20040319.patch.bz2 817920
diff --git a/sys-devel/oskit/oskit-20020317-r1.ebuild b/sys-devel/oskit/oskit-20020317-r1.ebuild
new file mode 100644
index 000000000000..e0c49eb03ea7
--- /dev/null
+++ b/sys-devel/oskit/oskit-20020317-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/oskit/oskit-20020317-r1.ebuild,v 1.1 2004/03/24 00:23:08 avenj Exp $
+
+inherit flag-o-matic
+
+PATCH_REV="20040319"
+
+DESCRIPTION="Building blocks for a x86 operating system."
+HOMEPAGE="http://www.cs.utah.edu/flux/oskit/"
+SRC_URI="ftp://flux.cs.utah.edu/flux/oskit/${P}.tar.gz
+ mirror://gentoo/oskit-${PATCH_REV}.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+DEPEND="doc? ( app-text/tetex )"
+IUSE="debug oskit-profiling oskit-noassert doc oskit-nobuild oskit-noconf"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch ${DISTDIR}/oskit-${PATCH_REV}.patch.bz2
+}
+
+src_compile() {
+ local myconf
+ if [ -n "$(use debug && use oskit-noassert)" ] ; then
+ ewarn "Configuring for debugging without assertions!"
+ echo -e '\a' 1>&2
+ sleep 5
+ fi
+ #if [ -z $(use oskit-nobuild) ] && [ ! -z $(use oskit-noconf) ] ; then
+ # eerror "Building but not configuring"
+ # die
+ #fi
+ use debug && myconf="${myconf} --enable-debug"
+ use oskit-profiling && myconf="${myconf} --enable-profiling"
+ use oskit-noassert && myconf="${myconf} --disable-asserts"
+ use doc && myconf="${myconf} --enable-doc"
+ if [ -n "${OSKIT_MODULEFILE}" ] ; then
+ if [ -f "${OSKIT_MODULEFILE}" ] ; then
+ myconf="${myconf} --enable-modulefile=${OSKIT_MODULEFILE}"
+ else
+ ewarn "Modulefile ${OSKIT_MODULEFILE} does not exist or is not a file, not using!"
+ echo -e '\a' 1>&2
+ sleep 5
+ fi
+ fi
+ if [ -n "$(use oskit-nobuild)" ] ; then
+ if [ -n "$(use oskit-noconf)" ] ; then
+ einfo "Configuring OSKit, but not building..."
+ econf ${myconf} || die
+ fi
+ else
+ einfo "Configuring OSKit..."
+ econf ${myconf} || die
+ einfo "Compiling OSKit..."
+ make || die
+ fi
+}
+
+src_install() {
+ if [ -n "$(use oskit-nobuild)" ] ; then
+ dodir /usr/src
+ cd ${WORKDIR}
+ einfo "Fixing permissions and ownership..."
+ chown -R root:root * || die
+ chmod -R a+r-w+X,u+w * || die
+ einfo "Installing OSKit sources..."
+ mv ${S} ${D}/usr/src || die
+ rm -f ${WORKDIR}/../.unpacked
+ else
+ einfo "Installing OSKit..."
+ einstall || die
+ fi
+}