summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Reisch <doctomoe@gentoo.org>2002-06-02 16:07:28 +0000
committerOlivier Reisch <doctomoe@gentoo.org>2002-06-02 16:07:28 +0000
commit8142a4e468b1ec32945c32279fafd389b81b17e8 (patch)
tree45f03b2499425e289432bb0e06c1b37d22cf60d9 /sys-devel
parentdidn't i commit this? removes the bad flags from CFLAGS (diff)
downloadgentoo-2-8142a4e468b1ec32945c32279fafd389b81b17e8.tar.gz
gentoo-2-8142a4e468b1ec32945c32279fafd389b81b17e8.tar.bz2
gentoo-2-8142a4e468b1ec32945c32279fafd389b81b17e8.zip
Digest for the gdb-5.1.1-r2.ebuild. What else??
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/ChangeLog10
-rw-r--r--sys-devel/gdb/files/digest-gdb-5.1.1-r21
-rw-r--r--sys-devel/gdb/gdb-5.1.1-r2.ebuild82
3 files changed, 90 insertions, 3 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 5308a45f5b2e..48344eb5e852 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,10 @@
-# ChangeLog for sys-devel/gdb
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.4 2002/05/06 21:16:02 kain Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.5 2002/06/02 16:07:28 doctomoe Exp $
+
+*gdb-5.1.1-r2 (2 June 2002)
+
+ 2 June 2002; Olivier Reisch <doctomoe@gentoo.org> gdb-5.1.1-r2.ebuild
+
+ Have the PPC patch only applied on PPC platform.
*gdb-5.1.1-r1 (6 May 2002)
diff --git a/sys-devel/gdb/files/digest-gdb-5.1.1-r2 b/sys-devel/gdb/files/digest-gdb-5.1.1-r2
new file mode 100644
index 000000000000..ae3b64a8f9cf
--- /dev/null
+++ b/sys-devel/gdb/files/digest-gdb-5.1.1-r2
@@ -0,0 +1 @@
+MD5 805163efd455663745532c12893a96ca gdb-5.1.1.tar.gz 13874218
diff --git a/sys-devel/gdb/gdb-5.1.1-r2.ebuild b/sys-devel/gdb/gdb-5.1.1-r2.ebuild
new file mode 100644
index 000000000000..9d7e29543e7d
--- /dev/null
+++ b/sys-devel/gdb/gdb-5.1.1-r2.ebuild
@@ -0,0 +1,82 @@
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-5.1.1-r2.ebuild,v 1.1 2002/06/02 16:07:28 doctomoe Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU debugger"
+HOMEPAGE="http://www.gnu.org/software/gdb/gdb.html"
+SRC_URI="ftp://sourceware.cygnus.com/pub/gdb/releases/${P}.tar.gz
+ ftp://ftp.freesoftware.com/pub/sourceware/gdb/releases/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack gdb-${PV}.tar.gz
+ cd ${S}
+ if [ ${ARCH} = "ppc" ]
+ then patch -p1 < ${FILESDIR}/gdb-5.1.1-ppc-booltypes.patch || die
+ fi
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="--disable-nls"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --without-included-regex \
+ --without-included-gettext \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ cd gdb/doc
+ make \
+ infodir=${D}/usr/share/info \
+ install-info || die
+
+ cd ${S}/bfd/doc
+ make \
+ infodir=${D}/usr/share/info \
+ install-info || die
+
+ cd ${S}
+
+ # These includes and libs are in binutils already
+ rm -f ${D}/usr/lib/libbfd.*
+ rm -r ${D}/usr/lib/libiberty.*
+ rm -f ${D}/usr/lib/libopcodes.*
+
+ rm -rf ${D}/usr/include
+
+ dodoc COPYING* README
+
+ docinto gdb
+ dodoc gdb/CONTRIBUTE gdb/COPYING* gdb/README \
+ gdb/MAINTAINERS gdb/NEWS gdb/ChangeLog* \
+ gdb/TODO
+
+ docinto sim
+ dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
+
+ docinto mmalloc
+ dodoc mmalloc/COPYING.LIB mmalloc/MAINTAINERS \
+ mmalloc/ChangeLog mmalloc/TODO
+}