summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-05-30 00:31:49 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-05-30 00:31:49 +0000
commit939b334828b52f6a4d7a2c0e8d6134d9837949d5 (patch)
tree1de6a1b5971de73268db7852dcfba303f505cb27 /sys-devel
parentBump to 3.4.6, and mark 3.4.5 as stable. (diff)
downloadgentoo-2-939b334828b52f6a4d7a2c0e8d6134d9837949d5.tar.gz
gentoo-2-939b334828b52f6a4d7a2c0e8d6134d9837949d5.tar.bz2
gentoo-2-939b334828b52f6a4d7a2c0e8d6134d9837949d5.zip
Bump weekly 4.2 snapshot
(Portage version: 2.1_rc2-r2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.2.0_alpha200605273
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20060527.ebuild66
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 8eb8ab9fe20c..ed78666be93f 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.547 2006/05/29 17:56:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.548 2006/05/30 00:31:49 halcy0n Exp $
+
+*gcc-4.2.0_alpha20060527 (30 May 2006)
+
+ 30 May 2006; Mark Loeser <halcy0n@gentoo.org>
+ -gcc-4.2.0_alpha20060520.ebuild, +gcc-4.2.0_alpha20060527.ebuild:
+ Bump weekly 4.2 snapshot
29 May 2006; Diego Pettenò <flameeyes@gentoo.org> gcc-4.1.1.ebuild:
Add ~x86-fbsd keyword (currently profile masked).
diff --git a/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060527 b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060527
new file mode 100644
index 000000000000..c6da31625685
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060527
@@ -0,0 +1,3 @@
+MD5 98d06f41fdfefd8920fd37c955d02ed4 gcc-4.2-20060527.tar.bz2 38961309
+RMD160 f7710198fb5f2d59e206dbcf3c0d425143eac454 gcc-4.2-20060527.tar.bz2 38961309
+SHA256 5340f90d8d808f1c2a2a409f17f076c20b2d3786e09f9455216f4d36b9bce5bd gcc-4.2-20060527.tar.bz2 38961309
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20060527.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20060527.ebuild
new file mode 100644
index 000000000000..c4bfee0290f1
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20060527.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060527.ebuild,v 1.1 2006/05/30 00:31:49 halcy0n Exp $
+
+ETYPE="gcc-compiler"
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-*"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ virtual/libiconv
+ fortran? (
+ dev-libs/gmp
+ dev-libs/mpfr
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND="${RDEPEND} elibc_glibc? (
+ hppa? ( >=sys-libs/glibc-2.3.4 ) !hppa? ( >=sys-libs/glibc-2.3.6 )
+ )"
+fi
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ >=${CATEGORY}/binutils-2.16.1"
+
+PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+ x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( =virtual/libstdc++-3.3 ) ) ) )"
+
+pkg_setup() {
+ if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+ die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild. This is to try and cut down on people filing bugs for a compiler we do not currently support."
+ fi
+}
+
+src_unpack() {
+ gcc_src_unpack
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+}
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ einfo "This gcc-4 ebuild is provided for your convenience, and the use"
+ einfo "of this compiler is not supported by the Gentoo Developers."
+ einfo "Please file bugs related to gcc-4 with upstream developers."
+ einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
+}