summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-08-07 23:08:38 +0000
committerMike Frysinger <vapier@gentoo.org>2011-08-07 23:08:38 +0000
commitb1e1a9bd9d9b56a9409dbacbc321622e6c7c1b32 (patch)
tree0bc818eb86d648b16ef643661e95a35781cb90f9 /sys-devel
parentmake sure log output is unique #378057 by Martin von Gagern (diff)
downloadgentoo-2-b1e1a9bd9d9b56a9409dbacbc321622e6c7c1b32.tar.gz
gentoo-2-b1e1a9bd9d9b56a9409dbacbc321622e6c7c1b32.tar.bz2
gentoo-2-b1e1a9bd9d9b56a9409dbacbc321622e6c7c1b32.zip
Clean up dead yacc symlink on unmerge #377469 by Michael.
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/ChangeLog5
-rw-r--r--sys-devel/bison/bison-2.5.ebuild15
2 files changed, 16 insertions, 4 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index b0ccc8b27a72..891d755bf554 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.106 2011/07/31 17:26:47 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.107 2011/08/07 23:08:38 vapier Exp $
+
+ 07 Aug 2011; Mike Frysinger <vapier@gentoo.org> bison-2.5.ebuild:
+ Clean up dead yacc symlink on unmerge #377469 by Michael.
31 Jul 2011; Matt Turner <mattst88@gentoo.org> bison-2.5.ebuild:
Bump m4 requirement to 1.4.16, bug 375637. Also move it from RDEPEND back to
diff --git a/sys-devel/bison/bison-2.5.ebuild b/sys-devel/bison/bison-2.5.ebuild
index 9940302ded6f..b30445ada6a7 100644
--- a/sys-devel/bison/bison-2.5.ebuild
+++ b/sys-devel/bison/bison-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.5.ebuild,v 1.2 2011/07/31 17:26:47 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.5.ebuild,v 1.3 2011/08/07 23:08:38 vapier Exp $
EAPI="2"
@@ -38,7 +38,16 @@ src_install() {
}
pkg_postinst() {
- if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
- ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ local f="${ROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${ROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
fi
}