summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-07 23:03:40 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-07 23:03:40 +0000
commitce9094b452c4449418de19edc0219861ea3ea7bf (patch)
tree8e45e4f044e9a596b0b888776aeb1f1eea382974 /sys-devel
parentremove 061 release from tree as it's broken. (diff)
downloadgentoo-2-ce9094b452c4449418de19edc0219861ea3ea7bf.tar.gz
gentoo-2-ce9094b452c4449418de19edc0219861ea3ea7bf.tar.bz2
gentoo-2-ce9094b452c4449418de19edc0219861ea3ea7bf.zip
Make sure the f77 wrapper is installed/run properly for g77 #97437 by John C. Vernaleo.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog9
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.11-r40
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.115
-rw-r--r--sys-devel/gcc-config/files/wrapper-1.4.6.c4
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.11-r4.ebuild48
5 files changed, 62 insertions, 4 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index d3464ee02470..86784814fc53 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.94 2005/06/17 20:38:59 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.95 2005/07/07 23:03:40 vapier Exp $
+
+*gcc-config-1.3.11-r4 (07 Jul 2005)
+
+ 07 Jul 2005; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.11,
+ files/wrapper-1.4.6.c, +gcc-config-1.3.11-r4.ebuild:
+ Make sure the f77 wrapper is installed/run properly for g77 #97437 by John
+ C. Vernaleo.
17 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org>
gcc-config-1.3.10-r1.ebuild, gcc-config-1.3.10-r2.ebuild,
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.11-r4 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.11-r4
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.11-r4
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.11 b/sys-devel/gcc-config/files/gcc-config-1.3.11
index 7715f6ab5d6c..baf9985391f3 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.11
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.11
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.11,v 1.5 2005/06/13 04:57:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.11,v 1.6 2005/07/07 23:03:40 vapier Exp $
trap ":" INT QUIT TSTP
@@ -213,7 +213,8 @@ switch_profile() {
# sync mtimes together. This makes things like ccache
# happy. See Bug #70548 for more info.
local ref=${ROOT}/${GCC_BIN_PATH}/${x}
- [[ ${x} == "cc" ]] && ref=${ROOT}/${GCC_BIN_PATH}/gcc
+ [[ ${x} == "cc" ]] && ref=${ROOT}/${GCC_BIN_PATH}/gcc
+ [[ ${x} == "f77" ]] && ref=${ROOT}/${GCC_BIN_PATH}/g77
if [[ -x ${ref} ]] ; then
${CP} -f "${ROOT}/usr/lib/misc/gcc-config" \
"${ROOT}/usr/bin/${x}"
diff --git a/sys-devel/gcc-config/files/wrapper-1.4.6.c b/sys-devel/gcc-config/files/wrapper-1.4.6.c
index b59ec542aa8b..5744dfbd9110 100644
--- a/sys-devel/gcc-config/files/wrapper-1.4.6.c
+++ b/sys-devel/gcc-config/files/wrapper-1.4.6.c
@@ -1,7 +1,7 @@
/*
* Copyright 1999-2005 Gentoo Foundation
* Distributed under the terms of the GNU General Public License v2
- * $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/wrapper-1.4.6.c,v 1.2 2005/03/16 23:32:12 vapier Exp $
+ * $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/wrapper-1.4.6.c,v 1.3 2005/07/07 23:03:40 vapier Exp $
* Author: Martin Schlemmer <azarah@gentoo.org>
*/
@@ -353,6 +353,8 @@ int main(int argc, char *argv[])
/* cc calls "/full/path/to/gcc" ... */
if (!strcmp(data->name, "cc"))
strcpy(data->name, "gcc");
+ if (!strcmp(data->name, "f77"))
+ data->name[0] = 'g';
/* What is the full name of our wrapper? */
size = sizeof(data->fullname);
diff --git a/sys-devel/gcc-config/gcc-config-1.3.11-r4.ebuild b/sys-devel/gcc-config/gcc-config-1.3.11-r4.ebuild
new file mode 100644
index 000000000000..5997f38d7694
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.3.11-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.11-r4.ebuild,v 1.1 2005/07/07 23:03:40 vapier Exp $
+
+inherit toolchain-funcs
+
+# Version of .c wrapper to use
+W_VER="1.4.6"
+
+DESCRIPTION="Utility to change the gcc compiler being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh ~sparc x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_compile() {
+ $(tc-getCC) -O2 -Wall -o wrapper \
+ "${FILESDIR}"/wrapper-${W_VER}.c || die "compile wrapper"
+}
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die "install gcc-config"
+ dosed "s:PORTAGE-VERSION:${PVR}:" /usr/bin/${PN}
+
+ exeinto /usr/lib/misc
+ newexe wrapper gcc-config || die "install wrapper"
+}
+
+pkg_postinst() {
+ # Do we have a valid multi ver setup ?
+ if gcc-config --get-current-profile &>/dev/null ; then
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ [[ -L ${ROOT}/usr/include/g++ ]] && rm -f "${ROOT}"/usr/include/g++
+ [[ -L ${ROOT}/usr/include/g++-v3 ]] && rm -f "${ROOT}"/usr/include/g++-v3
+ [[ ${ROOT} = "/" ]] && gcc-config $(/usr/bin/gcc-config --get-current-profile)
+ fi
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config
+}