summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-11-13 15:44:36 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-11-13 15:44:36 +0000
commitda4088349662463d1adf9eb09f7d78219ab47aee (patch)
tree74dd2a5b669c39f81138e8bbb011688a8b7bf97e /sys-devel
parentPatch by Jaco Kroon adds subscribe context to SipShowPeers AMI command, close... (diff)
downloadgentoo-2-da4088349662463d1adf9eb09f7d78219ab47aee.tar.gz
gentoo-2-da4088349662463d1adf9eb09f7d78219ab47aee.tar.bz2
gentoo-2-da4088349662463d1adf9eb09f7d78219ab47aee.zip
added prefix support (bug #442928)
(Portage version: 2.2.0_alpha142/cvs/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/patch/ChangeLog7
-rw-r--r--sys-devel/patch/patch-2.7.1-r1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index c43d1d0bc4de..706e4f7c48ab 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/patch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.59 2012/09/28 22:16:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.60 2012/11/13 15:44:36 ottxor Exp $
+
+*patch-2.7.1-r1 (13 Nov 2012)
+
+ 13 Nov 2012; Christoph Junghans <ottxor@gentoo.org> +patch-2.7.1-r1.ebuild:
+ added prefix support (bug #442928)
*patch-2.7.1 (28 Sep 2012)
diff --git a/sys-devel/patch/patch-2.7.1-r1.ebuild b/sys-devel/patch/patch-2.7.1-r1.ebuild
new file mode 100644
index 000000000000..0f7c3ea1f532
--- /dev/null
+++ b/sys-devel/patch/patch-2.7.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.7.1-r1.ebuild,v 1.1 2012/11/13 15:44:36 ottxor Exp $
+
+EAPI=4
+
+inherit flag-o-matic unpacker
+
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+SRC_URI="mirror://gnu/patch/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static test xattr"
+
+RDEPEND="xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_enable xattr) \
+ --program-prefix="$(use userland_BSD && use !prefix && echo g)"
+}