summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-20 21:50:34 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-20 21:50:34 +0000
commitf664154180e05a6d21a6eaa2015a7e59a9156c81 (patch)
tree9d7f4c9a02289f57e7ac35519fdadbab42a2f0ab /sys-devel
parentalpha stable, bug 494822. (diff)
downloadgentoo-2-f664154180e05a6d21a6eaa2015a7e59a9156c81.tar.gz
gentoo-2-f664154180e05a6d21a6eaa2015a7e59a9156c81.tar.bz2
gentoo-2-f664154180e05a6d21a6eaa2015a7e59a9156c81.zip
Disable libxml2 support in non-native ABIs since it is meaningful for installed c-index-test only.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild8
2 files changed, 8 insertions, 6 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 49db9d1496ab..c1f70f80877f 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.154 2013/12/20 13:18:30 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.155 2013/12/20 21:50:34 mgorny Exp $
+
+ 20 Dec 2013; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
+ Disable libxml2 support in non-native ABIs since it is meaningful for
+ installed c-index-test only.
20 Dec 2013; Michał Górny <mgorny@gentoo.org>
+files/llvm-3.5-gentoo-install.patch, llvm-9999.ebuild:
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 8e3a0b3bee56..0688ba5ad4aa 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.68 2013/12/20 13:18:30 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.69 2013/12/20 21:50:34 mgorny Exp $
EAPI=5
@@ -21,8 +21,6 @@ KEYWORDS=""
IUSE="clang debug doc gold +libffi multitarget ncurses ocaml python
+static-analyzer test udis86 xml video_cards_radeon kernel_Darwin"
-# TODO: update libxml2 to multilib, bug #480404
-
COMMON_DEPEND="
sys-libs/zlib:0=
clang? (
@@ -197,8 +195,8 @@ multilib_src_configure() {
if use clang; then
conf_flags+=( --with-clang-resource-dir=../lib/clang/3.5 )
fi
- # well, it's used only by clang but easier to pass unconditionally
- if use xml; then
+ # well, it's used only by clang executable c-index-test
+ if multilib_build_binaries && use xml; then
conf_flags+=( XML2CONFIG="$(tc-getPKG_CONFIG) libxml-2.0" )
else
conf_flags+=( ac_cv_prog_XML2CONFIG="" )