summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-20 20:07:01 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-20 20:07:01 +0000
commitff68d6e1500f37eb846787f00dd136bc6ed5f8a4 (patch)
treecc055271cea0405a3a649984a3aef1f4e3440cc7 /sys-devel
parentremove old glibc mask (diff)
downloadgentoo-2-ff68d6e1500f37eb846787f00dd136bc6ed5f8a4.tar.gz
gentoo-2-ff68d6e1500f37eb846787f00dd136bc6ed5f8a4.tar.bz2
gentoo-2-ff68d6e1500f37eb846787f00dd136bc6ed5f8a4.zip
Fix by Diego Pettenò to make sure we use GNU m4 #123471.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/flex/ChangeLog6
-rw-r--r--sys-devel/flex/files/flex-2.5.31-gnu-m4.patch42
-rw-r--r--sys-devel/flex/flex-2.5.31-r2.ebuild3
3 files changed, 49 insertions, 2 deletions
diff --git a/sys-devel/flex/ChangeLog b/sys-devel/flex/ChangeLog
index 5a6de762d429..3e636bdd931c 100644
--- a/sys-devel/flex/ChangeLog
+++ b/sys-devel/flex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/flex
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/ChangeLog,v 1.39 2006/02/09 05:35:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/ChangeLog,v 1.40 2006/02/20 20:07:01 vapier Exp $
+
+ 20 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/flex-2.5.31-gnu-m4.patch, flex-2.5.31-r2.ebuild:
+ Fix by Diego Pettenò to make sure we use GNU m4 #123471.
*flex-2.5.31-r2 (09 Feb 2006)
diff --git a/sys-devel/flex/files/flex-2.5.31-gnu-m4.patch b/sys-devel/flex/files/flex-2.5.31-gnu-m4.patch
new file mode 100644
index 000000000000..8b27dcec41df
--- /dev/null
+++ b/sys-devel/flex/files/flex-2.5.31-gnu-m4.patch
@@ -0,0 +1,42 @@
+This is a simple hack to get flex to use GNU m4 on non-GNU systems.
+The issue has been fixed properly upstream already, we use this
+because it's much smaller.
+
+Patch by Diego Pettenò
+
+http://bugs.gentoo.org/123471
+
+
+--- flex-2.5.31/main.c
++++ flex-2.5.31/main.c
+@@ -344,7 +344,7 @@ void check_options ()
+
+ /* Setup the filter chain. */
+ output_chain = filter_create_int(NULL, filter_tee_header, headerfilename);
+- filter_create_ext(output_chain,"m4","-P",0);
++ filter_create_ext(output_chain,GM4_PROGRAM,"-P",0);
+ filter_create_int(output_chain, filter_fix_linedirs, NULL);
+
+ /* For debugging, only run the requested number of filters. */
+--- flex-2.5.31/Makefile.am
++++ flex-2.5.31/Makefile.am
+@@ -141,7 +141,7 @@ SUBDIRS = \
+ tests
+
+ localedir = $(datadir)/locale
+-AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
++AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl -DGM4_PROGRAM=\"@M4@\"
+ LIBS = @LIBINTL@ @LIBS@
+
+ skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
+--- flex-2.5.31/Makefile.in
++++ flex-2.5.31/Makefile.in
+@@ -290,7 +290,7 @@ SUBDIRS = \
+
+
+ localedir = $(datadir)/locale
+-AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
++AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl -DGM4_PROGRAM=\"@M4@\"
+
+ # Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
+ #
diff --git a/sys-devel/flex/flex-2.5.31-r2.ebuild b/sys-devel/flex/flex-2.5.31-r2.ebuild
index cade5d7d876e..fc121d2672a6 100644
--- a/sys-devel/flex/flex-2.5.31-r2.ebuild
+++ b/sys-devel/flex/flex-2.5.31-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/flex-2.5.31-r2.ebuild,v 1.1 2006/02/09 05:35:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/flex-2.5.31-r2.ebuild,v 1.2 2006/02/20 20:07:01 vapier Exp $
inherit eutils flag-o-matic
@@ -25,6 +25,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-include.patch
epatch "${FILESDIR}"/${P}-isatty.patch #119598
epatch "${FILESDIR}"/${P}-check-for-locale-header.patch #121920
+ epatch "${FILESDIR}"/${P}-gnu-m4.patch #123471
}
src_compile() {