summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-05-16 21:30:15 +0000
committerYixun Lan <dlan@gentoo.org>2014-05-16 21:30:15 +0000
commit102b6a6043b5ae97c9cb6c8f4782c7919cc46761 (patch)
treebf43c1ce94bcb4b4402c9ebe6797f77dd6341594 /sys-firmware
parentVersion bump (old stable branch). (diff)
downloadgentoo-2-102b6a6043b5ae97c9cb6c8f4782c7919cc46761.tar.gz
gentoo-2-102b6a6043b5ae97c9cb6c8f4782c7919cc46761.tar.bz2
gentoo-2-102b6a6043b5ae97c9cb6c8f4782c7919cc46761.zip
version bump, fix bug 510052, 510492
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/seabios/ChangeLog7
-rw-r--r--sys-firmware/seabios/seabios-1.7.4.ebuild106
2 files changed, 112 insertions, 1 deletions
diff --git a/sys-firmware/seabios/ChangeLog b/sys-firmware/seabios/ChangeLog
index 58193bb94b35..52c228a548f7 100644
--- a/sys-firmware/seabios/ChangeLog
+++ b/sys-firmware/seabios/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-firmware/seabios
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.29 2014/04/30 21:17:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.30 2014/05/16 21:30:15 dlan Exp $
+
+*seabios-1.7.4 (16 May 2014)
+
+ 16 May 2014; Yixun Lan <dlan@gentoo.org> +seabios-1.7.4.ebuild:
+ version bump, fix bug 510052, 510492
30 Apr 2014; Mike Frysinger <vapier@gentoo.org> seabios-1.7.3.ebuild,
seabios-1.7.3.2.ebuild:
diff --git a/sys-firmware/seabios/seabios-1.7.4.ebuild b/sys-firmware/seabios/seabios-1.7.4.ebuild
new file mode 100644
index 000000000000..acc4e941b584
--- /dev/null
+++ b/sys-firmware/seabios/seabios-1.7.4.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.4.ebuild,v 1.1 2014/05/16 21:30:15 dlan Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils toolchain-funcs python-any-r1
+
+#BACKPORTS=1
+
+# SeaBIOS maintainers sometimes don't release stable tarballs or stable
+# binaries to generate the stable tarball the following is necessary:
+# git clone git://git.seabios.org/seabios.git && cd seabios
+# git archive --output seabios-${PV}.tar.gz --prefix seabios-${PV}/ rel-${PV}
+
+if [[ ${PV} = *9999* || ! -z "${EGIT_COMMIT}" ]]; then
+ EGIT_REPO_URI="git://git.seabios.org/seabios.git"
+ inherit git-2
+else
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+ SRC_URI="http://code.coreboot.org/p/seabios/downloads/get/${P}.tar.gz
+ http://code.coreboot.org/p/seabios/downloads/get/bios.bin-${PV}.gz
+ http://dev.gentoo.org/~cardoe/distfiles/${P}.tar.gz
+ http://dev.gentoo.org/~cardoe/distfiles/bios.bin-${PV}.gz
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
+fi
+
+DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
+HOMEPAGE="http://www.seabios.org"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+IUSE="+binary"
+
+REQUIRED_USE="ppc? ( binary )
+ ppc64? ( binary )"
+
+DEPEND="
+ !binary? (
+ >=sys-power/iasl-20060912
+ ${PYTHON_DEPS}
+ )"
+RDEPEND=""
+
+pkg_pretend() {
+ if ! use binary; then
+ ewarn "You have decided to compile your own SeaBIOS. This is not"
+ ewarn "supported by upstream unless you use their recommended"
+ ewarn "toolchain (which you are not)."
+ elog
+ ewarn "If you are intending to use this build with QEMU, realize"
+ ewarn "you will not receive any support if you have compiled your"
+ ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
+ ewarn "in SeaBIOS."
+ fi
+
+ local myld=$(tc-getLD)
+
+ ${myld} -v | grep -q "GNU gold" && \
+ ewarn "gold linker unable to handle 16-bit code using ld.bfd. bug #438058"
+}
+
+pkg_setup() {
+ use binary || python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ if [[ -z "${EGIT_COMMIT}" ]]; then
+ sed -e "s/VERSION=.*/VERSION=${PV}/" \
+ -i "${S}/Makefile"
+ else
+ sed -e "s/VERSION=.*/VERSION=${PV}_pre${EGIT_COMMIT}/" \
+ -i "${S}/Makefile"
+ fi
+
+ epatch_user
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ if ! use binary ; then
+ LANG=C emake \
+ CC=$(tc-getCC) \
+ LD="$(tc-getLD).bfd" \
+ AR=$(tc-getAR) \
+ OBJCOPY=$(tc-getOBJCOPY) \
+ RANLIB=$(tc-getRANLIB) \
+ OBJDUMP=$(tc-getPROG OBJDUMP objdump) \
+ HOST_CC=$(tc-getBUILD_CC) \
+ out/bios.bin
+ fi
+}
+
+src_install() {
+ insinto /usr/share/seabios
+ if ! use binary ; then
+ doins out/bios.bin
+ else
+ newins ../bios.bin-${PV} bios.bin
+ fi
+}