summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-07-06 05:42:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-07-06 05:42:56 +0000
commit05627b993ce5ad481f2b65e4f9f42a27167edee3 (patch)
tree722731bc29c0e4da8b5c79b1c68f225dd7dddd31 /sys-freebsd/boot0/boot0-8.2.ebuild
parentbe a bit more restrictive on how to math libl so that it doesnt match liblzma (diff)
downloadgentoo-2-05627b993ce5ad481f2b65e4f9f42a27167edee3.tar.gz
gentoo-2-05627b993ce5ad481f2b65e4f9f42a27167edee3.tar.bz2
gentoo-2-05627b993ce5ad481f2b65e4f9f42a27167edee3.zip
bump to 8.2
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd/boot0/boot0-8.2.ebuild')
-rw-r--r--sys-freebsd/boot0/boot0-8.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-freebsd/boot0/boot0-8.2.ebuild b/sys-freebsd/boot0/boot0-8.2.ebuild
new file mode 100644
index 000000000000..e727c6ec0cb3
--- /dev/null
+++ b/sys-freebsd/boot0/boot0-8.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-8.2.ebuild,v 1.1 2011/07/06 05:42:56 aballier Exp $
+
+EAPI=2
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="FreeBSD's bootloader"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+
+IUSE="bzip2 ieee1394 tftp zfs"
+
+SRC_URI="mirror://gentoo/${SYS}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-mk-defs-${RV}*
+ =sys-freebsd/freebsd-lib-${RV}*"
+
+S="${WORKDIR}/sys/boot"
+
+boot0_use_enable() {
+ use ${1} && mymakeopts="${mymakeopts} LOADER_${2}_SUPPORT=\"yes\""
+}
+
+pkg_setup() {
+ boot0_use_enable ieee1394 FIREWIRE
+ boot0_use_enable zfs ZFS
+ boot0_use_enable tftp TFTP
+ boot0_use_enable bzip2 BZIP2
+}
+
+src_prepare() {
+ sed -e '/-fomit-frame-pointer/d' -e '/-mno-align-long-strings/d' \
+ -i "${S}"/i386/boot2/Makefile \
+ -i "${S}"/i386/gptboot/Makefile \
+ -i "${S}"/i386/gptzfsboot/Makefile \
+ -i "${S}"/i386/zfsboot/Makefile || die
+}
+
+src_compile() {
+ strip-flags
+ append-flags "-I/usr/include/libstand/"
+ append-flags "-fno-strict-aliasing"
+ NOFLAGSTRIP="yes" freebsd_src_compile
+}
+
+src_install() {
+ dodir /boot/defaults
+ mkinstall FILESDIR=/boot || die "mkinstall failed"
+}